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This guide explains how to get started with Pix4Dmapper. It shows the needed steps before using Pix4D to obtain good data to achieve the best results, how to
create a project and how to start processing it. It also shows how to get started with advanced features such as using Ground Control Points. Offline version of the
Getting Started and User Manual: pdf.

System Requirements
Software Download and Installation
Step 1. Before Starting a Project
1. Designing the Image Acquisition Plan
a. Selecting the Images Acquisition Plan Type
b. Computing the Flight Height for a Given GSD
c. Computing the Image Rate for a Given Frontal Overlap
2. Configuring the Camera Settings
3. Georeferencing the Images (optional but recommended)
4. Getting GCPs in the Field or Through Other Sources (optional)
Step 2. Creating a Project
1. Creating a New Project
2. Importing the Images
3. Configuring the Image Properties
a. Selecting Image Coordinate System (optional)
b. Importing Images Geolocation and Orientation (optional)
c. Editing Camera Model (optional)
4. Selecting the Output / GCP Coordinate System
5. Selecting the Processing Options Template
Step 3. Before Processing (optional)
1. Selecting the Processing Area (optional)
2. Changing the Processing Options Template and /or the Process Options (optional)
3. Adding GCPs (optional)
Step 4. Processing 
1. Initial Processing
2. Analyzing the Quality Report
3. Point Cloud and Mesh
4. DSM, Orthomosaic and Index
Step 5. After Processing (optional)

 

Additionally, there are some recommended articles to consult in order to fulfill some specific actions with the software:

Navigating in the Support Site
Pix4Dmapper Product Editions - Comparison Table
Features Description
How to buy Pix4Dmapper

News and Updates

Using GCPs
Using the rayCloud
Using the Volumes
Using the Mosaic Editor
Using the Index Calculator 
Using Pix4Dmapper Output Files in Other Software

Processing Large Datasets
Merging Projects
Uploading Project Files to Pix4D Cloud
Input Files
Quality Report Help
Output Files

Project Folder Structure

Pix4Dmapper's Software Manual describes every feature in detail:

Pix4Dmapper Software Manual
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https://support.pix4d.com/hc/en-us/articles/202558649
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The following description shows the minimum and recommended Hardware and Software requirements:

 

Minimum:

Windows 7, 8, 10, Server 2008, Server 2012, 64 bits  (PC or Mac computers using Boot Camp).
Any CPU (Intel i5/ i7/ Xeon recommended).
Any GPU that is compatible with OpenGL 3.2. (integrated graphic cards Intel HD 4000 or above).
Small projects (under 100 images at 14 MP): 4 GB RAM, 10 GB HDD Free Space.
Medium projects (between 100 and 500 images at 14 MP): 8 GB RAM, 20 GB HDD Free Space.
Large projects (between 500 and 2000 images at 14 MP): 16 GB RAM, 40 GB HDD Free Space.
Very Large projects (over 2000 images at 14 MP): 16 GB RAM, 80 GB HDD Free Space.

Important: Unusually long times have been observed when processing with some Quadro GPU. This is related to some settings in the NVIDIA control
panel. For more information: 218195063. 

Recommended:

Windows 8, 10 64 bits.
CPU quad-core or hexa-core Intel i7/Xeon.
GeForce GPU compatible with OpenGL 3.2 and 2 GB RAM.
Hard disk: SSD.
Small projects (under 100 images at 14 MP): 8 GB RAM, 15 GB SSD Free Space.
Medium projects (between 100 and 500 images at 14 MP): 16GB RAM, 30 GB SSD Free Space.
Large projects (over 500 images at 14 MP): 32 GB RAM, 60 GB SSD Free Space.
Very Large projects (over 2000 images at 14 MP): 64 GB RAM, 120 GB SSD Free Space.

Information:  
An SSD hard drive can speed up processing. 
The graphic card may have an improvement on the processing speed for step 1 and step 2 (if the graphic card is compatible with CUDA (NVIDIA Graphic
Cards). Processing time of step 3 is not affected by the GPU. The GPU affects considerably the visualization of the rayCloud. For more information about
the use of the GPU: 203405619.
For more information about Hardware components usage when processing with Pix4Dmapper: 202559519.
For more information regarding: Mac / Windows XP / Linux / Remote Access - Virtual machine / Distributed - Parallel processing: 202556809.
For more information about processing speed: 204191535.
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Important: Internet connection is required to download and install the software.

Download the software following:

1. Go to: https://cloud.pix4d.com/download/.
2. Under the section Pix4Dmapper click Download.

Once the software has been downloaded, install it using the following steps:

1. Double click the downloaded file. The Pix4Dmapper Setup wizard starts.
2. (optional): If the Open file - Security Warning pop-up appears, click Run.

3. In the Pix4Dmapper Setup pop-up, in the Welcome to the Pix4Dmapper Setup Wizard screen, click Next >.
4. (optional) Click Browse... to change the destination path for the installation and click Next >.

5. Click Install.

 

https://cloud.pix4d.com/download/
https://mapper.pix4d.com/


6. (optional) In the software information window: "Do you want to allow the following program to install software on this computer?", Click Yes.
7. Click Finish.
8. A shortcut is created on your desktop and the software opens automatically once the installation is completed.

9. The first time the software opens, the Pix4Ddesktop Login window appears:
(If a proxy server is used to connect to internet, click Proxy... and follow these instructions: 202560089)

  

 10. Type the Email and Password of the account and click Login. 

Note: If you do not have an account: 
1. Click Sign up now. 
2. Complete the online form. 
3. A confirmation email will be sent to activate the account. Open the email and click Confirm my email. 
4. Go back to the Pix4Ddesktop Login window, type the Email and Password and click Login. 

11. Read the End-User License Agreement, select "I accept the terms in the License Agreement" and click Next.

 

https://support.pix4d.com/hc/en-us/articles/202560089


12. Select:

Request Pix4Dmapper Pro now (Free Trial) to activate a 15-day trial.
Use Pix4Ddiscovery, to activate the limited version. For more information: 202559479.

13. Click OK.

 Pix4D Desktop is now ready for processing!

Note: When a new version of Pix4D Desktop is available, an update message will appear: 210661706. 
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Warning: A dataset of insufficient quality will lead to poor results or may even lead to processing failure. This requires taking a new dataset on the field.

The dataset (compulsory: images, optional but recommended: images geolocation and Ground Control Points (GCPs)) have to be obtained on the field before
using Pix4Dmapper. A good dataset is required in order to automatically produce results with high quality and accuracy. In order to take a good dataset, follow
the steps below:

1. Designing the Images Acquisition Plan: It is very important to design a good images acquisition plan considering:

Type of project (aerial, terrestrial, mixed).
Type of terrain / object.
Type of camera.
Purpose of the project.
Image rate that the images are taken.
Distance (flight height) at which the images are taken and with which angle to take the images.
Path(s) to follow to take the images.
etc.

For aerial projects, this also implies:

Selecting corridor path or regular grid and/or circular grid.
Deciding whether terrestrial images will be used.
If more than one flights are needed to cover the full area: designing the area to cover with each flight.

2. Configuring the Camera Settings: The camera settings used to acquire the images need to be configured. Wrong configuration can result in images with
blur, noise, distortions, etc.

3. Georeferencing the Images (optional but recommended): The images can be georeferenced using a camera with built-in GPS or using external GPS
devices.

4. Getting GCPs on the field or through other sources (optional but recommended): Using GCPs (Ground Control Points) requires planning how many GCPs
have to be acquired, as well as where and how they have to be measured.

 

Index  Previous  |  Next  

 



Index > Step 1. Before Starting a Project  Previous  |  Next  

 

In order to automatically get high accuracy results, a high overlap between the images is required. Therefore, the image acquisition plan has to be carefully
designed in order to have enough overlap. The image acquisition plan depends on the required GSD by the project specifications and the terrain type / object to be
reconstructed. A bad image acquisition plan will lead to inaccurate results or processing failure and will require to acquire images again.

When designing the image acquisition plan the following factors need to be taken into consideration:

Image acquisition plan type: The image acquisition plan type depends on the type of terrain / object to be reconstructed.
Ground Sampling Distance (GSD): The required GSD by the project specifications will define the distance (flight height) at which the images have to be taken.
Overlap: The overlap depends on the type of terrain that is mapped and will determine the rate at which the images have to be taken.

Nowadays, technologically advanced UAVs come with very good software that can design the image acquisition plan given some parameters (area of interest, the
percentage of overlap between the images, the desired GSD, etc). In this case, the images are taken automatically by the UAV according to the selected images
acquisition plan without any user intervention.

Important: Pix4Dmapper allows the user to process using a Processing Template. The templates with the label Rapid/Low Res produce fast results at
low resolution that can be used on the field as an indicator of how good the dataset is.

If the Rapid/Low Res processing does not yield to good results, very probably, the dataset is not adequate and it is necessary to acquire images again.
In some cases, the Rapid/Low Res option fails while the Full processing successfully reconstructs the model. 

For more information about the difference between Rapid/Low Res and Full processing: 202558949.

The design of the image acquisition plan consists of 3 steps:

a. Selecting the Image Acquisition Plan Type
b. Computing the Flight Height for a given GSD
c. Computing the Image Rate for a given Frontal Overlap
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Pix4Dmapper is an image processing software that is based on automatically finding thousands of common points between images. Each characteristic point
found in an image is called a keypoint. When 2 keypoints on 2 different images are found to be the same, they are matched keypoints. Each group of
correctly matched keypoints will generate one 3D point. When there is high overlap between 2 images, the common area captured is larger and more keypoints
can be matched together. The more keypoints there are, the more accurately 3D points can be computed. Therefore, the main rule is to maintain high overlap
between the images.

As the image acquisition plan has a high impact on the quality of the results, it is important to design it carefully.

Important: Pix4Dmapper allows the user to process using a Processing Template. The templates with the label Rapid/Low Res produce fast results at
low resolution that can be used on the field as an indicator of how good the dataset is.

If the Rapid/Low Res processing does not yield to good results, very probably, the dataset is not adequate and it is necessary to acquire images
again. In some cases, the Rapid/Low Res option fails while the Full processing successfully reconstructs the model.

For more information about the difference between Rapid/Low Res and Full processing: 202558949.

 

Ideal image acquisition plan

The ideal image acquisition plan depends on the type of terrain / object to be reconstructed.:

General case: For projects that do not include forests, snow, lakes, agricultural fields and/or other terrain that is difficult to reconstruct.
Forest and dense vegetation: For project with areas covered by forest or dense vegetation.
Flat terrain with agriculture fields: For flat terrain with homogeneous visual content such as agriculture fields.
Building reconstruction: For 3D modelling of buildings.
Special cases: For snow, sand, and water surfaces (oceans, lakes, rivers, etc).
Corridor mapping: For projects with linear area of interest (roads, rivers, etc).
Multiple flights: For projects with images taken using multiple flights.
City reconstruction (visible facades): For 3D modelling of urban areas.
3D interior reconstruction: For 3D modelling of the interior of buildings.
Mixed reconstruction: For combined datasets (interior/exterior and/or aerial/terrestrial and/or nadir/oblique).
Large Vertical Objects reconstruction: For 3D modelling of objects like power towers, wind turbines, etc.
Tunnel reconstruction: For 3D modelling of a tunnel.
Small objects: For 3D modelling of small objects. 

Important: Below it is described the recommended different image acquisition paths and overlap for different cases, despite it may work with lower overlap
than the suggested ones, in order to obtain the best possible results, it is suggested to use the recommended overlaps.

General case 

The recommended overlap for most cases is at least 75% frontal overlap (with respect to the flight direction) and at least 60% side overlap (between flying tracks).
It is recommended to take the images with a regular grid pattern (Figure 1). The camera should be maintained as much possible at a constant height over the
terrain / object to ensure the desired GSD.

Figure 1. Ideal Image Acquisition Plan - General case.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558949
https://support.pix4d.com/hc/en-us/articles/218022823


Forest and dense vegetation

Trees and dense vegetation often have a very different appearance between overlapping images due to their complex geometry (thousands of branches and
leaves). Therefore, it is difficult to extract common characteristic points (keypoints) between the images. In order to achieve good results, it is recommended to
use a grid image acquisition plan as the one described in the General Case section by applying the following changes:

Increase the overlap between images to at least 85% frontal overlap and at least 70% side overlap.
Increase the flight height: At higher altitude, there is less perspective distortion (therefore causing less appearance problems) and the dense vegetation has
better visual properties. In other words, it is easier to detect visual similarities between overlapping images in such areas. The flight height in combination
with the image pixel resolution and the focal length determine the Ground Sampling Distance (spatial resolution) of the images. Best results are obtained
with a GSD higher than 10cm/pixel.

For more information about how to improve the results of dense vegetation areas selecting the correct processing options: 202560159.

 

Flat terrain with agriculture fields

In cases where the terrain is flat with homogeneous visual content such as agriculture fields, it is difficult to extract common characteristic points (keypoints)
between the images. In order to achieve good results, it is recommended to use a grid image acquisition plan as the one described in the General Case section
by applying the following changes:

Increase the overlap between images to at least 85% frontal overlap and at least 70% side overlap.
Fly higher. In most cases, flying higher improves the results.
Have accurate image geolocation and use the Agriculture template. For more information about the Agriculture (Ag) template: 205319155.

 

Building reconstruction

Reconstructing 3D buildings requires a specific image acquisition plan (Figure 2):

Fly around the building a first time with a 45° camera angle.
Fly a second and third time around the building increasing the flight height and decreasing the camera angle with each round. 

Note: For more information about oblique imagery: 202559859.

It is recommended to take one image every 5-10 degrees to ensure enough overlap, depending on the size of the object and distance to it. Shorter distance
and larger objects require images every less degrees.

Note: 
The flight height should not be increased more than twice  between the flights, as different heights lead to different spatial resolution. For
more information: 202558979.
Pix4Dmapper generates a high quality point cloud for oblique images of buildings. However, no orthomosaic is generated, when the selected template is
3D Models: 205319155.

Important: By default, Pix4Dmapper generates orthomosaics that are parallel to the (X,Y) plane. Therefore, to generate mosaics of facades, the
Orthoplane tool needs to be used. For more information: 202559889.

Figure 2. Ideal Image Acquisition Plan - Building.
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Note: It is possible to combine aerial nadir and/or aerial oblique and/or terrestrial images.

The images should have enough overlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie
Points to properly adjust the different sets of images. For more information: 202561599

 

Special cases

This section presents some hints for terrain that is difficult to map such as terrains with snow, sand, lakes, etc.

Snow and sand
Snow and sand have little visual content due to large uniform areas. Therefore: 

Use a high overlap: At least 85% frontal overlap and at least 70% side overlap.
Set the exposure settings accordingly to get as much contrast as possible in each image.
Water
Water surfaces have almost no visual content due to large uniform areas. Sun reflection on the water and waves cannot be used for visual matching.

Oceans are impossible to reconstruct.
To reconstruct other water surfaces such as rivers or lakes, each image needs to have land features. Flying higher may help to include more land features.

 

Corridor mapping

Mapping corridors such as railways, roads or rivers requires at least 2 flight lines (Figure 3). GCPs are not required, but are recommended to improve the
georeference and accuracy of the reconstruction. For more information about the number and distribution of GCPs in corridor mapping: 202559299.

For a dual track it is recommended to use at least 85% frontal overlap and at least 60% side overlap.

It is possible to use nadir images or oblique images (with an angle between 0º and 45º pointing in both tracks to the center of the corridor). For flat terrain it is
recommended to use nadir images. 

Figure 3. Dual track image acquisition plan for corridor mapping.

 

If a dual track image acquisition plan is not possible, a single track image acquisition plan can be used if (Figure 4):

Overlap is high enough: At least 85% frontal overlap.
Ground control points (GCPs) are defined along the flight line in zig zag.

Figure 4. Single track flight NOT RECOMMENDED.

Multiple flights

Pix4Dmapper can process images taken from multiple flights. When designing the different image acquisition plans, make sure that:

Each plan captures the images with enough overlap.
There is enough overlap between 2 image acquisition plans (Figures 5 and 6).
The different plans are taken as much as possible under the same conditions (sun direction, weather conditions, no new buildings, etc.).

Important: The flight height should not be too different between the flights, as different height leads to different spatial resolution. For more information:
202558979.

There is a special way to process datasets taken from multiple flights, for step by step instructions: 202558579.

 

 

https://support.pix4d.com/hc/en-us/articles/202561599
https://support.pix4d.com/hc/en-us/articles/202559299
https://support.pix4d.com/hc/en-us/articles/202558979
https://support.pix4d.com/hc/en-us/articles/202558579


Enough overlap between 2 flights Not enough overlap between 2 flights
Figure 5. Overlap between 2 flights.

 

Figure 6. Recommended image acquisition plan for 2 flights.

 

City reconstruction (visible facades)

The 3D reconstruction of urban areas requires a double grid image acquisition plan, so that all the facades of the buildings (north, west, south, east) are visible on
the images. The overlap should be the same as in the General Case.

Figure 7. Double grid image acquisition plan.



For the facades to be visible, the images should be taken with an angle between 10º and 35º, (for more information about the definition of the
angles: 202559859) and not pointing to the nadir. If much detail is needed, aerial and terrestrial images should be combined.

Note: It is possible to combine aerial nadir and/or aerial oblique and/or terrestrial images.

The images should have enough overlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie
Points to properly adjust the different sets of images. For more information: 202561599.

 

3D Interior reconstruction

For interior reconstruction, it is strongly recommended to use terrestrial images. High overlap is needed (90%). Therefore, it is recommended to use a fisheye lens
camera.

Manual Tie Points improve the reconstruction and help to properly adjust the model. For more information: 202970309.

 

Mixed reconstruction

It is possible to combine interior/exterior and/or aerial/terrestrial and /or nadir/oblique. Any combination is possible.

The images should have enough overlap in each dataset and between datasets. For such cases it is strongly recommended to use GCPs or Manual Tie Points to
properly adjust the different sets of images. For more information: 202561599.

 

Large Vertical Objects reconstruction

The 3D reconstruction of objects like power towers, wind turbines etc requires a specific image acquisition plan (figure 8):

Fly close to the structure.
Turn several times around the structure at several heights.
Images should be taken with high overlap: 90% of overlap between images taken at the same height and 60% of overlap between images taken at different
heights. 
The optimal camera angle for the top circle is 45 degrees. By pointing to the ground, the content of the images is easier to be matched and the results are better.
The images should be as focused as possible (both the main object and the background should be focused).
Having image geolocation is recommended. For more information about the image geolocation: 202557499.

 

  

Power Tower Power Tower reconstructed in the rayCloud
Figure 8. Image Acquisition Plan - Power tower.

 

Note: For more information on how to map and measure pole and tower structures: 202560479.  

 

Tunnel reconstruction

Pix4Dmapper can reconstruct tunnels. The biggest challenge for tunnel reconstruction is the lighting conditions. If the lighting is good either with natural light (if
the tunnel is not too long) or with artificial light, the reconstruction could be very good.

 

 

https://support.pix4d.com/hc/en-us/articles/202559859
https://support.pix4d.com/hc/en-us/articles/202561599
https://support.pix4d.com/hc/en-us/articles/202970309
https://support.pix4d.com/hc/en-us/articles/202561599
https://support.pix4d.com/hc/en-us/articles/202560479


In case of very dark tunnels, a tripod is recommended.

Tip: It is recommended to: 
Use fisheye lens camera.
Take images in more than one line (avoid single track shooting). If a multiple tracks image acquisition plan is not possible, a single track could work.
GCPs are highly recommended in this case.

 

 

 

Figure 9. Automatic Tie Points of a tunnel.
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The Ground Sampling Distance (GSD) is the distance between the center of two consecutive pixels on the ground. It influences the accuracy and the quality of
the final results as well as the details that are visible in the final Orthomosaic. 

 

The flight height H that is needed to obtain a given GSD can be computed and depends on the camera focal length, the camera sensor width [mm], and the image
width [pixels].

Sw = real sensor width [mm]

FR = real focal length [mm]

H = flight height [m]

Dw = distance covered on the ground by one image in the width direction (footprint width) [m]

 

Some lens manufacturers give the focal length (F35) in the 35 mm equivalent. It is not the 35 mm equivalent but the real focal length that should be used in
Pix4Dmapper. In order to find the real focal length, some computations are needed. In the case of a 4:3 ratio, the formula for the real focal length FR is given by:

FR [mm] = (F35 * SW) / 34.6     (1)

Where

F35 = focal length that corresponds to the 35 mm equivalent

FR = real focal length

Sw = the real sensor width

For more information about the 35mm equivalent focal length concept: Wikipedia article.

Using the fact that 

H / FR = DW / SW,

the flight height H is given by:

H = (DW * FR) / SW .     (2)

The distance covered on the ground by one image in the width direction (footprint width) is given:

DW = (imW * GSD) / 100.     (3)

where

DW = distance covered on the ground by one image [m] in the width direction (footprint width)

imW = image width [pixel]

GSD = desired GSD [cm/pixel]

Combining equation (2) and (3), the flight height is given by:

H [m] = (imW * GSD * FR) / (SW * 100)     (4)

Note: The result is given in [m], considering that the GSD is in [cm/pixel].

Example: Computation of the flight height to get a GSD of 5 [cm/pixel] using a camera with a real focal length of 5 [mm] and a real sensor width of 6.17
[mm]. Assuming that the image width is 4000 [pixels] and using the equation (4), the flight height should be 162 [m].

H = (imW * GSD*  FR ) / (Sw * 100) = (4000 * 5 * 5) / (6.17 * 100) = 162.07 [m]

Tools: The GSD Calculator can be found here: 202560249.

 

 

 

 

 

https://en.wikipedia.org/wiki/35_mm_equivalent_focal_length
https://support.pix4d.com/hc/en-us/articles/202560249
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The image shooting rate to achieve a given frontal overlap depends on the speed of the UAV/plane, the GSD and the pixel resolution of the camera.

D = distance covered on the ground by one image in the flight direction [m]

overlap = percentage of desired frontal overlap between two images

od = overlap between two images in the flight direction [m]

x = distance between two camera positions in the flight direction [m]  

v = flight speed [m/s]

t = elapsed time between two images (image rate) [s]

Figure 1.

From Figure 1, we obtain the following equations:

od = overlap * D      (1)

x = D - od                (2)

t = x / v                   (3)

 

Two cases are possible:

Camera oriented with the sensor width (long dimension) perpendicular to the flight direction (usual case)
Camera oriented with the sensor width (long dimension) parallel to the flight direction

Camera oriented with the sensor width (long dimension) perpendicular to the flight direction (usual case)

D = Dh = (imH * GSD) / 100     (4)

Where: 

Dh = distance covered on the ground by one image in the height direction
(footprint height) [m]

imH = image height [pixel]

GSD = desired GSD [cm/pixel]

 

Figure 2. Sensor width placed perpendicular to the flight direction.

Combining Equations (1) and (4) into Equation (2):

x = Dh - overlap * Dh

x = Dh * (1 - overlap)

x =  ((imH* GSD) / 100) * (1 - overlap)     (5)

Note: x is given in [m], considering that the GSD is in [cm/pixel].

Combining the equations (3) and (5):

t = x / v = ((imH * GSD) / 100) * (1 - overlap) / v     (6)

Example: In order to achieve an overlap of 75% (overlap = 0.75) and a GSD of 5 [cm/pixel], supposing that the image height is 4000 [pixels] and the
speed of the UAV/plane is 30 [km/h] = 8.33 [m/s], based on the equation (6), the image rate should be 6 seconds: 

t = ((imH * GSD) / 100) * (1 - overlap) / v = ((4000 * 5 ) / 100)  * (1 - 0.75) / 8.33 = 6 [s] 

 

Camera oriented with the sensor width (long dimension) parallel to the flight direction

If the camera is placed on the plane / UAV having the sensor width (long dimension) parallel to the flight direction:

 

 



D = DW = (imW * GSD) / 100     (7)

Where: 

DW = distance covered on the ground by one image in the width direction
(footprint width) [m]

imW = image width [pixel]

GSD = desired GSD [cm/pixel]

Figure 3. Sensor width placed parallel to the flight direction.

 

Combining equations (1) and (7) into the equation (2):

x = DW - overlap * DW

x = DW * (1 - overlap)

x =  ((imW * GSD) / 100) * (1 - overlap)     (8)

Note: The result is given in [m], considering that the GSD is in [cm/pixel].

Combining equations (3) and (8):

t = x / v = ((imW * GSD) / 100) * (1 - overlap) / v     (9)
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Pix4Dmapper is able to process images taken with any camera:

Lightweight compact cameras.
DSLR cameras.
Large format cameras.
Action cameras.
Camera Rigs.
360 ° panorama cameras.

Compact DSLR Large format Action Rig 360 ° panorama

Using any lens:

Perspective (narrow and wide focal length).
Ultra wide focal length (Fisheye).

The cameras can be loaded on any platform:

UAVs from the hobby world.
Professional UAVs.
Manned aircrafts.
Helicopters.
Terrestrial vehicles.
No platform, for terrestrial imagery (taken by hand).

Pix4Dmapper can process images regardless of the spectral specifications of the camera:

RGB cameras.
NIR, Red Edge cameras for agriculture applications.
Thermal cameras: 20275534.
etc.

 

Summary 

Camera body and lens
Perspective and fisheye lens supported.
The zoom should be stable.
Fixed focal length is recommended.
Video frames are not recommended due to low pixel resolution.

Camera settings
Stabilization settings should be off.
Shutter/aperture/ISO should be on automatic.
If images are blurry or noisy, manually set shutter/aperture/ISO. For more
information: Camera settings.
Select Manual Focus on Infinity.

 

Camera Body 

As a rule of thumb: Heavier cameras (higher pixel resolution) provide better results but require a flying platform with a higher payload.

 

Recommended Cameras

Camera Type Recommendation Tips
Compact Canon IXUS 220HS (135 g)

Sony RX 100 (240 g)
Let parameters on automatic and disable image stabilization.

DSLR Sony Nex 5/7 (270 g - 350 g) Canon
5D mark ii (>800 g)

Use a fixed focal length lens to improve the results.

Action GoPro Hero 4 Recommended for close range imagery (up to 50 meters). Take the images with the widest angle and
highest resolution possible.

 

Video cameras

https://support.pix4d.com/hc/en-us/articles/202755349


Videos are not recommended for accurate mapping: The quality of the results will almost always be inferior to the results from still imagery. 
4K video from camera such as GoPro 4 and DJI provides reasonable results.
Full HD video is usually not sufficient to get good results.
When using a video for processing, it is important to consider the following: 205294735.

  

Recommended Camera Focal Length

There is no limit in the focal length that can be used with Pix4Dmapper.

Application Recommendation Why
Mapping: aerial project with a flight
height above 50 meters.

Perspective lens: between 22 mm and 80 mm focal length (in
35 mm equivalent). 

To ensure a good GSD that will lead to higher accuracy
results.

Indoor / close range reconstruction. Fisheye lens: very small focal length. Flexibility in data acquisition: Ensuring higher overlap.

 

Most lens manufacturers give the focal length (F35) that corresponds to 35 mm equivalent. In order to find the real focal length:

FR = (F35 * SwR) / 34.6 (mm) 

where:

F35 = focal length that corresponds to 35 mm equivalent [mm]
FR = real focal length [mm]
SwR = the real sensor width [mm]

For a given height, the wider the field of view (small focal length), the fewer the images to achieve sufficient overlap. This is especially useful if a regular and dense
flight plan cannot be setup.  The spatial resolution, though, will be low leading to less accurate results.

If the field of view is narrow (large focal length), more images will be required to ensure enough overlap when mapping the same area. The spatial resolution will be
higher in this case, leading to more accurate results.

For more information about how to select camera focal length and flight altitude considering the desired spatial resolution (GSD) and the area to map: 202558849.

Tip: Use a fixed focal length lens, as it will usually result in sharper images with reduced noise.

 

Camera Settings

The shutter speed, aperture and ISO should be set on automatic. If images are blurry or noisy, it is recommended to manually set these parameters.

There is a tradeoff between the shutter speed, the aperture, and the ISO sensitivity. For processing, the images should be sharp and have the least amount of
noise. Such images can be obtained when the scene is well illuminated (scattered clouds should be avoided) and the camera parameters are well adjusted. If the
scene is not sufficiently illuminated, images will be noisier and less sharp, thus lowering the accuracy of the results.

As a rule of thumb, the shutter speed should be fixed, the ISO needs to be set at a low value that does not produce noisy images, and the aperture should be set
to automatic to adjust for varying levels of brightness in the scene. If the tradeoff is not correct, overexposed or underexposed images may be obtained.

The shutter speed should be fixed and set to a medium speed (as an indication: between 1/300 second and 1/800 second), but fast enough to not produce blurry
images. If more than 5% of the images are subject to a directional blur, it is a good indication that the shutter speed should be slightly increased.

The ISO should be set as low as possible (minimum 100). High ISO settings generally introduce noise into images and drastically reduce the quality of
the results.

The aperture minimum and maximum values depend on the lens. High aperture is translated into low numbers, for example f2.7 (which will capture a lot of light). If
both the shutter speed and ISO are adjusted, it is better to leave the aperture (f) on automatic.
The electronic and mechanical stabilization should be disabled as it interferes with Pix4Dmapper's algorithms.

The recommended focus mode is Manual Focus on Infinity. This mode of focusing should always give focused images for aerial projects. For terrestrial projects,
this mode will probably lead to out of focus results, if a long focal length is used.

Tip: For terrestrial projects it is recommended to use a wide angle lens.

Problems with images due to wrong camera parameters or inadequate equipment that interfere with the processing:

 

 

https://support.pix4d.com/hc/en-us/articles/205294735
https://support.pix4d.com/hc/en-us/articles/202558849


Blur due to slow shutter speed. Noise due to high ISO sensitivity. Overexposed
or
underexposed
(wrong
aperture and/or
shutter speed).

Distortions
due
to electronic
or
mechanical
image
stabilization.

Distortions due to
the rolling shutter.
Pix4Mapper
models the rolling
shutter improving
the
results:202558159. 
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>> Skip this step if no Georeferencing will be used for the images <<

Pix4Dmapper can process images both with and without geolocation. However, it is strongly recommended to know the position of the camera for at least 80% of
the images to get high quality and faster results. Pix4Dmapper does not require the IMU parameters. Orientation parameters are computed during the
processing. 

Images without geolocation
Images with known position using a camera with built-in GPS tagging
Images with known position using an external GPS logger

Images without geolocation

Pix4Dmapper can process images without geolocation. When images have no geolocation, Pix4Dmapper needs additional information to locate, scale and orient
correctly the model. Ground Control Points (202557489) will place the model at the correct location, scale and orient it. If no GCPs are used, then the scale
(205360375) and orientation (205360385) constraints can be used. 

Warning: If neither GCPs nor constraints are used, the final results have no scale, orientation and absolute position information. Therefore, they cannot
be used for measurements, overlay and comparison with previous results. Besides, they may produce an inverted 3D model in the rayCloud.

 

Images with known position using a camera with built-in GPS tagging

Most of the major manufacturers push their weight behind GPS tagging; Panasonic, Sony, and Canon are some well known camera manufacturers that have
released such cameras so far. Most of these cameras save the GPS coordinates in the images' EXIF data. Pix4Dmapper reads this information from the EXIF
data in order to automatically import the image geolocation into the software. For more information about the EXIF information read by Pix4Dmapper: 205732299.

Warning: If the GPS refresh rate is lower than the shooting images rate, more than one image will have the same GPS position and the processing may
fail or may not calibrate correctly some of the images. 

 

Images with known position using an external GPS logger

GPS loggers are very light devices (easily placed on a UAV) that can collect position information for the images. They register latitude, longitude and altitude
values for each camera position while shooting. These values are saved to a file that can be imported into Pix4Dmapper if it has the correct file format. Otherwise,
the file requires some editing before being imported in order to comply with Pix4Dmapper's geolocation file format.

Figure 1. GPS logger

 

Recommended GPS Logger 

RTK GPS can capture accuracy of 2-4 cm at a high refresh rate. Having a RTK GPS, no GCPs are needed to obtain high accuracy. 

Information: Some loggers come with image geotagging software. If not, GPS data and images can be synchronized by using other software such as:
GPicSync (free)
Geosetter (free) 
RoboGeo (commercial) 

A list of available loggers is maintained by OpenStreetMap.

For more information about geolocation file formats supported by Pix4Dmapper: 202558539.

For more information about how the onboard GPS affects the accuracy of a project: 202558909.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/205360375
https://support.pix4d.com/hc/en-us/articles/205360385
https://support.pix4d.com/hc/en-us/articles/205732299
https://code.google.com/p/gpicsync/
https://code.google.com/p/gpicsync/
http://www.geosetter.de/en/
http://www.geosetter.de/en/
http://www.robogeo.com/home/
http://wiki.openstreetmap.org/wiki/GPS_Reviews
https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558909
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>> Skip this step if no GCPs will be added <<

Warning: Using GCPs is HIGHLY RECOMMENDED when processing a project with no image geolocation.

If no Ground Control Points are used:

The final results have no scale, orientation, and absolute position information. Therefore they cannot be used for measurements, overlay, and comparison
with previous results.
They may produce an inverted 3D model in the rayCloud. 
The 3D reconstruction may not preserve the shape of the surveyed area. For more information: 202561199.

Ground Control Points (GCPs) are points of known coordinates in the area of interest. Their coordinates have been measured with traditional surveying methods or
have been obtained by other sources (LiDAR, older maps of the area, Web Map Service). They are not required for processing a project with Pix4Dmapper, but
they increase significantly the absolute accuracy of the project. GCPs can also be used as Check points to verify the accuracy of the results. They can be used: 

In projects with image geolocation: GCPs increase the absolute accuracy of a project, placing the model at the exact position on the Earth. They reduce the shift
due to GPS from meters to centimeters. For more information about the shift due to GPS: 202558909.
In projects without image geolocation: GCPs are required if there is need for georeferenced outputs. In this case, the GCPs will scale, oriente and position the
final results. Additionally, they are very useful for increasing the relative accuracy of the outputs, i.e. the reconstruction of the 3D model.

When using GCPs the following points need to be taken into consideration:

Number and distribution of GCPs
GCP acquisition

 

Number and distribution of GCPs

The GCPs should be placed homogeneously in the area of interest. Imagine the area as a large table and the GCPs as the legs that will support it. If all the "legs"
are placed at the same location of the "table," then it will tilt. If the "legs" are homogeneously spread, then the "table" will be stable. Additionally, it is also
recommended to place one GCP in the center of the area in order to further increase the quality of the reconstruction (Figure 1).

Important:
A minimum number of 3 GCPs is required for them be taken into account in the reconstruction. Each one should be clicked in at least 2 images.
A minimum number of 5 GCPs is recommended. 5 to 10 GCPs are usually enough, even for large projects. More GCPs do not contribute significantly to
increasing the accuracy.
In cases that the topography of the area is complex, then more GCPs will, indeed, lead to better (more accurate) reconstruction.
It is recommended to use at least 5 GCPs, each of which is identified in 5 images, as it minimizes the measurement inaccuracies and helps to detect
mistakes that may occur when inserting the GCPs.
The GCPs should be placed evenly on the landscape to minimize the error in Scale and Orientation.
Do not place the GCPs exactly at the edges of the area, as they will only be visible in few images.
For corridor mapping: 202559299.

Figure 1. Distribution of the GCPs.

 

GCP acquisition

 

 

https://support.pix4d.com/hc/en-us/articles/202561199
https://support.pix4d.com/hc/en-us/articles/202558909
https://support.pix4d.com/hc/en-us/articles/202559299


The Ground Control Points can be: 

GCPs measured in the field
GCPs defined from other sources

GCPs measured in the field
Measuring GCPs in the field requires spending some time in the area and locating the position where the GCPs should be measured. This process requires the
terrain to be accessible. Before measuring the GCPs coordinates, the following items must be defined:
GCP coordinate system
GCP accuracy
Topographic equipment

GCP coordinate system

A coordinate system is a set of numbers and parameters that is used in order to define the position of any object in the 2D or 3D space. The chosen GCP
coordinate system depends on the needs of the end-user. Usually the coordinate systems can be:

Global coordinate systems: They are defined using 3D ellipsoid coordinates (latitude, longitude, altitude).
National coordinate systems: They are usually defined using a projection defined for a specific country (X, Y, altitude).
Local coordinate systems: They are defined using a projection. The user sets the origin and orientation where it is most convenient (X, Y, altitude).

Note: The altitude can be either geometric (using as reference the level of the ellipsoid) or orthometric (using as reference level the Mean Sea Level).

GCP accuracy

In order to define the accuracy with which the GCPs will be measured, the following factors must be taken into account:

Accuracy needed for the final results: The accuracy of the GCPs should correspond to the final absolute accuracy the user needs. For example, for projects
for which an accuracy of some meters is acceptable (e.g. fast assessment tasks), then the accuracy of the GCPs is NOT required to be of some centimeters.
For projects for which the accuracy is very important (e.g. construction sites) then the GCPs should be measured with an accuracy of some centimeters in order
to comply with the project requirements. In general, the accuracy of the GCPs should be slightly better than the expected accuracy of the final results.
Ground Sampling Distance of the images: The GCPs should:
Be visible in the images. The GCP photogrammetric target (figure 2) should have about five to ten times the dimensions of the GSD. If the GCP is natural (a
characteristic point in the area that is not signed by a photogrammetric target), then the GCP can be even more difficult to identify and mark.

Figure 2. GCP photogrammetric target.

Not be more accurate than 1/10 of the GSD. For example, if the GSD is 10 cm, the GCP accuracy should not be below 1 cm, since they cannot be marked in
the images with such accuracy.

Important: The accuracy of the GCPs must be known in order to correctly set the GCP accuracy (Horizontal and Vertical) for processing. For more
information about the GCP accuracy: 202557919.

 

Topographic equipment

Total station accuracy: They can reach millimeters accuracy (depending on the distance of the measured points from the station).
GPS system accuracy: They can reach several centimeters accuracy (depending on the equipment, the area, and the country).

GCPs defined from other sources
If no GCPs have been measured in the field, they can be extracted from other sources. The advantage of such GCPs is that they can be extracted at any time
while being at the office. The disadvantage is that they give no control over the accuracy and that the coordinate system is the coordinate system of the GCP
source.

GCPs can be extracted from 2 type of sources:

GCPs extracted from high accuracy sources: GCPs can be extracted from sources such as existing maps and laser scanning outputs of the same area. If
these sources are updated, then the GCPs can be very accurate. The coordinate system and the accuracy of these points depend on the source.
GCPs extracted from Web Map Services: Web Map Services provide online georeferenced maps using a standard protocol called Web Map Service
(WMS). Some servers have their GIS databases publicly available and free-of-charge. Well-known free WMS servers are Google Maps and Bing Maps. They cover
the whole planet but the accuracy of the map georeference may not be high enough. In addition, their data is not available with the same accuracy for different
parts of the world. It is recommend to use GCPs derived from such sources when:
The images are not geolocated and therefore the project has no georeference.
The desired output is a .kml file, which can align perfectly with Google Maps.

For more information about how to obtain the georeference using 2D or 3D GCPs taken from a Web Map Service server: 202560149.
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https://support.pix4d.com/hc/en-us/articles/202560149
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To create a project, follow these steps:

1. Creating a New Project.
2. Importing the Images.
3. Configuring the Image Properties:

If the images have geolocation:
Define the coordinate system and import the image geolocation information.
If the software cannot recognize the camera model or it is needed to use different camera parameters:
Edit the camera model.

4. Selecting the Output / GCP Coordinate System.
5. Selecting the Processing Options Template.
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To create a new project:

1. Start Pix4Dmapper.
2. On the Menu bar, click Project > New Project...

3. The New Project wizard opens:

4.  In Name: type a name for the project.
5. (optional) In Create in: click Browse... On the Select Project Location pop-up, navigate to select the folder where the project and results will be stored and
click Select Folder.



Warning: Ensure that:
The project name DOES NOT use special character(s).
The path where the project will be created DOES NOT use special character(s).
The project name and the path together contain less than 128 characters.

Note: When the wizard is completed, a folder named after the project will be created in the selected folder and it will store all the results.

6. (optional) Select the check box Use As Default Project Location to save all new projects in the selected folder.
7. In Project Type, keep the default option New Project selected.
8. Click Next.
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On the Select Images window:

1. Click Add Images... to add the images.

Warning:
Images should not contain any symbol such as time and date stamps. Images that contain such symbols cannot be processed.
Images should not be edited manually, i.e. should not be scale, rotated, etc.
Images taken during take-off or landing should not be used.

 

2. On the Select Images pop-up, navigate to select the folder where the images are stored, select the images to be imported (it is possible to select multiple
images), and click Open.

Note:
Images can be imported as *.jpg, *.jpeg, *.tif, or *.tiff. By default all supported image formats can be selected. To filter images according to their
format change the input format to JPEG images (*.jpg,*.jpeg) or to TIFF images (*.tif, *.tiff).
It is possible to select images stored in different folders. Once images are imported from one folder, click Add images... again to add more images
from another folder.

 

3. (optional) It is possible to remove images by selecting them in the image list (use Ctrl+click or Shift+click for multiple selection) and clicking Remove
Selected.
4. (optional) It is possible to clear the list of images that have been added by clicking Clear List.
5. Click Next.
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The New Project wizard displays the Image Properties window which contains 3 sections:

Image Geolocation:
Sets the coordinate system to which the image geolocation refers.
Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.
Sets the accuracy of the image geolocation.
Selected Camera Model: Sets and configures the camera model associated to the images.
Images table: Displays the selected images, as well as the group, position, position accuracy and orientation of each image and if the image is enabled or not (an
enabled image will be taken into account for processing).

 

There are 3 optional steps to follow before clicking Next:

a. (optional) Select Image Coordinate System

On Coordinate System, click Edit... if the image geolocation is given in a coordinate system other than WGS84 (default).

For more information and step by step instructions about how to select/change the Image Coordinate System: 202560029.

b. (optional, recommended) Import Image Geolocation and Orientation

If the image geolocation (position) information is stored in the EXIF of the images, it will be loaded automatically.

For more information and step by step instructions about how to select/change the Image Geolocation and Orientation: 202560019.

https://support.pix4d.com/hc/en-us/articles/202560029
https://support.pix4d.com/hc/en-us/articles/202560029
https://support.pix4d.com/hc/en-us/articles/202560019
https://support.pix4d.com/hc/en-us/articles/202560019


Note:
The software considers the Date Taken field of the EXIF to set up the order in which the images are taken.
Step 1. Initial Processing is faster for projects with image geolocation. In the case of not sufficient overlap, image geolocation helps calibrating
the images. 

 

c. (optional) Edit Selected Camera Model

A camera model needs to be defined in order to run a project in Pix4Dmapper. The parameters of this model depend on the camera that was used to
capture the image. Most cameras save their name in the metadata of the image in EXIF format. This field is used to associate a given camera model to
all the images captured with this camera. 

The Selected Camera Model section, on the Image Properties window displays the selected camera model. The camera model can be:

 Valid: A green check is displayed if the camera model is valid. A camera model is valid if it already exists in the camera model database of

Pix4Dmapper or if there is sufficient information in the EXIF data of the images to create a new camera model that will be saved into the user camera model
database. If the camera model is retrieved from the EXIF data, it is recommended to check the camera model parameters and, if needed, to edit them. 

 Invalid: A red cross is displayed if the camera model is not valid. A camera model is invalid if it is not in the camera model database of Pix4Dmapper

and if there is not enough information in the EXIF data of the images. In this case the camera model needs to be defined manually.

For more information and step by step instructions about how to edit the camera model: 202560169.

Note: Grouping the images:
When the project contains images with different spectral signatures (RGB, NIRGB, etc) usually the images are grouped automatically. In case
that they are not grouped by default, group them manually following: 202560509.
In this case one orthomosaic is generated per group.
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In the Select Output Coordinate System window:

1. (optional) Change the output / GCP coordinate system: 202560029.

Note: For more information about the Output / GCP coordinate System section: 202558239.

Note: 
By default, the output and GCP coordinates system will be the same. To select a different coordinate system for the outputs: 202558099. To select
different coordinate system for the GCPs: 202557749.
By default, the Unit is m (meters).
If the images have geolocation, by default, Auto detected is selected, displaying the corresponding UTM or Nad83 zone of the images.
If the images do not have geolocation, by default, Arbitrary Coordinate System is selected.

 

2. Click Next.
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Ιn the window Processing Options Template:

1. Select a processing options template.

Note: A template has to be to chosen in order to open a project, but it can always be modified or changed later.

Note: For more information about the default processing templates, their outputs and their selected processing options: 205319155.

Note: In the window Processing Options Template, the processing options templates are organized into three sections: Standard, Rapid and Advanced.
A fourth section titled Personal appears above the others when a new personal template has been created by the user.

2. (optional) Select the box Start Processing Now to start the processing automatically.
3. Click Finish to close the wizard and start the project.
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Once the project is created, the Map View is displayed.

There are some optional steps that can be done before processing:

1. (optional) Selecting the Processing Area 

By default, the area selected for processing corresponds to the entire area covered by all the images that are calibrated. It is possible to restrict the
processing area to the area of interest, but it is not compulsory. This option can be useful to generate the outputs only for an area of interest instead of the
entire area. 

For step by step instructions about creating a Processing Area: 202560179.

 

2. (optional) Changing the Processing Options Template and / or the Process Options 

Change the output results files (types and format), change some processing options to improve the quality of the results when needed, or change some
processing options for advanced use. For more information: 202560009.

Note: For more information about the Processing Options Templates, the outputs they generate and their selected processing options: 205319155.

 

3. (optional) Adding GCPs 

Add Ground Control Points (GCPs) to improve the global accuracy of the project (georeference). GCPs can be measured in the field using topographic
methods, taken from existing geospatial data or Web Map Service (WMS).

Warning: Using GCPs is HIGHLY RECOMMENDED when processing images without image geolocation.

If no Ground Control Points are used:

The final results are not scaled, oriented or georeferenced. Therefore they cannot be used for measurements, overlay, and comparison with previous
results.
They may produce an inverted 3D model in the rayCloud. 
The final 3D model may be shifted (this problem can be corrected using Manual Tie Points: 202560349).

For step by step instructions about how to include GCPs in the project: 202560239.

 

 

https://support.pix4d.com/hc/en-us/articles/202560179
https://support.pix4d.com/hc/en-us/articles/202560009
https://support.pix4d.com/hc/en-us/articles/205319155
https://support.pix4d.com/hc/en-us/articles/202560349
https://support.pix4d.com/hc/en-us/articles/202560239
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When processing a project it is recommended to go through the following steps:

Initial Processing
Analyzing the Quality Report
Point Cloud and Mesh 
DSM, Orthomosaic and Index
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To start processing the project:

1. On the Menu bar, click View > Processing.

  

2.  The Processing bar opens on the bottom of the main window.

 

3. Ensure that 1. Initial Processing is selected and that 2. Point cloud and Mesh and 3. DSM, Orthomosaic and Index are unselected:

 

4. Click Start.

For more information about the outputs resulting from 1. Initial Processing: 202558519.
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Important:
For a detailed description about how to analyze the Quality Report: 202558689.
For a detailed description about any parameter described in the Quality Report: 202558679.
Example of a Quality Report available at the following link: Quality Report.

Once step 1. Initial Processing is completed, the Quality Report is automatically displayed. To not be displayed automatically, unselect the Display Automatically
after Processing box at the bottom of the Quality Report. 

When more than one step are processed sequentially the PDF Quality Report is generated in the results folder only when the processing is completed. However,
it is automatically displayed in Pix4D Desktop once a step is completed.

It is recommended to verify the following information in the Quality Report:

1. Quality Check

Verify that:

All the checks are green.
All or almost all the images are calibrated in one block. 
The relative difference between initial and optimized internal camera parameters is below 5%.
(optional) If using GCPs, the GCP error is below 3×GSD.

 

2. Preview

For projects with nadir images and for which the orthomosaic preview has been generated, verify that the orthomosaic:

Does not contain holes.
Does not have distortions.
(optional) If GCPs or image geolocation has been used, it has the correct orientation.

 

 

3. Initial Image Positions

(optional) If the images have geolocation, verify that the Initial Image Positions figure corresponds to the flight plan.

 

https://support.pix4d.com/hc/en-us/articles/202558689
https://support.pix4d.com/hc/en-us/articles/202558679
https://support.pix4d.com/hc/en-us/articles/mining_quarry_withGCPS_report.pdf


4. Computed Image/GCPs/Manual Tie Points Positions

Verify that :

(optional) If using images with geolocation, the computed image geolocation is good.
(optional) If using only images with geolocation, the uncertainty ellipses are similar in size.
(optional) If using GCPs, the GCPs' error is low (the difference between input and computed GCPs is small).
(optional) If using GCPs and images with geolocation, the uncertainty ellipses are very small close to the GCPs and may increase for images further away.

 

5. Absolute Camera Position and Orientation Uncertainties

Verify that:

For projects only with image gelocation, the absolute camera position uncertainty is similar to the GPS accuracy and that the sigma is smaller than the mean.
For projects with GCPs, the absolute camera position uncertainties are similar to the accuracy of the GCPs.

 

6. 3D Points from 2D Keypoints Matches

Verify that:

Enough matches have been computed between the images.
The graph consists of one block. If multiple blocks exist, each block will have a different color.
The uncertainty ellipses are approximately of the same size throughtout the project. 

 



7. Geolocation Details

(optional) If using GCPs, verify that:

All GCPs are taken into account (not displayed with red color on the Geolocation and Ground Control Points table).
All marked GCPs have been verified.

 

8. Processing Options

Verify that:

(optional) If using GCPs, the Ground Control Point (GCP) Coordinate System is correct.
(optional) If using images with geolocation, the Image Coordinate System is correct.
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To process step 2. Point Cloud and Mesh:

1. On the Menu bar, click View > Processing.

2. The Processing bar opens on the bottom of the main window.
3. Ensure that 2. Point Cloud and Mesh is selected, and that 1. Initial Processing  and 3. DSM, Orthomosaic and Index are unselected.

4. Click Start.

For more information about the outputs resulting from 2. Point Cloud and Mesh: 202558549.
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To process step 3. DSM, Orthomosaic and Index:

1. On the Menu bar, click View > Processing. 

2. The Processing bar appears in the bottom of the main window.  
3. Ensure that 3. DSM, Orthomosaic and Index is selected, and that 1. Initial Processing, and 2. Point Cloud and Mesh are unselected.

4. Click Start.

For more information about the outputs resulting from 3. DSM, Orthomosaic and Index: 202558559.
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Once the project has been processed, it is possible to use the results:

Using the rayCloud
Using the Volumes
Using the Mosaic Editor
Using the Index Calculator
Uploading Project Files
Using output files in other software

 

Using the rayCloud

The use of the rayCloud is optional and it can be used to:

Visualize the different elements of the reconstruction (Camera Positions, Reprojections (rays), GCPs, Manual / Automatic Tie Points, Processing Area, Clipping
Box, Densified Point Cloud, Terrain / Objects / other Point Groups, 3D Textured Mesh, Video Animation Trajectories) and their properties.
Verify/ improve the accuracy of the reconstruction of the model. 
Visualize point clouds / triangle meshes created in other projects or with other software.
Georeference a project using GCPs and /or Scale and Orientation constraints.
Create Orthoplanes to obtain mosaics of any selected plane (for example, building facades).
Assign points of the point cloud to different point groups.
Improve the visual aspect.
Create objects and measure distances (polylines) and surfaces.
Create 3D fly-through animations (Video Animation Trajectories).
Export different elements (GCPs, Manual / Automatic Tie Points, Objects, Video Animation Trajectories).
Export point cloud files using points belonging to one or several classes.

For more information: 202558639.

Using the Volumes

The use of the Volumes is optional and it can be used to:

Draw volumes.
Measure volumes.
Exports the measurements.

For more information: 209268446.

 

Using the Mosaic Editor

The use of the Mosaic Editor is optional and it can be used to:

Visualize the DSM (raster GeoTIFF Digital Surface Model).
Visualize the Orthomosaic.
Improve the visual aspect of the Orthomosaic.

For more information: 202558709.

 

Using the Index Calculator

The use of the Index Calculator is optional and it can be used to:

Generate an Index Map / Index Grid where the color of each pixel is computed using a formula that combines different bands of the Reflectance Map(s).
Provide information about the bands of the Reflectance Map(s) and Index Map.
Visualize the Index Map as a Colored Index Map by applying a color mapping to it.
Export a georeferenced Colored Index Map.
Annotate the classes of the Index Map to generate an Application Map.
Export an Application Map as a shape file to be imported in any Tractors Consoles.
Upload the Reflectance Map on MicaSense Atlas platform.

For more information: 202558729.

 

Uploading Project Files

The use of the Upload Project Files feature is optional and it can be used to:

https://support.pix4d.com/hc/en-us/articles/202558639
https://support.pix4d.com/hc/en-us/articles/209268446
https://support.pix4d.com/hc/en-us/articles/202558709
https://support.pix4d.com/hc/en-us/articles/202558729


Upload Files to the Pix4D Cloud, in order to:
Store files in the Pix4D online account.
Process projects online.
Provide project information to the support team.
Upload 3D Textured Mesh to Sketchfab, for viewing, interacting and sharing.

For a full description about the File Upload pop-up: 202557689.

For step by step instructions about how to Upload project files into Pix4D Cloud: 202558589.

 

Using output files in other software

Pix4Dmapper outputs are compatible with many software (GIS, CAD, etc.) and can be used for many different applications. For more information about how to
use Pix4Dmapper output files in other software: 202558499.
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The software manual describes all the options that can be found in the Pix4Dmapper software. Offline version: pdf. The following links contain a detailed
description of these options:

 

Table View Blocks View Index View

 

Interface
Menu bar Toolbar View toolbar Main view
Floating License
Shortcuts

 

 

Menu Bar
Menu Project Menu Process Menu View
New Project...
Open Project...
Recent Projects
Close Project
Download Project Files... 
Upload Project Files...
Image Properties Editor...
Image Geolocation
Selected Camera Model
Edit Camera Model
Images Table
GCP/MTP Manager...
GCP Coordinate System
GCP/MTP Table
Import GCPs...
Export GCPs... 
Add Point
Remove Points
Import Marks...
Export Marks...
GCP/MTP Editor
rayCloud
Basic GCP/MTP Editor
GCP/MTP Table
Images
Preview
Select Output Coordinate System...
Save Project
Save Project As...
Split into Subprojects...
Exit

Reoptimize
Rematch and Optimize 
Quality Report...
Open Results Folder...
Outputs Status...
Generate Quality Report 
Save Undistorted Images
Run Point Cloud Classification
Generate 3D Textured Mesh 
Import Point Cloud for DSM Generation...
Generate DTM
Generate Contour Lines 
Send Elevation Data (DSM) to eMotion
Send Map to eMotion
Processing Options...

1. Initial Processing
2. Point Cloud and Mesh 
3. DSM, Orthomosaic and Index
Resources and Notifications
Templates 

Show View Toolbar
Show Sidebar
Home
Projects
Help
Demo Project
Map View
rayCloud
Volumes 
Mosaic Editor
Index Calculator 
Processing
Log Output
Menu Help
Help Contents
Online Support
Forum 
Personal Support
Settings...
About...

 

 

 

Views
Map View rayCloud Volumes 

https://s3.amazonaws.com/mics.pix4d.com/manual_pdf/Pix4Ddesktop_Manual_3.2_May_2017.pdf
https://support.pix4d.com/hc/en-us/articles/202557989
https://support.pix4d.com/hc/en-us/articles/202558109
https://support.pix4d.com/hc/en-us/articles/204606405


Menu bar entry
Processing Area
Toolbar
2D View
Status bar

Menu bar entry
Viewpoint
Navigation Modes 
Perspective/ Orthographic
Change Background...
Display Sky
New Processing Area
New Scale Constraint 
New Orientation Constraint 
New Orthoplane
New Video Animation Trajectory... 
New Polyline
New Surface
Toolbar
Left sidebar
Create
Layers
Cameras
Rays
Tie Points
Processing Area 
Point Clouds
Point Groups 
Triangle Meshes
Objects
3D View
Right sidebar
Clipping Box 
Cameras
GCPs and Manual Tie Points 
Automatic Tie Points
Processing Area 
Point Clouds
Objects
Status bar

Menu bar entry
Viewpoint
Navigation Modes
Perspective/Orthographic
Change Background...
Display Sky
New Volume
3D View
Sidebar
Objects
Layers
Status bar

 

Views
Mosaic Editor Index Calculator 
Menu bar entry
View
Mosaic Editing
Visualization
Toolbar
Mosaic View
Sidebar
Status bar 

Menu bar entryToolbar
Index View
Sidebar
1. Reflectance Map
2. Regions 
3. Index Map
Formula Editor 
Index List
4. Color Maps and Prescription 
5. Export 
Status bar

 

 Next  
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When Pix4Dmapper opens, 4 sections appear:

Menu bar
Toolbar
View toolbar
Main view

 

Figure 1. Menu bar (yellow), toolbar (red), view toolbar (blue) and main view (green).

 
Menu bar

There are 4 items:

Project: This menu allows to create, open, close, save, upload to download from the cloud or split a project. It also allows to view and define the properties of the
images, GCPs, and output coordinate system.



Process: This menu gives access to all processing options and actions.
View: This menu gives access to the different views of the software. Depending on the selected view, a new item will appear on the Menu bar: Map,
rayCloud,Volumes, Mosaic Editor or Index Calculator. This extra menu bar item contains options specific for the selected view.
Help: This menu:
Gives access to the Manual, Support Site and Forum.
Allows to set some settings (proxy, camera model database, language)
Gives information about the installed release.

The different options within the menu bar items may be active or grayed out depending on the status of the project and the selected options.

 

Toolbar

The different buttons within the toolbar may be active or grayed out depending on the status of the project and the selected options. Each button's action can also
be accessed through the Menu bar and is explained in more details in the next articles.

The toolbar buttons are: 

On the left:

Project

 Image Properties Editor...

 GCP/MTP Manager...

Process

 Quality Report...

 Open Results Folder...

 Reoptimize

 Rematch and Optimize

On the right:

 User Options: There are 4 items that can be selected:

Logged In as USERNAME: Displays the username.
Cloud Projects: Opens the user website account, displaying the Projects page, where the user can access the uploaded projects
(https://mapper.pix4d.com/projects/).
Manage Licenses: Opens the user website account, displaying the Licenses page, where the user can access the Licenses and Devices information
(https://mapper.pix4d.com/licenses/).
Log Out...: Option to deactivate the license in the installed computer.

 Show sidebar: Shows the sidebar on the right of the main window. The Home view and the Volumes do not have a right sidebar.

 Hide sidebar: Hides the sidebar on the right of the main window. The Home view and the Volumes do not have a right sidebar.

 

When activating the different views using the View Menu bar item (Map View, rayCloud, Volumes, Mosaic Editor and Index Calculator) some extra buttons appear
in the toolbar. These extra buttons are specific for the selected view (see Figures 2-6 below).

 

View toolbar

Appears on the left of the main window and allows to select the view, bars (Processing and/or Log Output bar) and the Processing Options window. Depending on
the status of the project and the selected options, the different options may be active or grayed out. When starting the software, only the Welcome View and the
Log Output bar are active.

The following views are available:

 Welcome

 Map View

 rayCloud

 Volumes

 Mosaic Editor

 Index Calculator

The following bars are available:

Processing



Log Output

The following windows are available:

 Processing Options...

In order to show / hide the view toolbar, on the Menu bar click View > Show View Toolbar.

 

Main view

When Pix4Dmapper opens, the Welcome View appears.

When opening a project the Map View is selected by default and the 2D View appears. When the rayCloud or the Volumes are selected, the 3D View appears.
When the Mosaic Editor is selected, the Mosaic View appears and when the Index Calculator is selected, the Index View appears.

 

Figure 1. Menu bar, toolbar buttons, view toolbar and main view when starting the software.



 

Figure 2. Menu bar, toolbar buttons, view toolbar and main view when the Map View is selected.



 

Figure 3. Menu bar, toolbar buttons, view toolbar and main view when the rayCloud is selected.



  

Figure 4. Menu bar, toolbar buttons, view toolbar and main view when the Volumes is selected.



 

Figure 5. Menu bar, toolbar buttons, view toolbar and main view when the Mosaic Editor is selected.



 

Figure 6. Menu bar, toolbar buttons, view toolbar and main view when the Index Calculator is selected.
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Access: On the Menu bar, click Project.

There are 13 items that can be selected:

New Project... 
Open Project... 
Recent Projects
Close Project
Download Project Files...
Upload Project Files...
Image Properties Editor...
GCP/MTP Manager...
Select Output Coordinate System...
Save Project
Save Project As...
Split into Subprojects...
Exit

Depending on whether there is a project loaded/created, different options will be enabled or grayed out:

 

Available options before a project is loaded or created. Available options once a project is loaded or created.

 

New Project...

Opens the wizard to create a new project.

For step by step instructions about how to create a new project: 202557309.

 

Open Project...

Opens an existing project. By clicking Open Project, a pop-up appears to navigate and select a .p4d project file (Pix4Dmapper project file format).

 

Recent Projects 

Displays a menu with the 10 last projects that have been opened. By clicking on one of them, the project will open.

 

Close Project

Closes the current project.

 

Download Project Files...

 



Allows to download and load a project previously uploaded to Pix4D Cloud. This option is enabled when the software is opened and disabled once a project is
loaded or created.

For step by step instructions: 205751415.

 

Upload Project Files...

Allows to:

Upload and process a project on Pix4D Cloud.
Upload Files on Sketchfab.

For more information: 202557689.

 

Image Properties Editor...

Allows to change the properties of the project's images such as: the coordinate system, the image geolocation, the image geolocation accuracy and the
associated camera model. For more information: 202557849.

 

GCP/MTP Manager...

Allows to set up and edit the properties of the GCPs / Manual Tie Points / Check Points such as: Select the GCP coordinate system, import GCPs, add / remove
points, import / export the marks, open the rayCloud or Basic Editor for marking. For more information: 202558329.

 

Select Output Coordinate System...

Allows to select the coordinate system of the results. For more information: 202558099.

 

Save Project

Saves the status/properties and configuration of the current project.

Important: This option saves any change made since the project was opened and saved for the last time. The .p4d project file will be updated with the
current state of the project. This has no impact on other files such as input files or output files. Output files will be modified/created only when
processing.

 

Save Project As... 

Save the status/properties, configuration, and results of the current project into another location and/or with a different name.

Important: If a different project name or path is selected, this option will save a copy of the project in the new location using the new project name.

A new .p4d project file will be created and saved with the same information as the current project. Once this new project is created, any changes made
and saved with the option Save Project will not be saved in the original project. Only the new project will include all the changes.

 

Split into Subprojects...

Allows to automatically split the project into subprojects by creating different .p4d files.

Each .p4d file contains the images for the created subproject.

The different subprojects overlap, therefore, some images will appear in more than one subproject.  

Important: Only aerial projects with geolocated images can be split.

By clicking Split into Subprojects... the Split the Project into Subprojects pop-up will open:

 

 

 

https://support.pix4d.com/hc/en-us/articles/205751415


It contains the following options:

Maximum Number of Images: Defines the area to be used to split the terrain into subprojects. When selecting for example 100, a subproject will cover the area
from 100 images plus some area and images from neighboring subprojects so as to ensure there will be overlap between them.
Suffix of the Subproject's Name: Text to use as suffix for the subprojects. Each subproject will be named as projectname + Suffix + Number.

Important: All the Manual Tie Points, GCPs, Check Points and Objects created in the original project will be copied into all the generated subprojects.

 

Exit

Closes the project and exits the software.

Important: If changes have been made and the project was not saved, the following pop-up appears:

Click Save to save the changes and exit, Discard to exit without saving, and Cancel to keep the software open.
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Access: On the Menu bar, click Project > Upload Project Files... (active once a project has been loaded or created).

The File Upload pop-up appears, which allows the user to:

Upload and process a project on Pix4D Cloud.
Upload Files on Sketchfab

   

Upload and process a project on Pix4D Cloud
The File Upload window contains 2 sections:

Upload Project and Image Files
Progress 

and the action button:

Close: Closes the window.  

Upload Project and Image Files

The Upload Project and Image Files section contains the Start Processing box:

Start Processing: To start processing on Pix4D Cloud. For more information and step by step instructions: 202558589.

Note: When sending a project to Pix4D Support Team, there is no need to select Start Processing.

Progress

The Progress section contains:

Progress bar: Displays the upload status in percentage.
Upload: Allows to upload the selected files on the cloud.
Cancel: Cancels the upload.

Note: The solution that corresponds to the valid license used to process the project can be selected: 
from the File Upload window: Click here to change the solution preference 
for more information: 115002204266.

  

Upload Files on Sketchfab

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558589
https://cloud.pix4d.com/account/
https://support.pix4d.com/hc/en-us/articles/115002204266


Note: In order to use the 3D Textured Mesh in Sketchfab: 203282189.

The File Upload window contains 2 sections:

Account
Upload

 and the action button:

Close: Closes the window.  

Account

It displays the URL to log in or create (free of charge) a Sketchfab account.

Note: There is a limit on the size of the files that can be imported:
Basic (free account): 50MB per upload.
Pro: 200MB per upload.
Business: 500MB per upload.

 

Upload

It displays the instructions to upload the 3D Textured Mesh on Sketchfab: 204963595.
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https://support.pix4d.com/hc/en-us/articles/204963595
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Access: On the Menu bar, click Project > Image Properties Editor...

Access via the New Project wizard: When creating a new project, after loading the images.

The Image Properties Editor window contains 3 sections:

Image Geolocation: 
Selects the coordinate system used for the images' geolocation.
Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.
Selects the accuracy of the geolocation.
Selected Camera Model: Selects and configures the camera model associated to the images.
Images Table: Displays the selected images, as well as each image's group, position, position accuracy, orientation, and if the image is enabled or not (an
enabled image will be taken into account for processing).
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Access: On the Menu bar, click Project > Image Properties Editor...

Access via the New Project wizard: When creating a new project, after loading the images.

The Image Geolocation section contains:

Coordinate System: Selects the coordinate system used for the images' geolocation.
Geolocation and Orientation: Imports/exports the coordinates and, optionally, the orientation of the images and/or the accuracy of the coordinates.
Geolocation Accuracy: Selects the accuracy of the geolocation.

 

Coordinate System

Datum: Displays the selected image datum. By default the selected datum is World Geodetic System 1984. 
Coordinate System: Represents the selected image coordinate system. By default the selected coordinate system is WGS 84.
Vertical coordinate system or Geoid Height Above the Ellipsoid: It is displayed in parenthesis. It represents the vertical coordinate system / Geoid Height Above
the Ellipsoid that will be used to convert the image height from geoidal to ellipsoidal. For more information about when to use this function: 202559459.
Edit...: Opens the Select Image Coordinate System pop-up that allows the user to change the selected coordinate system.
For more information: 202558239. 

 

Geolocation and Orientation

Important: Pix4Dmapper can process images with or without geolocation. If more than 80% images are not geolocated, lower precision results are
expected.

The left icon indicates the status:

: If less than 20% images are geolocated, lower precision results are expected.

: More than 20% images are geolocated.

The number of geolocated images is displayed next to the status indicator icon.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202559459
https://support.pix4d.com/hc/en-us/articles/202558239


There are 4 options available for this section:

Clear: Deletes the images' coordinates that are already loaded.
From EXIF: Imports the image geolocation (coordinates) written in the EXIF data of the images if they are available.
From File...: Imports from a file the coordinates of the images and, optionally, the orientation of the images and/or the accuracy of the coordinates using
the Select Geolocation File pop-up.
To file: Exports to a file the coordinates of the images and, optionally, the orientation of the images and/or the accuracy of the coordinates using the Export Image
Geolocation pop-up.

 

Geolocation Accuracy

Defines the horizontal and vertical accuracy values (Accuracy Horz, Accuracy Vert).

The horizontal accuracy (Accuracy Horz) refers to the first and second coordinates (latitude and longitude or X and Y) of the images. 
The vertical accuracy (Accuracy Vert) refers to the third coordinate (altitude or Z) of the images.

There are 3 options:

Standard: Useful when having very accurate image geolocation. Sets the values to:
Accuracy Horz: 5m.
Accuracy Vert: 10m.
Low: Useful when having non accurate image geolocation. Sets the values to:
Accuracy Horz: 50m.
Accuracy Vert: 100m.
Custom: Allows to set other values or edit the accuracy of each individual image or of a group of images.

The higher the accuracy numerical value (m or ft), the less influence the image's coordinates will have in the Initial Processing compared to other images or GCPs
with lower accuracy numerical values (m or ft). The accuracy is a value between 0.001 and 10'000. 

Warning: The accuracy must be given in meters or feet according to the selected coordinate system.

To edit the accuracy of one image, double click on the corresponding cell and enter the new value: 202557949.
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https://support.pix4d.com/hc/en-us/articles/204606405
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Access: On the Menu bar, click Project > Image Properties Editor...

Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images.

The Selected Camera Model section is used to describe the selected camera model(s) associated with the images.

 

The status indicator is represented with the left icon:

: The camera model is valid, if it is retrieved from Pix4Dmapper's camera model database, from the user's camera model database, from a project file, or

from the image EXIF data if enough information exists in the data.

: The camera model is invalid if the camera model does not correspond to any model of the camera model databases and if the EXIF data of the images

does not have sufficient information about the camera model.

On the right of the status indicator, there is an icon that describes the source of the camera model:

: Camera model taken from the Pix4Dmapper's camera model database.
: Camera model taken from the Pix4Dmapper's camera model database with some user-edited values.
: Camera model taken from the user's camera model database.
: Camera model taken from the image EXIF data when the camera model does not exist in the Pix4Dmapper's or the user's database and there is valid

information in the EXIF data.
: Camera model taken from the .p4d project file when a .p4d file is opened and its camera model does not exist in the Pix4Dmapper's or the user's

database.

Beside the status indicator, appears the EXIF ID (CameraModel_ FocalLength_ResolutionWidthxResolutionHeight)  and the band configuration.

On the right of the Selected Camera Model section there are the following buttons:

Edit...: Opens the Edit Camera Model pop-up which allows the user to edit the corresponding camera model. For more information about the Edit Camera
Model window: 202558159.
Assign (optional): Appears if more than one camera models are detected (e.g. multiple flights with different cameras or merged projects). By clicking it, the
corresponding camera model is assigned to other detected camera models that have the same image width and height.
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Access: On the Menu bar, click on Project > Image Properties Editor..., the Image Properties Editor window appears, in the Selected Camera
Model section, click Edit... 

Access via the New Project wizard: When creating a new project, the Image Properties window appears after loading the images, in
the Selected Camera Model section, click Edit...

The Edit Camera Model window is used to define or edit the camera model.

The camera model can be set to perspective or fisheye lens. 

 

 



There are 3 sections:

Camera Model: Displays the current EXIF ID and the associated camera model. 
Camera Model Bands: Displays the configuration band selected for the camera model.
Camera Model Parameters: Describes the camera parameters for the selected camera model.

 and 3 action buttons:

OK: Confirms/applies the changes:
Uses the camera model selected in the Camera Model section if saved into the camera model database.
Uses the camera model name and parameters displayed in the Camera Model Parameters section if selected while editing or creating a new camera model. The
currently displayed camera parameters are not saved into the camera model database but they are saved only in the project .p4d file.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.

Camera Model

The following items are displayed:

EXIF ID: Displays the current EXIF ID (CameraModel_ FocalLength_ResolutionWidthxResolutionHeight) of the camera. No user intervention is possible.
   
Camera Model Name: Displays the currently selected camera model. The corresponding drop-down list allows the user to select another known camera model
with the same image width and height.

Beside on the left of the selected camera model name, an icon appears that describes the source of the camera model:

: Camera model taken from the internal camera model database.
: Camera model taken from the internal camera model database with some user-edited values.
: Camera model taken from the user camera model database.
: Camera model taken from the image EXIF data when the camera model does not exist in the internal or the user database and there is valid



information in the EXIF data.
: Camera model taken from the .p4d file when a .p4d file is created and its camera model does not exist in the internal or the user camera database.

Note: There are 2 camera databases: internal camera database (with the cameras and values from Pix4Dmapper), and user camera database (with
the cameras added or modified by the user).
The internal camera database cannot be edited, modified or deleted.
The user camera database can be:
Edited Menu Project > Image Properties Editor... > Selected Camera Model > Edit Camera Model.
Cleared, imported or exported from Help > Settings..., under the tab Camera database.

Click the drop-down list to display the available camera models. The drop-down list only displays camera models with the same image width and height as
the one detected in the EXIF ID. The drop-down list displays camera models using perspective lenses if Perspective Lens (Camera Model
Parameters section) is selected and it displays camera models using fisheye lenses if Fisheye Lens (Camera Model Parameters section) is selected.

Note: No information is displayed if no camera model exists with the same image width and height.

The following buttons are displayed:

Edit: Edit the Camera Model Bands and/or the Camera Model Parameters for the selected camera model. To edit the camera parameters: 202560169.
New: Create a new camera model. To create a new camera model: 202560169.
Restore: It is displayed only for camera models that exist in the internal camera database and have been edited by the user and stored in the user camera
database. It removes the camera model from the  user database and restores the parameters from the  internal database.
Save to DB: Visible when clicking on Edit or New. Save the camera model in the user camera model database.

Note:
When editing , and saving to DB, it changes to 
When editing , and saving to DB, it creates 
When editing , and saving to DB, it creates 
When editing , and saving to DB, it creates 
When editing  or  or  or , and clicking in OK without saving to DB, it creates 
When creating new and Saving to DB, it creates 
When creating new and clicking in OK without saving to DB, it creates 
Cancel edit: Visible when clicking on Edit or New. Cancel the editing or creating of a new camera model.

 

Camera Model Bands

The section contains 2 items:

Bands: Displays the band configuration selected for the project. If the band configuration is in the EXIF, and it is one of the bands listed below, it is selected
automatically. It allows the user to change the band configuration when more bands have been added to the camera model.

Edit...: Opens the Edit Camera Model Band Configurations pop-up:

Access: It is enabled if Edit or New has been selected in the Camera Model section.  

Allows to add/edit/remove Band configurations.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202560169
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There is one section:

Band configurations table:

Each row displays information for one band configuration: 

Default: Displays which band configuration is selected by default when using the selected Camera Model.
Bands Number: Number of bands for the Camera Model.
Name: Name of the band configuration, double click on the cell to edit the name.

 and the action buttons:

Add..: Opens the pop-up band configuration window to add a new band configuration.

By default the values of the RGB band configuration appear:

Each row displays information for one band and by double clicking on them, it is possible to edit the value:

Enabled: Displays if the band is enabled or not for the selected band configuration.
Name: Name of the band for the band configuration.
Central Wave Length [mm]: Representative (most influential) wave length for the band.
Band Width [mm]: Width of the distribution related the central wave length of the band.
Weight: How much value Pix4Dmapper gives to the selected band compared to other bands of the band configuration. These values only affect step 1. Initial
Processing. The sum of all weights should be 1.

And the action buttons:

Add...: Adds one more band. The number of bands should match the number of channels present in the image.
Remove: Deletes the selected row.
OK: Saves the new band configuration.
Cancel: Does not save the band configuration.
Help: Opens the Pix4Dmapper help.

Edit...: Opens the Edit Band Configuration pop-up. It edits an existing band configuration:

By default the values of the RGB band configuration appear:



Each row displays information for one band and by double clicking on them, it is possible to edit the value:

Enabled: Displays if the band is enabled or not for the selected Band configuration.
Name: Name of the band for the Band configuration.
Central Wave Length [mm]: Representative (most influential) wave length for the band.
Band Width [mm]: Width of the distribution related the central wave length of the band.
Weight: How much value Pix4Dmapper gives to the selected band compare to other bands of the band configuration. These values only affect step 1. Initial
Processing. All the weights should sum to 1.

And the action buttons:

Add...: Add one more band. The number of bands should match the number of channels present in the image.
Remove: Deletes the selected row.
OK: Saves the new band configuration.
Cancel: Does not save the band configuration.
Help: Opens the Pix4Dmapper help.

Remove: Deletes the selected band from the Band configurations table. 
OK: Confirms/applies the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.

Example: Examples of band configurations:
RGB: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band corresponds to
Blue. 
Blue, Green, NIR: For images with 3 bands. The first band corresponds to Blue, the second band corresponds to Green, and the third band
corresponds to Near Infrared.
NIR, Green, Blue: For images with 3 bands. The first band corresponds to Near Infrared, the second band corresponds to Green, and the third band
corresponds to Blue.
NIR, Red, Green: For images with 3 bands. The first band corresponds to Near Infrared (or Infrared), the second band corresponds to Red, and the
third band corresponds to Green.
Red edge, Green, Blue: For images with 3 bands. The first band corresponds to Red edge, the second band corresponds to Green, and the third
band corresponds to Blue.
Red, Green, NIR: For images with 3 bands. The first band corresponds to Red, the second band corresponds to Green, and the third band
corresponds to Near Infrared.

 

Camera Model Parameters

The Camera Model Parameters section includes all camera parameters and is enabled for editing if the Edit or New button has been clicked in the Camera
Model section. It displays the camera parameters of the selected Camera Model Name in the Camera Model section. 

The Camera Model Parameters section has 3 action buttons (enabled if Edit or New has been clicked in the Camera Model section):

Clear: It clears all the fields except image width (pixel) and height (pixel).
Estimate from EXIF:  Estimates the parameters from the EXIF data if enough information about the camera model is found there.
Load Optimized Parameters: Enabled once at least step 1 has been completed, it changes the camera initial values to the optimized values.

It also has the Shutter Model dropdown list with the following options:

Global Shutter or Fast Readout
Linear Rolling Shutter

Global Shutter or Fast Readout

To be used if the camera has a global shutter: all light information is read at the same time for the whole sensor.

Linear Rolling Shutter

This option models the rolling shutter (the image is scanned line by line) of some cameras such as the GoPro or the standard DJI cameras. This can be enabled if
the camera's shutter is a rolling shutter and, the flight plan is linear (grid mission, building facade, etc.). For more information about how Pix4D models the rolling
shutter effect: scientific white paper.

 

The parameters can be defined or edited for a:

Perspective lens: When the camera model uses a perspective lens.
Fisheye lens: When the camera model uses a fisheye lens (ultra wide angle lens).
Spherical camera: Only available when the camera detected is spherical or the height of the image is two times the width. Spherical images are unidisorted by
the camera manufacturer and the Image Properites Editor does not present any camera model parameters. For step by step instructions about how to process

 

https://support.pix4d.com/hc/en-us/articles/208255036


Spherical images: 210663886.

Perspective lens

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of
the Sensor width [mm] text box.

 

Internal Camera Parameters for Perspective lens
Camera Model Name Name for the camera model.
Image Width [pixel] The image width in pixels. This value cannot be edited. It is read from the image file information.
Image Height [pixel] The image height in pixels. This value cannot be edited. It is read from the image file information.
Focal Length [pixel] The focal length in pixels.
Principal Point x [pixel] The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The

coordinate system has its origin as displayed here:

 

Principal Point y [pixel] The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The
coordinate system has its origin as displayed here:

Sensor Width [mm] The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXIF data, the
sensor width is set to 36[mm].

Sensor Height [mm] The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXIF data, the
sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height in
millimeters equals the ratio image width / image height in pixels.

Pixel Size [μm] The size of the pixel is read from the EXIF data if the information is available. If there is no information related to the pixel size,
then it is calculated in order to correspond to 36 x 24 mm sensor size.

Focal Length [mm] The focal length in millimeters.

https://support.pix4d.com/hc/en-us/articles/210663886


Principal Point x [mm] The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

 

Principal Point y [mm] The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

 

Radial Distortion K1: Radial distortion of the K1 lens.
Radial Distortion K2: Radial distortion of the K2 lens.
Radial Distortion K3: Radial distortion of the K3 lens.
Tangential Distortion T1: Tangential distortion of the T1 lens.
Tangential Distortion T2: Tangential distortion of the T2 lens.

Tip: If the radial and tangential distortions of the lens are not known, it is recommended to set the values for K1, K2, K3, T1, T2 to 0. For more
information about how to calibrate a perspective camera: 206065716.

Note: For more information about how the internal parameters for a perspective lens are defined: 202559089.

 

Fisheye lens

To edit values in pixels, select the radio button on the left of the Image width [pixels] text box. To edit values in millimeters, select the radio button on the left of
the Sensor width [mm] text box.

 

Internal Camera Parameters for Fisheye lens
Camera Model Name Name for the camera model.
Image Width [pixel] The image width in pixels. This value cannot be edited. It is read from the image file information.
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Image Height [pixel] The image height in pixels. This value cannot be edited. It is read from the image file information.
Principal Point x [pixel] The x image coordinate of the principal point in pixels. The principal point is located around the center of the image. The

coordinate system has its origin as displayed here:

 

Principal Point y [pixel] The y image coordinate of the principal point in pixels. The principal point is located around the center of the image. The
coordinate system has its origin as displayed here:

 

Sensor Width [mm] The sensor width in millimeters. If the sensor width is estimated from the EXIF and no information is in the image EXIF data, the
sensor width is set to 36[mm].

Sensor Height [mm] The sensor height in millimeters. If the sensor height is estimated from the EXIF and no information is in the image EXIF data, the
sensor width is set to 36 [mm] and the sensor height is computed in such a way that the ratio sensor width / sensor height
in millimeters equals the ratio image width / image height in pixels.

Pixel Size [μm] The size of the pixel is read from the EXIF data if the information is available. If there is no information related to the pixel size,
then it is calculated in order to correspond to 36 x 24 mm sensor size.

 Principal Point x [mm] The x image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

 

 Principal Point y [mm] The y image coordinate of the principal point in millimeters. The principal point is located around the center of the sensor. The
coordinate system has its origin as displayed here:

 

Polynomial Coefficients 4 different type of polynomials can be selected from a drop-down list, where 1,2 or 3 values are already pre-defined and cannot be
changed:

0-1-x-x-0
x-1-x-x-0
0-1-x-x-x: recommended
x-1-x-x-x: ignores an area around the image center. This is useful when the center is blurry or contains a lot of noise

Camera Model with Symmetric
Affine Transformation

If selected, the model is symmetric and C=D and E=F=0. This is useful when the circular image cannot be modeled by a sphere.

Affine Transformation C Affine transformation C value.
Affine Transformation D Affine transformation D value.
Affine Transformation E Affine transformation E value.
Affine Transformation F Affine transformation F value.

Note: For more information about how the internal parameters for a fisheye lens are defined: 202559089.

Tip: For more information about how to calibrate a fisheye camera: 202557009.
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Access: On the Menu bar, click Project > Image Properties Editor...

Access via the New Project wizard: When creating a new project, the Image Properties Editor window appears after loading the images.

This table is used to describe and edit the information and the status of the images used for the project.

 

The following actions can be performed on the table:

Sorting the table
Selecting Images
Editing Values

 

The table has as many rows as the amount of images in the project. Each row displays information for one image: 

Status of the image (Enabled)
Image
Group
Camera model (Multi-camera model projects)
First coordinate
Second coordinate
Third coordinate
Accuracy Horz
Accuracy Vert
Omega 
Phi 
Kappa 

 

Actions on the table

Sorting the table

 

 



By clicking the column Image, the title will be used to sort the table, it will be ordered from the smallest to the highest value. By clicking again the column, the
title already used for sorting, will be switched from smallest to highest and from highest to smaller and vice versa.

A triangle indicates which column title is used for sorting and the type of sorting:

Smallest to highest values. Highest to smallest values.

Selecting images
Selecting an image

Left click any of the image's cells. The row corresponding to the selected image is displayed in blue.
Selecting multiple images

For images that are displayed one after the other: Press the Shift key and left click the first and last images to be selected. The rows corresponding to the
selected images are displayed in blue. Alternatively, left click one image and while keeping the left button clicked, move the mouse up or down.

For images that are not displayed one after the other: Press the Control key and left click all the images to be selected. The rows corresponding to the selected
images are displayed in blue.
Editing values
Editing one image

For the Enabled column:

1. Click the box (the status switch between selected / unselected).

For the Group column:

1. Double click the cell.
2. Type the new value or click the left arrow to select among the existing values.
3. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Double click the cell.
2. Type the new value.
3. Click Enter or click outside the cell.

Editing all the values for one column

For the Enabled column:

1. Right click one cell of the column.
2. Click Enabled All Images or Disable All Images.

For the Group column:

1. Right click one cell of  the column.
2. Click Edit All Groups.
3. Type the new value or click the left arrow to select among the existing values.
4. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Right click one cell of the column.
2. Click Edit All Altitudes / Horz. Accuracies / Vert. Accuracies.
2. Type the new value.
3. Click Enter or click outside the cell.



Editing the selected rows values for one column

Select multiple images and:

For the Enabled column:

1. Right click one of the selected cells of the column.
2. Click Enabled Selected Images or Disable Selected Images.

For the Group column:

1. Right click one of the selected cells of the column.
2. Click Edit Groups in Selected Rows.
3. Type the new value or click the left arrow to select among the existing values.
4. Click Enter or click outside the cell.

For the Latitude, Longitude, Altitude, Accuracy Horz or Accuracy Vert columns:

1. Right click one of the selected cells of the column.
2. Click Edit Altitudes / Horz. Accuracies / Vert. Accuracies in Selected Rows.
2. Type the new value.
3. Click Enter or click outside the cell.

 

Status of the image (Enabled)

The status of the image is displayed in the Enabled column. It is defined by a box that indicates if the image is used for the processing or not. If the box is
selected, the image is enabled and is used for the processing.

To select or unselect an image: Left click on the box.

Note: The disabled images are not deleted from the project in case of further need to use them.

 

Image

This column displays the name of the images. It cannot be edited. 

 

Group

When processing images that belong to different groups, all images are processed together, generating:

One point cloud of automatic tie points for the whole project. The color of the automatic tie points will be mixed: some points will take color from the RGB images
and others from the NIRGB images.
One densified point cloud per group. 
One DSM for the whole project.
One orthomosaic per group.

Important: Images taken by the same camera during different flights should not be grouped into different groups, unless there is need to generate different
orthomosaics for each data.

Tip: Use the groups to group images with different spectral signatures (RGB, NIRGB, etc). In this case different reflectance maps are generated that can
be used for index calculations. For more information about index calculations: 202558289. 

By default the images that have the same number and type of bands as well as the images with the same pixel type (byte, float) will be grouped as group1.
Images with different bands and pixel type will be grouped as group2, group3, etc. To change the group of one image, double click on the corresponding cell and
edit the group. For more information about editing the group of multiple images: 202557949.

Important: When having more than one group, the Google files (Google Maps tiles and .kml) will only be generated if one of the groups is
named RGB (capital letters). Then the Google files will be generated only for this group.

 

Camera model (Multi-camera model projects)

For projects with more than one camera model, this column displays the camera model assigned to the corresponding images. 

To change the camera model of one image, double click on the corresponding cell. Click on the arrow that appears and, from the drop-down list, choose the
desired camera model. 

Note: The camera model can only be chosen among a list of detected camera models for the project.

 

 

 

 

 



First Coordinate

The first coordinate is:

Latitude [degree]: If the coordinate system of the images is a geographic coordinate system.
X [m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.
X [feet]: If the coordinate system of the images is a projected coordinate system.  The unit is given in feet.
Local X [m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXIF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: double click on the corresponding cell and enter the coordinate.

Note: If no image geolocation has been imported then the value of the cells is zero (0.000).

 

Second coordinate

The second coordinate is:

Longitude [degree]: If the coordinate system of the images a geographic coordinate system. 
Y [m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.
Y [feet]: If the coordinate system of the images is a projected coordinate system. The unit is given in feet.
Local Y [m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXIF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the coordinate.

Note: If no image geolocation has been imported then the value of the cells is zero (0.000).

 

Third Coordinate

The third coordinate is:

Altitude [m]: If the coordinate system of the images is a geographic coordinate system. 
Z [m]: If the coordinate system of the images is a projected coordinate system. The unit is given in meters.
Z [feet]: If the coordinate system of the images is a projected coordinate system. The unit is given in feet.
Local Z [m]: If the coordinate system is defined by the user (local coordinate system). The unit is given in meters.

The coordinate columns are filled:

When importing the coordinates from the image EXIF data if the information exists.
When importing the coordinates from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the coordinate.

Note: If no image geolocation has been imported then the value for the cells is zero (0.000).

Warning: 
The Z coordinate must be given in the same unit as the (X,Y) coordinates (meters or feet).
All image geolocation coordinates have to be given in the same coordinate system.

 

Accuracy Horz

Defines the horizontal accuracy value (Accuracy Horz). The horizontal accuracy refers to the first and second coordinates (latitude, longitude, or X,Y) of the
images.

Very accurate image geolocation (latitude, longitude, or X,Y) coordinates: Low accuracy value.
Non accurate image geolocation (latitude, longitude, or X,Y) coordinates: High accuracy value.

The higher the accuracy value, the less impact the image's coordinates will have on the Initial Processing, compared to other images or GCPs with lower
accuracy values. The accuracy is a value between 0.001 and 10'000. 

Warning: The horizontal accuracy must be given in meters or feet according to the selected coordinate system.

 

 

 

 

 



To edit the horizontal accuracy of one image, double click on the corresponding cell and enter the new value. For more information about editing the horizontal
accuracy of multiple images, see Actions on the table.

 

Accuracy Vert

Defines the vertical accuracy value (Accuracy Vert). The vertical accuracy refers to the third coordinate (altitude or Z) of the images.

Very accurate image geolocation (altitude or Z) coordinate: Low accuracy value.
Non accurate image geolocation (altitude or Z) coordinate: High accuracy value.

The higher the accuracy value, the less impact the image´s coordinate will have on the Initial Processing, compared to other images or GCPs with lower
accuracy values. The accuracy is a value between 0.001 and 10'000. 

Warning: The vertical accuracy must be given in meters or feet according to the selected coordinate system.

To edit the vertical accuracy of one image, double click on the corresponding cell and enter the new value. For more information about editing the vertical
accuracy of multiple images, see Actions on the table.

Omega

Omega (ω) is the rotation around the Χ-axis. It is given in degrees.

The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969.

 

Phi

Phi (φ) is the rotation around the Y-axis. It is given in degrees.

The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969. 

 

Kappa

Kappa (κ) is the rotation around the Z-axis. It is given in degrees.

The rotation columns are filled:

When importing the angles from the image geolocation file.
When manually editing the table: Double click on the corresponding cell and enter the angle.

This value is optional as Pix4Dmapper does NOT require the orientation of the camera in order to process the projects.
For more information about how Pix4Dmapper defines the Omega - Phi - Kappa angles: 202558969.
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Access: On the Menu bar, click Project > GCP/MTP Manager...

The GCP/MTP Manager pop-up has the following 3 sections:

GCP Coordinate System: Section to select the coordinate system on which the GCPs/MTPs/Check Points position are based.
GCP/MTP Table: Section to:
Import, edit, add and remove GCPs/MTPs/Check Points
Export GCPs/Check Points coordinates and, optionally for GCPs, the accuracy of the coordinates.
Import or export a file with the image coordinates of the GCPs/MTPs/Check Points and on which images have been marked, in which position and at which zoom
level.
GCP/MTP Editor: Section to mark the GCPs/MTPs/Check Points on the images. 

And the action buttons:

OK: Confirms the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click Project > GCP/MTP Manager...

The GCP Coordinate System section is used to define the coordinate system on which the GCPs/MTPs/Check Points position are based.

Datum: Represents the selected images' datum. By default the selected Datum is World Geodetic System 1984.
Coordinate system: Represents the selected images' coordinate system.

 When the selected coordinate system is a Geographic Coordinate System.

 When the selected coordinate system is a Projected Coordinate System.

Vertical coordinate system or Geoid Height Above the Ellipsoid: It is displayed in parenthesis. It represents the vertical coordinate system / Geoid Height Above
the used ellipsoid that will be used to convert the GCPs height from geoid to ellipsoidal. For more information about when to use this function: 202559459.
Edit...: Opens the Select GCP Coordinate System pop-up that allows to change the selected coordinate system.
For more information: 202558239.
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Access: On the Menu bar, click Project > GCP/MTP Manager...

This section contains a GCP/MTP Table which displays all the GCPs/MTPs/Check Points of the projects together with their properties, and 6 action buttons:

Import GCPs...: Allows the user to import a file with GCPs/Check points.
Export GCPs...: Allows the user to export GCPs/Check Points coordinates and, optionally for GCPs, the accuracy of the coordinates.
Add Point : Allows the user to manually add one by one GCPs/MTPs/Check Points.
Remove Points : Allows the user to remove the selected GCPs/MTPs/Check Points.
Import Marks...: Allows the user to import a file which contains, for each GCPs/MTPs/Check Points list of the marked images and, for each image, the
coordinates and zoom level.
Export Marks...:  Allows the user to export a file which contains, for each GCPs/MTPs/Check Points list of the marked images and, for each image, the
coordinates and zoom level.

In the bottom left side, a status text appears indicating how many GCPs are implemented in the project and marked in at least 2 images.
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Access: On the Menu bar, click Project > GCP/MTP Manager..., on the GCP/MTP Table section, click Import GCPs...

Pix4Dmapper can import a file with the coordinates of the GCPs. For more information about the file format: 202558539.

When clicking Import GCPs..., the Import Ground Control Points pop-up appears:

It contains the following sections:

Coordinates Order: Allows the user to select the order of the coordinates of the file to be imported. Depending the coordinate system, there are the following
possibilities: 
Latitude, Longitude, Altitude or Longitude, Latitude, Altitude (only if a geographic coordinate system is selected).
X, Y, Z, or Y, X, Z. 
File: Displays the name of the selected file to be imported.

And the action buttons:

Browse...: Opens the Select GCPs File, a navigation window used to search for and select the file to be imported.

OK: Imports the selected file.
Cancel: Does not save the changes and exits the pop-up.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click Project > GCP/MTP Manager..., on GCP/MTP Table, click Add Point.

This button is used to manually add GCPs/MTPs/Check Points one by one. 

Note: Before adding the points, their coordinate system needs to be defined. For more information: 202557749.

Warning: All GCPs/MTPs/Check Points need to be defined in the same coordinate system.

The Add Point button allows the user to add a new point in the GCP/MTP Table. The Type is by default set to Manual Tie Point. The label is automatically
generated and starts by "mtp" followed by a number that increases with the number of points added (e.g. mtp1, mtp2, mtp3, etc.). The labels are automatically
generated when adding a point in the GCP/MTP Manager by clicking the Add Point button or when adding a point or an object in the rayCloud. The point type can
be changed by double clicking on the Type cell and selecting the desired type.

For more information about the GCP/MTP Table properties: 202557919.
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Access: On the Menu bar, click Project > GCP/MTP Manager..., on GCP/MTP Table, click Remove Points.

When clicking Remove Points the GCPs/MTPs/Check Points that are displayed on the GCP/MTP Table can be removed. One or multiple points can be selected
from the GCP/MTP Table and be removed by clicking Remove Points. For more information about how to select a point on the GCP/MTP Table: 202557919.
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Access: On the Menu bar, click Project > GCP/MTP Manager..., on GCP/MTP Table, click Import / Export Marks...

Import Marks...

Pix4Dmapper can import a file with the image coordinates of the GCPs / MTPs. For more information about the file format: 202558539.

Warning: The zoom level at which GCPs / MTPs are marked has an impact on the GCP / MTP error obtained in the Quality Report. Usually the higher
the zoom level, the more precisely the GCP / MTP is marked. These GCPs / MTPs will have a bigger impact on the reconstructed model than GCPs /
MTPs marked on a lower zoom level; lower error values are also expected for these GCPs / MTPs. For example, when GCPs / MTPs are marked without
zooming into the images, the GCP / MTP error can be 10 times higher than when the GCPs / MTPs are marked by zooming into the images.

When clicking Import Marks..., the Select Import Image Marks File pop-up appears:

 

 

https://support.pix4d.com/hc/en-us/articles/202558539


Navigation menu, to select the location to store the file.
On File name, type the name of the file.
The Save as type displays the file format used to save the file: 
Pix4D marks files (*.txt, *.csv): 202558539.
Bingo text file (*.txt): 202558539.
XML structure (*.xml): 202558539.
Save: Saves the file.
Cancel: Does not save the file and exits the pop-up.

Export Marks...

Once the GCPs / MTPs are marked on the images, Pix4Dmapper can export the image coordinates of the GCPs / MTPs. This option allows the user to use the
same GCPs / MTPs with the same images the next time the project has to be processed (e.g. merging with another project, adding new images to the current
project) without having to manually mark the GCPs / MTPs again.

Warning: The zoom level at which GCPs / MTPs are marked has an impact on the GCP / MTP error obtained in the Quality Report. Usually the higher
the zoom level, the more precisely the GCP / MTP is marked. These GCPs / MTPs will have a bigger impact on the reconstructed model than GCPs
marked on a lower zoom level; lower error values are also expected for these GCPs / MTPs. For example, when GCPs / MTPs are marked without
zooming into the images, the GCP / MTP error can be 10 times higher than when the GCPs / MTPs are marked by zooming into the images.

When clicking Export Marks..., the Export Image Marks pop-up appears:

 

https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539
https://support.pix4d.com/hc/en-us/articles/202558539


Navigation menu, to select the location to store the file.
On File name, type the name of the file.
The Save as type displays the file format used to save the file:
Pix4D marks files (*.txt, *.csv): 202558539.
Bingo text file (*.txt): 202558539.
XML structure (*.xml): 202558539.
When Pix4D marks files is selected, the Pix4D Marks File Options pop-up appears:

Marks's Zoom Level check box: Exports the zoom level at which the GCPs / MTPs are marked on the images.
Image Directory check box: Exports the directory of the images.
Data Seperator: Sets the character used to separate the values in the file. The drop down list has the following options:
Comma (default)
Semicolon
Tab
Space
Save: Saves the file.
Cancel: Does not save the file and exits the pop-up.

 

For step by step instructions about how to export the marks of the GCPs / MTPs: 204924709.
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Access: On the Menu bar, click Project > GCP/MTP Manager...

Allows the user to mark/edit the GCPs/MTPs/Check Points in the initial images. There are 2 options:

rayCloud Editor...: Available only if step 1. Initial Processing has been completed. It opens the left sidebar of the rayCloud. 
Basic Editor...: Available even if no processing step has been completed. It opens the Basic GCP/MTP Editor pop-up. 
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

The Basic GCP/MTP Editor pop-up has the following 3 sections:

GCP/MTP Table: Section that allows the user to edit the GCPs/MTPs/Check Points values and status.
Images: A list with all the images.
Preview: Section where the GCPs / MTP / Check Points are marked on the image.

And the action buttons:

GCP/MTP Manager: Closes the Basic GCP / MTP Editor and goes back to the GCP/MTP Manager.
OK: Confirms the changes.
Cancel: Does not save the changes and exits the pop-up.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

This section allows the user to view the GCPs/MTPs/Check Points, values and status.

 

Next to the section title GCP/MTP Table, the coordinate system of the GCPs is displayed.

This section contains a Ground Control Points Table which displays all the GCPs of the projects together with their properties.
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https://support.pix4d.com/hc/en-us/articles/202557919
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

This section displays a list of all the project's images. 

For each selected point on the GCP/MTP Table section, the Images section is shown with: 

Green color: The images on which the point has been marked.
Black color: The images on which the point has not been marked.

 

The images can be sorted according to three different criteria by clicking on the corresponding buttons:

 Sort Images by Name.
 Sort Images by the Distance to GCP.
 Sort Images by the Distance to the marked Images.

There is one context menu for the Images section that can be accessed by right clicking on one image. The context menu gives access to the following action:

Remove Mark: Deletes the marked point that appears on this image.

 

Sort Images by Name

The images are sorted alphabetically by name.  

 
Sort Images by the Distance to GCP

The images are sorted by distance to the GCP (closest image to the GCP is displayed first).  This sorting is selected by default when 2D GCPs, 3D GCPs or

 



Check points have been imported into the project. This sorting is recommended to easily find images on which GCPs or Check points may appear.

Note: Non geolocated images are displayed at the bottom of the list.

 

Sort Images by the Distance to the Marked Images

The images are sorted by distance to the marked images (closest image to the marked images is displayed first). This sorting is recommended to easily find
images on which Manual Tie Points appear. It can be used after having marked the Manual Tie Point on at least one image.

Note: Non geolocated images are displayed at the bottom of the list.
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Access: On the Menu bar, click Project > GCP/MTP Manager... The GCP/MTP Manager window opens. In the GCP/MTP Editor section, click Basic
Editor...

This section is used to mark the GCPs/MTPs/Check Points on the images.

Important: Each point needs to be marked on at least 2 images to be taken into account in processing. It is recommended to mark each point in at least
4-5 images.

Important: The zoom level at which GCPs are marked has an impact on the GCP error obtained in the Quality Report. Usually the higher the zoom level,
the more precisely the GCP is marked. These GCPs will have more impact on the reconstructed model than GCPs marked in a lower zoom level and
lower error values are expected for those GCPs. For example, when GCPs are marked without zooming into the images, the GCP error can be 10 times
higher than when GCPs are marked by zooming into the images.

 

When the Basic GCP/MTP Editor is opened the first time, no image is displayed in the Preview section. Once points are imported from a file or once a new point
has been added, the first image is displayed in the Preview section. 

The following actions are available:

Zoom in: Move the mouse scroll wheel forwards.
Zoom out: Move the mouse scroll wheel backwards.
Pan: Press the left mouse button and move the mouse.
Zoom in instantly to a specific point: Hover the mouse on the point of interest while pressing the Alt key.
Zoom out instantly to zero zoom level: Hover the mouse on the point of interest while pressing the Shift key.
Mark a point: Left click on the point on the image.

 

 

 

 



In the right part of the Preview section there is a control panel to navigate in the image:

 Left arrow button: Moves to the left part of the image (when the image is zoomed in).

 Right arrow button: Moves to the right part of the image (when the image is zoomed in).

 Up arrow button: Moves to the top part of the image (when the image is zoomed in).

 Down arrow button: Moves to the bottom part of the image (when the image is zoomed in).

 Reset view button:  Zooms out to zero zoom level.

 Zoom in button: Zooms in.

Zoom slider: Zooms in or out.
In: Move the slider up.
Out: Move the slider down.

 Zoom out button: Zooms out.

 Remove button: Removes the marked point (if any) from the image displayed in the Preview section. If there is no mark in the image displayed in the Preview

section, the Remove button is grayed out. 
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Access: On the Menu bar, click Project > Select Output Coordinate System...

Important: The output coordinate system does not need to be the same as the image geolocation coordinate system or the GCPs coordinate system.
By default, the output coordinate system is the same as the GCPs coordinate system if GCPs are used, otherwise it is the same as the image
geolocation coordinate system. If the coordinates system is WGS84, the output is given in the corresponding UTM zone.

If less than 3 images are geolocated and less than 3 GCPs are defined, then the output coordinates system is set to "Arbitrary".

The Select Output Coordinate System pop-up allows the user to choose the coordinate system of the outputs.

 

For a full description of the Select Output Coordinate System pop-up: 202558239.

 

Index > Interface > Menu Project  Previous  |  Next  
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Access: On the Menu bar, click Process.

The following items can be selected:

Reoptimize: Reoptimizes the camera positions using information from GCPs/ Manual Tie Points that are added after step 1. Initial Processing.
Rematch and Optimize: Computes more matches between the images (and therefore more Automatic Tie Points) and reoptimizes the internal and external
camera parameters.
Quality Report...: Opens the Quality Report in a new window.
Open Results Folder...: Opens an explorer window with the path where the project outputs are stored.
Output Status...: Shows the status of the generated output files.
Generate Quality Report: Generates a new Quality Report according to the new reconstruction obtained after applying changes to the project after step 1. Initial
Processing.
Save Undistorted Images: Generates and saves an undistorted copy of each original image using the optimized distortion camera parameters.
Run Point Cloud Classification: Generates a point cloud classification using the densified point cloud that is generated during step 2. Point Cloud and Mesh.
Generate 3D Textured Mesh: Generates a 3D Textured Mesh based on triangles using a simplified densified point cloud.
Import Point Cloud for DSM Generation...: Allows the user to import a point cloud that will be used to generate the DSM and orthomosaic.
Generate DTM: Generates a DTM based on the DSM and a mask representing the terrain/objects.
Generate Contour Lines (DSM): Generates the contour lines specified in the Processing Options using the raster DSM.
Generate Contour Lines (DTM): Generates the contour lines specified in the Processing Options using the raster DTM, if it has been generated.
Send Elevation Data (DSM) to eMotion: (only if senseFly eMotion is installed) Sends a DSM generated in Pix4Dmapper to eMotion.
Send Map to eMotion: (only if senseFly eMotion is installed) Sends an orthomosaic generated in Pix4Dmapper to eMotion.
Processing Options...: Opens a pop-up that allows the user to select the processing options and/or the processing options template.
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https://support.pix4d.com/hc/en-us/articles/115004864586
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Access: On the Menu bar, click Process > Reoptimize (enabled once step 1. Initial Processing has been completed).

This process reoptimizes the internal and external camera parameters. It should be used when changes have been applied to the project after step 1. Initial
Processing has been completed. Such changes can be:

Adding GCPs.
Adding Manual Tie points.
Adding Check points.
Changing coordinate systems.
Disable images.

Important: Disabled or uncalibrated cameras will not be taken into account. For more information about how to calibrate uncalibrated
cameras: 202560189.

Warning: 
Results generated during step 1. Initial Processing are overwritten.
The Quality Report is deleted. To generate a new Quality Report: 202558319. 
If step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index have been processed, their results files will be deleted so these files should be
backed up. 
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https://support.pix4d.com/hc/en-us/articles/202560189
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Access: On the Menu bar, click Process > Rematch and Optimize (enabled once step 1. Initial Processing has been completed).

This process computes more matches between the images (and therefore more Automatic Tie Points), and reoptimizes the internal and external camera
parameters. It is recommended to use it:

After manually calibrating cameras that were not initially calibrated.
For difficult projects where few matches were initially found.
To merge individual projects that do not share common images.
To optimize step 1. Initial Processing by re-matching images. For projects with more than 500 images, this process is unselected and disabled in the processing
options. 

Note: For large projects (more than 500 images), the Rematch and Optimize feature significantly increases processing time.

Important: Disabled or uncalibrated cameras will not be taken into account. For more information about how to calibrate uncalibrated
cameras: 202560189.

Warning: 
Results generated during step 1. Initial Processing are overwritten.
The Quality Report is deleted. To generate a new Quality Report: 202558319.
If step 2. Point Cloud and Mesh and step 3. DSM, Orthomosaic and Index have been processed, their result files will be deleted so these files should be
backed up.
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https://support.pix4d.com/hc/en-us/articles/202560189


Index > Interface > Menu Process  Previous  |  Next  

 

Access: On the Menu bar, click Process > Quality Report... (active once step 1. Initial Processing has been completed). The Quality Report opens in a
pop-up window.

Important: 
For a detailed description about how to analyze the Quality Report: 202558689.
For a detailed description about the parameters described in the Quality Report: 202558679.
For a description about how to analyze the Quality Report: 202557339.
Example of a Quality Report available at the following link: Quality Report.

 

 

https://support.pix4d.com/hc/en-us/articles/202558689
https://support.pix4d.com/hc/en-us/articles/202558679
https://support.pix4d.com/hc/en-us/articles/mining_quarry_withGCPS_report.pdf
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Access: On the Menu bar, click Process > Open Results Folder...

Important: 
For a detailed description of the folder structure: 20255864.
For more information about the output files: 202558509.
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https://support.pix4d.com/hc/en-us/articles/202558649
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Access: On the menu bar, click Process > Output Status... The pop-up Output Status appears.

The pop-up Output Status displays:

The processing step that is being processed.
The processing steps that have already been processed.
The processing steps that cannot be processed with the current version of Pix4Dmapper. For more information: 204162839.
The output files that are selected to be generated.
The output file that is being generated.
The output files that have already been generated.
The output files that can be generated with the current version of Pix4Dmapper. For more information: 204162839.
The formats of the output files selected to be generated.
The dependencies between the output files.
Information and links to the processing options and the results folders about the output files. 

 

 The pop-up Output Status consists of:

Processing steps
Output files
Display options

 

Processing steps
The three processing steps, 1. Initial Processing, 2. Point Cloud and Mesh and 3. DSM, Orthomosaic and Index appear in the pop-up Output Status.

 

https://support.pix4d.com/hc/en-us/articles/204162839
https://support.pix4d.com/hc/en-us/articles/204162839


 

The processing steps can be:

Transparent: If the processing step is not processed yet.
Orange: If the processing step is being processed.
Green: If the processing step is already processed.
Grayed out: If the processing step is not available in the current version of Pix4Dmapper. For more information: 204162839.

Processing
step not
processed yet.

Processing
step being
processed.

 Processing
step
processed.

 Processing
step grayed
out.

Important: When no Output Files are selected for step 3. DSM, Orthomosaic and Index, step 3. DSM, Orthomosaic and Index is grayed out and cannot
be processed.

 

Output files
The output files can be:

White: If the output file is not generated yet.
Orange: If the output file is being generated.
Green: If the output file is already generated.
Grayed out: If the output file is not selected to be generated or if the output file is not available in the current version of Pix4Dmapper. For more
information: 204162839.

 Output file selected to
be generated. Output file being generated. Output file being generated.  Output file not selected to

be generated.

 

For each processing step, the following output files are displayed:

1. Initial Processing:

Quality Report
Camera Internals and Externals, AAT, BBA
Undistorted Images

Note: The Camera Internals and Externals, AAT and BBA and the Undistorted Images are displayed only when the Advanced box is selected.

 

 

https://support.pix4d.com/hc/en-us/articles/204162839
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 2. Point Cloud and Mesh:

Densified Point Cloud
3D Textured Mesh

3. DSM, Orthomosaic and Index:

Grid DSM
Raster DSM
Contour Lines (based on the Raster DSM)
Raster DTM
Contour lines (based on the Raster DTM)
Orthomosaic
Google Maps Tiles and KML
Reflectance Map
Index Map

 

In each output file box, the different selected output file formats are displayed. 

Example: For the Densified Point Cloud, the .las, .laz, .ply and .xyz file formats are selected.     

    

 

Some output files are indented and connected to other output files with arrows. These arrows represent the dependencies between the different output files. If the
initial output file is not selected, the dependent one cannot be generated and it is grayed out. 

Example: The Contour Lines (based on the Raster DTM) depend on the generation of the Raster DTM.   

 

 



    

 

When clicking an output file box, the box extends. The extended box contains:

A description of the output file.
A link to the processing options of this output file.
A link to the results folder directory of the output file.

Description of the output file. Open the processing options for this output
file. Open the results folder for this output file.

 

Display options
The drop-down list Display Options selects the output files to be displayed. The display options are the following:

Disabled: The output files not selected or not available in the current version of Pix4Dmapper are displayed. 
To do: The output files selected to be generated are displayed.
In Progress: The output files being generated are displayed.
Done: The output files already generated are displayed.

If the box Advanced is selected, the advanced output files are shown.

 

And the action buttons:

Close: Closes the pop-up Output Status.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click Process > Generate Quality Report (enabled once step 1. Initial Processing has been completed).

This process generates a new Quality Report that refers to the new reconstruction obtained after applying changes to the project once step 1. Initial
Processing has been completed. Such changes can be:

Adding GCPs.
Adding Manual Tie Points.
Adding Check Points.
Changing coordinate systems.
Enabling/disabling images.
Running the Rematch and Optimize option.

Important: When adding GCPs, Manual Tie Points, Check Points, changing coordinate systems or enabling/disabling images, the Reoptimize option has
to be applied before generating the new Quality Report.
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Access: On the Menu bar, click Process > Save Undistorted Images (active once step 1. Initial Processing has been completed).

This process generates an undistorted copy of each original image using the optimized distortion parameters of the selected camera model.

Important: 
This process is only available when processing images using a perspective lens camera model.
The undistorted images will only be generated for the calibrated images. 

Information: For more information about camera distortion: 202559069.

Original image: The square grid is distorted because of the lens of the camera. Undistorted image: The square grid is now perfectly aligned.
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Access: On the Menu bar, click Process > Run Point Cloud Classification (active once step 2. Point Cloud and Mesh has been completed).

This process classifies the points of the Densified Point Cloud in 5 predefined groups: 

Ground
Road Surface
High Vegetation
Building
Human Made Object

Warning: When reprocessing step 2. Point Cloud and Mesh, the existing outputs and all edits will be deleted and overwritten.
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Access: On the Menu bar, click Process > Generate 3D Textured Mesh (active once step 2. Point Cloud and Mesh has been completed).

This process generates a 3D Textured Mesh based on triangles using the Densified Point Cloud. 

Important: By default, by clicking Process > Generate 3D Textured Mesh, the 3D Textured Mesh will be generated: 
In .p4b format, only readable in the rayCloud:
project_name\2_densification\project_data\project_name_3d_mesh.p4b
In .obj format:
project_name\2_densification\3d_mesh\project_name_simplified_3d_mesh.obj
In .fbx format:
project_name\2_densification\3d_mesh\project_name_simplified_3d_mesh.fbx

In order not to generate the .obj or .fbx files and/or generate other outputs (.ply, .dxf, .pdf) before clicking Process > Generate 3D Textured Mesh, change
the processing options and click OK. For more information: 202557799.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

Important: The 3D Textured Mesh will be generated using the Densified Point Cloud. If any Processing Area and/or image annotation is defined, and if the
corresponding options are selected in the Point Cloud Filters options, they will also be used for the 3D Textured Mesh generation. 

These options are available on the Menu bar, by clicking Process > Processing Options... and selecting 2. Point Cloud and Mesh. For more information:
202557799.

Important: If the 3D Textured Mesh has holes or is not planar in planar surfaces, it can be improved in the rayCloud. For more information: 211083803.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202560669
https://support.pix4d.com/hc/en-us/articles/211083803


3D Textured Mesh
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Access: On the Menu bar, click Process > Generate DTM (enabled once the Raster DSM is generated and the tiles of the Raster DSM are merged).

This process takes as input the merged Raster DSM (Digital Surface Model), computes a classification mask and generates the Raster DTM (Digital Terrain
Model).

DTM of the center of the city of Lausanne DSM of the center of the city of Lausanne
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Access: On the Menu bar, click Process > Import Point Cloud for DSM Generation... (enabled once step 1. Initial Processing has been completed).

This process allows to import a point cloud to generate the DSM and the orthomosaic.

Once the point cloud has been imported, step 3. DSM, Orthomosaic and Index needs to be processed to generate the DSM and the orthomosaic.

It opens the pop-up Select Point Cloud, which allows to navigate to the path where the point cloud to be imported is stored and select it.

The accepted formats are: 

.xyz

.las

.laz

It contains the action buttons:

Open: Confirms the importation of the selected file.
Cancel: Does not import any file and closes the pop-up.

Warning: 
The external point cloud needs to be in the same coordinate system as the output coordinate system.
The external point cloud needs to be aligned with the model generated in Pix4Dmapper. This can be achieved with common GCPs.
If step 3. DSM, Orthomosaic and Index has already been completed for this project, existing results are overwritten when running step 3 again.

Important: 
The imported point cloud cannot be visualized in the rayCloud.
If step 2. Point Cloud and Mesh has been completed, its results are not used for the DSM and orthomosaic generation.
The imported point cloud will be used to generate the DSM.
The original images are projected on the DSM in order to obtain the orthomosaic.
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Video: Watch the instructional video related to Contour Lines and DTM: here.

Access: On the Menu bar, click Process > Generate Contour Lines (DSM or DTM) (active once step 3. DSM, Orthomosaic and Index has been
completed and if any Contour Lines format is selected in the processing options). For step by step instructions: 202560639.

Important: This process generates the contour lines using : 
the Raster DTM, if it is already generated. For more information about contour lines using the DTM: 217262006.
the Raster DSM, if the raster DTM is not generated or if the DTM tiles are not merged. For more information about contour lines using the
DSM: 202559879.

Important: The option to generate the Contour Lines is grayed out if the option to merge the tiles of Raster DSM or Raster DTM are disabled. For more
information about the options of the Raster DSM: 202557769 and the Raster DTM: 202558419.

Note: 
If contour lines with the same Elevation Interval are already generated, they will be overwritten.
If the Contour Lines have been selected in the processing options, they will be generated when processing step 3. DSM, Orthomosaic and Index.

 

 

 

 

 

https://www.youtube.com/watch?v=NjCiTHTKXr8
https://support.pix4d.com/hc/en-us/articles/202560639
https://support.pix4d.com/hc/en-us/articles/217262006
https://support.pix4d.com/hc/en-us/articles/202559879


Contour lines
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Access: On the Menu bar, click Process > Send Elevation Data (DSM) to eMotion. Only available when eMotion (by senseFly) is installed on the same
device and step 1. Initial Processing is completed.

Important:  
If step 1. Initial Processing is processed, the Automatic Tie Points are used for the eMotion DSM generation. The same applies if step 1. Initial
Processing and step 3. DSM, Orthomosaic and Index are processed.
If step 2. Point Cloud and Mesh is processed, the densified point cloud is used for the eMotion DSM generation.
It is possible to generate the DSM that will be sent to eMotion only if the output coordinate system is not set to arbitrary.
The altitude of the DSM that is sent to eMotion refers to the ellipsoid. If the vertical coordinate system is set to a geoid model, a conversion will be
applied. 

 

When clicking Process > Send Elevation Data (DSM) to eMotion, a pop-up appears:

The resolution of the DSM that is sent to eMotion can be set. By default, the resolution of the DSM sent to eMotion is set to 100 cm.

The action buttons:

OK: Generates the DSM that will be sent to eMotion.
Cancel: Cancels the generation of the DSM. 
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Access: On the Menu bar, click Process > Send Map to eMotion. Only available when eMotion (by senseFly) is installed on the same device and step
3. DSM, Orthomosaic and Index is generated.

Important: It is possible to generate the map that will be sent to eMotion only if the output coordinate system is not set to arbitrary.  

When clicking Process > Send Map to eMotion, the Google Maps Tiles and KML are sent.
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Access: On the Menu bar, click Process > Processing Options..., the pop-up Processing Options appears.  

This feature allows to:

View/edit the processing options:
Selecting which outputs are generated and in which format.
Assigning hardware resources to the processing.
Select a processing options template.
Create a new processing options template.
Manage the processing options template.

It contains three sections:

Processing steps and resources: Allows the user to select a step or the resources in order to visualize/edit options.
Tabs associated with the selected step or resources: Allows the user to visualize/edit the processing options, outputs and/or resources for the selected
step/resource.
Processing options template: Allows the user to select a template, save a custom template and manage templates.

And four actions:

OK: Confirms the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.
Advanced options: Displays/hides the advanced options tabs, available for 1. Initial Processing and 2. Point Cloud and Mesh.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only
the General tab appears. On the bottom left, select the Advanced box to display all the tabs.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

General Matching Calibration  

Allows the user to change the processing options and to select what the Quality Report will display. It contains 2 sections:

Keypoints Image Scale: Allows to define the image size used to extract the keypoints.
Quality Report: Allows to select what will be displayed in the Quality Report.

 

 

 



Keypoints Image Scale

Allows to define the image size at which the keypoints are extracted in comparison to the initial size of the images. It is possible to select:

Full: It sets full Image Scale for precise results.
Rapid: It sets a lower Image Scale for fast results.
Custom: Allows the user to select the Image Scale. There are the following options:
Image Scale:

1 (Original image size): This is the recommended Image Scale.
2 (Double image size): For small images (e.g. 640x320 pixels), a scale of 2 (double image size) should be used. More features will be extracted and this will
have a positive impact on the accuracy of the results.
1/2 (Half image size): For large projects with high overlap, a scale of 1/2 (half image size) can be used to speed up processing. This will, usually, result in a
slightly reduced accuracy as less features will be extracted. This scale is also recommended for blurry or low textured images, as it usually results in better
outputs than the full scale for such images.
1/4 (Quarter image size): For very large projects with high overlap, a scale of 1/4 (quarter image size) can be used to speed up processing. This will, usually,
result in a slightly reduced accuracy as less features will be extracted. This scale is also recommended for very blurry or very low textured images, as it
usually results in better outputs than the full scale for such images.
1/8 (Eighth image size): For very large projects with high overlap, a scale of 1/8 (eighth image size) can be used to speed up processing. This will, usually,
result in a slightly reduced accuracy as less features will be extracted. 

 

Quality Report

Allows the user to select what the Quality Report will display.

Generate Orthomosaic Preview in Quality Report: The Quality Report will display a low resolution DSM and Orthomosaic. To display these elements, the Quality
Report generation takes longer. Disabling this option, the Quality Report generation is faster. 

Important: The low resolution DSM is generated using only the Automatic Tie Points. The low resolution Orthomosaic is generated based on this
DSM. Both outputs are expected to be of low quality and should not be used for further analysis.

Note: When processing images that belong to different groups, all images are processed together, generating only one DSM for the whole project,
but generating one Orthomosaic per group using the images associated to that group. For more information about the image groups: 202557949. 
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only
the General tab appears. On the bottom left, select the Advanced box to display the Matching tab.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

General Matching Calibration  

Allows the user to change the processing options related to the keypoints matching for step 1. Initial Processing. It contains 2 sections:

Matching Image Pairs: Allows to select which pairs of images are matched. 
Matching Strategy: Allows to determine how the images are matched.

 

Matching Image Pairs

 



Allows the user to select which pairs of images are matched:

Aerial Grid or Corridor: Optimizes the pair matching for Aerial Grid or Corridor flight paths. 
Free flight or Terrestrial: Optimizes the pair matching for Free-flight paths or Terrestrial images (for example, taking images around a house or a statue). 
Custom (for advanced users): Specific pair matching parameters useful in specific projects. Suggested if one of the above options does not provide the desired
results. It contains the different pair matching parameters:

Important: Higher number of matches will increase the processing time and the quality of the results and may generate results in case of low quality
datasets that failed with the default matching options.

Use Capture Time: Matches images considering the time on which they were taken.
Number of Neighboring Images: It allows the user to set how many images (before and after in time) are used for the pair matching. 
Use Triangulation of Image Geolocation: Only available if the images have geolocation. It is only useful for aerial flights. The position of the images is triangulated.
Each image is matched with images with which it is connected by a triangle.
Use Distance: Only available if the images have geolocation. It is useful for oblique or terrestrial projects. Each image is matched with images within a relative
distance. 
Relative Distance Between Consecutive Images: It allows the user to set the relative distance.

Example: For Relative Distance Between Consecutive Images = 5 and average distance between consecutive images = 2 m:
Pix4Dmapper will multiple the average distance by 5 (2*5 = 10 m). It will create a sphere with center the image and radius 10 m and will
match this image with all other images included in the sphere.

Use Image Similarity: Uses the image content for pairs matching. Matches the n images with most similar content.
Maximum Number of Pairs for Each Image Based on Similarity: Maximum number of image pairs with similar image content to be matched.
Use MTPs: Images connected via a shared Manual Tie Point will be matched.
Maximum Number of Image Pairs per MTP: Maximum number of image pairs connected by a given MTP.
Use Time for Multiple Cameras: When having multiple flights without geolocation using the same flight plan over the same area, and having different camera
models for each flight, it matches the images from one flight with the ones from the other flight using the time information.

 

Matching Strategy

Allows the user to determine how the images are matched:

Use Geometrically Verified Matching: Slower but more robust. If not selected, matches are established using only the image content. If selected, the relative
camera positions are also taken into account to discard geometrically unrealistic matches. Useful when many similar features are present throughout the project:
rows of plants in a farming field, window corners on a building's facade, etc.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 1. Initial Processing. By default, only
the General tab appears. On the bottom left, select the Advanced box to display the Calibration tab.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

General Matching Calibration  

Allows to change the processing options and desired outputs for step 1. Initial Processing. It contains 5 sections:

Targeted Number of Keypoints: Allows to set up the number of keypoints extracted.
Calibration: Allows to select how the camera internal and external parameters are optimized.
Rematch: Allows to add more matches after the first part of the initial processing.
Pre-Processing: Allows to select the pre-processing options.
Export: Allows to select the outputs of step 1.

 

Targeted Number of Keypoints

Allows to set up the number of keypoints to be extracted.

 



Automatic (Default): Automatic way to select which keypoints are extracted.
Custom: Allows to restrict the number of keypoints.
Number of Keypoints: Maximum number of keypoints to be extracted per image.

Information: When extracting the keypoints per image, an internal scoring is assigned to them. Based on this scoring, the best keypoints are selected.

Calibration

Allows to select how the camera internal and external parameters are optimized.

The optimization step consists of running the Automatic Aerial Triangulation (AAT), Bundle Block Adjustment (BBA), and camera self-calibration steps multiple
times, till an optimal reconstruction is achieved:

Calibration Method
Standard (default) 
Alternative: Optimized for aerial nadir images with accurate geolocation, low texture content and relatively flat terrain, fields for example. The calibration will fail if
the number of oblique images (>35 deg) in the dataset is higher than 5%. Furthermore, at least 75% of all images have to be geolocated. 
Accurate Geolocation and Orientation: Optimized for project with very accurate image geolocation and orientation. This calibration method requires all images to
be geolocated and oriented.
Camera Optimization: This option defines which camera parameters are optimized.
All (default): Optimizes all the internal camera parameters. Small cameras such as those used with UAVs, are much more sensitive to temperature or vibrations,
which affect the camera calibration. Therefore, it is recommended to select this option when processing images taken with such cameras.
None: Does not optimize any of the internal camera parameters. It is recommended when using large cameras that are already calibrated and when these
calibration parameters are used for processing.
Leading: Optimizes the most important internal camera parameters. This option is useful to process certain cameras such as cameras with a slow rolling shutter
speed.
Perspective lens camera models: The focal length and the first two radial distortion parameters.
Fisheye lens camera models: The polynomial coefficients.
All Prior: Forces the optimal internal parameters to be close to the initial values. 
All (default): Optimizes the rotation and position of the camera as well as the linear rolling shutter in case the camera model follows the linear rolling shutter
model.In this case the camera model should be defined accordingly: 202558159.
None: Does not optimize any of the external camera parameters. Only enabled when Accurate Geolocation and Orientation has been selected as Calibration
Method. Only recommended when the camera orientation and position are known and very accurate.
Orientation: Optimizes only the orientation of the cameras. Only enabled when Accurate Geolocation and Orientation has been selected as Calibration
Method. Only recommended when the camera position is known and very accurate but the orientation is not as accurate as the camera position.
Internal Parameters Optimization: Defines which internal camera parameters of the camera model are optimized.
External Parameters Optimization: The position and orientation of the cameras. Defines how the external camera parameters are optimized.

Note: 

The Camera Optimization processing options define which camera parameter are optimized. There are 2 types of camera parameters:

Internal camera parameters: The parameters of the camera model.
External camera parameters: The position and orientation of the cameras.

The optimization procedure starts with some initial values in order to compute the optimized values. The following initial values are used:

Internal camera parameters: The initial values are extracted from the camera model that has been chosen.
External camera parameters: The initial values are extracted from the Automatic Aerial Triangulation (AAT) during Step 1. Initial Processing or using the
geolocation and IMU when Accurate Geolocation and Orientation has been selected as Calibration Method.

After step 1. Initial Processing has been completed, the optimized values for the internal and external camera parameters are saved in output files. For
more information about the files generated during step 1. Initial Processing: 202558519.

The initial and optimized values for the internal camera parameters are also displayed in the Quality Report.

 

 

Rematch

Allows to add more matches after the first part of the initial processing, which usually improves the quality of the reconstruction:

Automatic (Default): Enables rematching only for projects with less than 500 images.
Custom: Allows to select if rematch is done or not for the project.
Rematch: Enables the rematch option.

Pre-Processing

Allows to select the pre-processing options:

Automatic Sky Masking: Selected by default and only available for projects consisting of Parrot Bebop images. The Automatic Sky Masking is masking the
pixels that are covered by sky on the images to avoid noise in the point cloud. 

Export

 

 

https://support.pix4d.com/hc/en-us/articles/202558519


Allows to select outputs:

Camera Internals and Externals, AAT, BBA: When this option is selected, the results of the AAT, BBA, and optimized internal and external camera
parameters are exported.
Undistorted Images: When this option is selected, an undistorted copy of each original image is generated using the optimized distortion parameters of the
selected camera model. 

Important: This feature is only available when processing images using a perspective lens camera model.

If step 1. Initial Processing has already been done, it is possible to generate undistorted images without running step 1 again. For more
information: 202557929.

Information: For more information about the camera distortions: 202559069.

 

Index > Interface > Menu Process  Previous  |  Next  

 

 

https://support.pix4d.com/hc/en-us/articles/202559069


Index > Interface > Menu Process  Previous  |  Next  

 

Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

Point Cloud 3D Textured Mesh Advanced

Allows to change the processing options and desired outputs for the Point Cloud that is generated during step 2. Point Cloud and Mesh. This step increases the
density of 3D points of the 3D model computed in step 1. Initial Processing, which leads to higher accuracy both for the DSM and the Orthomosaic. This tab
contains 2 sections:

Point Cloud Densification: Allows the user to define parameters for the point cloud densification.
Point Cloud Classification: Allows the user to classify the point cloud.
Export: Allows the user to select the desired output formats for the densified point cloud.

 

Point Cloud Densification

Allows the user to set parameters for the point cloud densification. It contains the following options:

 



Image Scale: The image scale defines the scale of the images at which additional 3D points are computed.  From the drop-down list, it is possible to select:
1/2 (Half image size, Default): Half size images are used to compute additional 3D points. It is the recommended image scale.
1 (Original image size, Slow): The original image size is used to compute additional 3D points. More points are computed than with half image scale, especially in
areas where features can be easily matched (e.g. cities, rocks, etc.). This option may require four times more RAM and processing time than when choosing the
default value 1/2 (half image size), and usually it does not significantly improve the results.
1/4 (Quarter image size, Fast): Quarter size images are used to compute additional 3D points. Less points are computed than with the half image scale.
However, more points are computed in areas with features that cannot easily be matched such as vegetation areas. This scale is recommended for projects with
vegetation.
1/8 (Eighth image size, Tolerant): Eighth size images are used to compute additional 3D points. Less points are computed than with the half or quarter image
scale. However, more points are computed in areas with features that cannot easily be matched such as vegetation areas. This scale is recommended for
projects with vegetation.

Multiscale (default): When this option is activated, additional 3D points are computed on multiple image scales, starting with the chosen scale from the
Image scale drop down list and going to the 1/8 scale (eighth image size, tolerant). For example, if 1/2 (half image size, default) is selected, the
additional 3D points are computed on images with half, quarter, and eighth image size. This is useful for computing additional 3D points in vegetation
areas as well as keeping details in areas without vegetation.

Note:  The Image Scale has an impact on the number of 3D points generated. For more information: 203269885.

Point Density: This parameter defines the density of the densified point cloud. The point density can be chosen from the following options: 
Optimal (Default): A 3D point is computed for every (4/ Image Scale) pixel. For example, if the Image Scale is set to 1/2 (half image size), one 3D point is
computed every 4/(0.5) = 8 pixels of the original image. This is the recommended point cloud density.
High (Slow): A 3D point is computed for every Image Scale pixel. The result will be an oversampled Point cloud that requires up to 4 times more processing time
and RAM than optimal density. Usually, this point cloud option does not significantly improve the results.
Low (Fast): A 3D point is computed for every (16/Image Scale) pixel . For example, if the Image Scale is set to 1/2 (half image size), one 3D point is computed
every 16/(0.5) = 32 pixels of the original image. The final point cloud is computed up to 4 times faster and uses up to 4 times less RAM than optimal density.

Note: The Point Density has an impact on the number of 3D points generated. For more information: 203269885.

Minimum Number of Matches: The minimum number of matches per 3D point represents the minimum number of valid re-projections of this 3D point to the
images. The minimum number of matches per 3D point can be:
3 (default): Each 3D point has to be correctly re-projected in at least 3 images.
2: Each 3D point has to be correctly re-projected in at least 2 images. This option is recommended for projects with small overlap, but it produces a point cloud
with more noise and artifacts.
4: Each 3D point has to be correctly re-projected in at least 4 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud.
5:  Each 3D point has to be correctly re-projected in at least 5 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud. It is recommended for oblique imagery projects that have high overlap.
6:  Each 3D point has to be correctly re-projected in at least 6 images. This option reduces the noise and improves the quality of the point cloud, but it might
compute less 3D points in the final point cloud. It is recommended for oblique imagery projects that have very high overlap.

Point Cloud Classification

Classify Point Cloud: Enables the generation of the point cloud classification. For more information: 115004864586

Note: When the point cloud classification is used for the DTM generation, it significantly improves the DTM.

Export

Allows the user to select the desired output formats for the Point Cloud. 

The following formats can be chosen: 

Note: It is possible to select more than one format in order to save the Point Cloud in multiple formats. When no output is selected, only a .p4b file is
generated. This is always generated, but it can only be opened in the rayCloud of the Pix4Dmapper. 

LAS (default): LiDAR LAS file with X,Y,Z position and color information for each point of the Point Cloud. 
LAZ: Compressed LiDAR LAS file with X,Y,Z position and color information for each point of the Point Cloud. 
PLY: PLY file with X,Y,Z position and color information for each point of the Point Cloud. 
XYZ: ASCII text file with the X,Y,Z and color information for each point of the Point Cloud.
Delimiter: Defines the delimiter character of the file, used to separate the values. The drop down list has the following options:
Space
Tab
Comma
Semicolon
Merge Tiles: If the point cloud consists of many points, several tiles are generated. This option produces a single file with all the points. 

For more information about the file formats and the software with which these files can be opened: 202558499.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display other tabs.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

Point Cloud 3D Textured Mesh Advanced

Allows the user to change the processing options and desired outputs for the 3D Textured Mesh of step 2. Point Cloud and Mesh. This tab contains 3 sections:

Generation: Allows the user to select the generation of the 3D Textured Mesh. 
Settings: Allows the user to select parameters concerning the generation of the 3D Textured Mesh. 
Export: Allows the user to select the desired output formats for the 3D Textured Mesh. 

 

Generation

 



Generate 3D Textured Mesh: Allows the user to select whether the 3D Textured Mesh should be generated.

Settings

Allows the user to select the resolution for the 3D Textured Mesh generation.

Important:  
The Point Cloud is used to generate a surface composed of triangles. The distance between the mesh and the points of the Point Cloud is optimized to
be minimal, but this means that points of the mesh do not necessarily correspond to points of the point cloud. 
Since the mesh is 3D, it is unfolded onto a 2D plane in order to define the resolution (pixel size). Then the 3D position of the pixel is reprojected into the
original images to obtain the color. Blending is used instead of stitching to generate the texture of the 3D Textured Mesh. 
The 3D Textured Mesh will be generated using the Point Cloud. If a Processing Area and/or Image Annotations are defined, and if the corresponding
options are selected in the Point Cloud Filters options, they will also be used for the generation of the 3D Textured Mesh.

The available parameters are:

High Resolution: High level of detail. Recommended to maximize the visual aspect of the 3D Textured Mesh. Computing time and size will increase significantly. 
Medium Resolution (default): Default option. Recommended setting for most project. Strikes a good balance between size, computing time and level of detail for
the 3D Textured Mesh. 
Low Resolution: Lower level of detail leading to faster computing time and lower size. Good compromise for sharing the 3DTextured Mesh. 
Custom: Allows the user to select the options for the 3D Textured Mesh generation:
Maximum Octree Depth: To create the 3D Textured Mesh, the project is iteratively subdivided into 8 subregions. These are organized in a tree structure, and this
parameter indicates how many subdivisions should be created. Higher values mean that more regions will be created, hence each region will be small, leading to
higher resolution and higher computing times.
Texture Size [pixels]: Parameter used to define the resolution of the texture of the 3D Textured Mesh, affecting the pixel size.
Decimation Criteria: After the first step in the mesh creation, too many triangles are created and this parameter indicates how the spurious triangles should be
discarded.
Quantitative: Some triangles will be discarded till they reach the desired number:
Maximum Number of Triangles: Maximum number of triangles in the final 3D Textured Mesh. The number will depend on the geometry and the size of the project.
Qualitative: Some triangles will be discarded trying to maintain the original geometry.
Strategy: Indicates the strategy employed to discard the triangles:
Sensitive: The triangles selected have as priority to maintain the original geometry of the 3D Textured Mesh.
Aggressive: The triangles selected have as priority to maintain a lower number of triangles.
Use Color Balancing for Texture: The Color Balancing algorithm will be used for the generation of the texture of the 3D Texture Mesh. The Color Balancing
algorithm ensures that the texture will be homogeneous.

Note: For projects that are not very large, it may be that the resulting number of triangles is lower than the maximum set up in the options. The
maximum will only be reached if the project is large and could create a model with more triangles.

Important: The higher the parameters selected the longer the processing time. Using high definition parameters have more visual impact when zooming in
and visualizing the model from close. This allows to better identify details in the model.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

 

Export

Allows the user to select the desired output formats for the 3D Textured Mesh. 

The following formats can be chosen: 

Note: It is possible to select more than one format in order to save the 3D Textured Mesh in multiple formats. When no output is selected, only a .p4b
file is generated. It is always generated but can only be opened in the rayCloud of Pix4Dmapper. 

PLY: PLY file with:
X,Y,Z position for each vertex of the 3D Textured Mesh
Texture information (using a .jpg texture file).
FBX: FBX file with:
X,Y,Z position for each vertex of the 3D Textured Mesh.
Texture information embedded.
DXF: DXF file with:
X,Y,Z position for each vertex of the 3D Textured Mesh.
OBJ (default): OBJ file with:
X,Y,Z position for each vertex of the 3D Textured Mesh.
Texture information (using a .jpg and .mtl texture files). 
Tiled Texture: Allows the user to tile the texture file to reduce the size of each individual file. 
3D PDF: PDF file containing a 3D model of the 3D Textured Mesh. The texture size of the 3D Textured Mesh that is displayed in the 3D PDF is 2000*2000 pixels.
Logo: Selects a logo (.jpg or .tif) that will be displayed on the 3D pdf.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202560669


Important: The 3D Textured Mesh file is not georeferenced. It has coordinates on a local coordinate system centered around the project.
To visualize the 3D Textured Mesh with georeference: 204606535.

Warning:  
For .ply and .obj format, the texture is generated in a .jpg file, which contains a 2D planar RGB image of the values for each pixel of the triangles that
forms the 3D Textured Mesh.
In order to use the 3D Textured Mesh in other software, use both files, having them in the same folder and without renaming the texture .jpg file.
The .jpg texture file is associated to the .ply / .obj / .p4b generated while generating the attached .jpg file.
If new .ply / .obj / .p4b files are generated, they cannot use a .jpg file generated previously even if it is for the same project and same parameter values.
If having problems visualizing the 3D textured Mesh in the rayCloud or external software due to lack of hardware resources, it is possible to resize the
.jpg file (reducing the same percentage for the width and height) using any image editor. This requires less memory.
Texture of sizes 65536x65536 and 131072x131072 are only supported for the .obj format and should be generated with the Tiled Texture option. Several
texture files will be generated. Not all external software can read tiled texture files. 

Important: The 3D Textured Mesh can be exported in multi-LOD format in order to be visualized on a web interface. To generate and export the LOD
Mesh: 202558079.

For step by step instructions about how to generate the 3D Textured Mesh: 202560669.

For more information about the file formats and the software with which these files can be opened: 202558499.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 2. Point Cloud and Mesh. By default,
only the Point Cloud and the 3D Textured Mesh tabs appear. On the bottom left, select the Advanced box to display the Advanced tab.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

Point Cloud 3D Textured Mesh Advanced

Allows to change the advanced processing options for the Point Cloud and the 3D Textured Mesh of step 2. Point Cloud and Mesh. This tab contains 4 sections:

Point Cloud Densification: Allows to define parameters for the point cloud densification.
Image Groups: Allows to select which image groups are used for different outputs.
Point Cloud Filters: Allows to change options concerning the filtering of the point cloud.
3D Textured Mesh Settings: Allows to change options concerning the mesh generation. 

 

Point Cloud Densification

Allows to set parameters for the point cloud densification. It contains the following option:

 

205443205.html


Matching Windows Size: Size of the grid used to match the densified points in the original images.
7x7 pixels: Faster processing. Suggested when using aerial nadir images.
9x9 pixels: Finds a more accurate position for the densified points in the original images. Suggested when using oblique and / or terrestrial images.

 

Image Groups

Allows to define which image groups are used to generate each of three different outputs: the Point Cloud, the Mesh Geometry and the Mesh Texture. Useful for
projects that consist of images of different band configuration.

Example: For a project that consists of both RGB and NIR images, the point cloud can be generated based on both the RGB and the NIR images, the
geometry of the Mesh can be computed using only the RGB images and the texture of the Mesh using only the NIR images.

This section consists of 3 fields:

Point Cloud: Image groups used for the Point Cloud generation.
Mesh Geometry: Image groups used for the computation of the geometry of the Mesh.
Mesh Texture: Image groups used for the texture of the Mesh.

 

Point Cloud Filters

Allows to select filters that are taken into account for the Point Cloud and the 3D Textured Mesh generation. The following options are available:

Use Processing Area: If a Processing Area has been drawn, it is used to filter the Point Cloud and the 3D Textured Mesh. For more information: 202558439.
Use Annotations: If Image Annotations have been created, they are used to filter the Point Cloud and the 3D Textured Mesh. For more information: 202558199.
Limit Camera Depth Automatically: Prevents the reconstruction of background objects. Useful for oblique/terrestrial projects around objects.

 

3D Textured Mesh Settings

Advanced option influencing the generation of the 3D Textured Mesh:

Sample Density Divider: The value goes from 1 (default) to 5. Increasing this value creates more triangles in regions with a lower density of points. However, this
might also create more unwanted triangles in noisy regions. To be used when there are holes in the mesh and the model is not too noisy. 
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 3. DSM, Orthomosaic and Index.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

DSM and Orthomosaic Additional Outputs Index Calculator  

Allows the user to change the processing options and desired outputs for DSM and Orthomosaic generation of step 3. DSM, Orthomosaic and Index. It contains 4
sections:

Resolution: Allows the user to define the spatial resolution used to generate the DSM and Orthomosaic.
DSM Filters: Allows the user to define parameters to filter and smooth the points of the Point Cloud used to obtain the DSM.
Raster DSM: Allows the user to select the output file format and options for the raster DSM.
Orthomosaic: Allows the user to select the output file format for the Orthomosaic as well as different options related to the Orthomosaic generation.

 

 

Resolution

Allows the user to define the spatial resolution used to generate the DSM and Orthomosaic.

 

205443205.html


Automatic (default): By default one GSD is selected. One can also easily change the resolution to multiples of the GSD.
Custom: Allows to select any value for the resolution of the Raster DSM and the Orthomosaic generation.

 

DSM Filters

Allows the user to define parameters to filter and smooth the points of the Point Cloud used to obtain the DSM. 

Important: The filtering and smoothing will not have any impact in the Point Cloud.

The following options are available: 

Use Noise Filtering: The generation of the Point Cloud can lead to noisy and erroneous points. The noise filtering corrects the altitude of these points with the
median altitude of the neighboring points.
Use Surface Smoothing: Once the noise filter has been applied, a surface is generated using the points. This surface can contain areas with erroneous small
bumps. The surface smoothing corrects these areas by flattening them. This section allows the user to set the following parameter:
Type: Three smoothing types can be selected:
Sharp (default): Tries to preserve the orientation of the surface and to keep sharp features such as corners and edges of buildings. Only quasi-planar areas are
flattened.
Smooth: Tries to smooth areas, assuming that sharp features exist because of noise and that they should be removed. Areas that are not very planar are
smoothed and become planar.
Medium: This is a compromise between the two other options. It tries to preserve sharp features while flattening roughly planar areas.

 

Raster DSM

Allows the user to select whether the raster DSM is generated and to select the method with which the DSM will be generated:

GeoTIFF (activated by default): Saves the DSM as a GeoTIFF file. For most projects the DSM is split into several tiles and one GeoTIFF file is generated per tile. 
Method: The method that is used for the Raster DSM generation. The method will affect the processing time and the quality of the results.
Inverse Distance Weighting: The inverse distance weighting algorithm is used to interpolate between points. This method is recommended for buildings.
Triangulation: The triangulation algorithm based on Delauney triangulation is used. This method is recommended for flat areas (agriculture fields) and stockpiles. 

Important: The triangulation method can be up to 10 times faster than the Inverse Distance Weight Method, but the results may be worse
especially for buildings.

Merge Tiles (activated by default):  Generates a single DSM GeoTIFF file by merging the individual tiles. When this option is not selected, the merged DSM file is
not generated.

 

Orthomosaic

Allows the user to select the output file format for the Orthomosaic as well as different parameters related to the Orthomosaic generation:

GeoTIFF (activated by default): Saves the Orthomosaic into a GeoTIFF file. For most projects, the Orthomosaic is split into several tiles and one GeoTIFF file is
generated per tile. 
Merge Tiles (activated by default): Generates a single Orthomosaic GeoTIFF file by merging the individual tiles. When this option is deactivated, the merged
Orthomosaic file is not generated.
GeoTIFF Without Transparency: Generates a GeoTIFF file without transparency. For more information: 202558809.
Google Maps Tiles and KML: This option allows the user to generate the Google Maps and Google Earth files for the Orthomosaic.

Important: 
When having images grouped in more than one group, the Google Maps Tiles and KML will only be generated if one of the groups is
named RGB (capital letters). For more information about the image groups: 202557949.
The Google Maps Tiles and KML are only generated for 3 band images with 8 bit per band.

Important: When having images grouped in more than one group, one Orthomosaic per group is generated. For more information about image
groups: 202557949.

 

Index > Interface > Menu Process  Previous  |  Next  

 

 

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558809
205443205.html


Index > Interface > Menu Process  Previous  |  Next  

 

Access: On the Menu bar, click Process > Processing Options..., in the Processing Options pop-up click 3. DSM, Orthomosaic and Index.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

DSM and Orthomosaic Additional Outputs Index Calculator  

Allows the user to change the selected processing options and output files for the additional outputs to be generated during step 3. DSM, Orthomosaic and
Index. It contains 2 sections:

Grid DSM: Allows the user to select the output file format for the Grid DSM.
Raster DTM: Allows the user to select the output file format and options for the raster DTM.
Raster DTM Resolution: Allows the user to define the spatial resolution used to generate the DTM.
Contour Lines: Allows the user to generate the contour lines using the Raster DSM or the Raster DTM and to select the processing options for the contour lines.

 

Grid DSM

Allows the user to select the desired file format for the DSM:

 



XYZ: ASCII text file with the X,Y,Z position and color information for each point of the Grid DSM.
Delimiter: It defines the delimiter character of the file, used to separate the values. The drop down list has the following options:
Space
Tab
Comma
Semicolon
LAS: LiDAR LAS file with X,Y,Z position and color information for each point of the Grid DSM. 
LAZ: Compressed LiDAR LAS file with X,Y,Z position and color information for each point of the Grid DSM. 
Grid Spacing [cm]: The spacing defines the distance between two 3D points in the Grid DSM and is given in centimeters. For example: a grid spacing of 100
centimeters will generate one 3D point every 100 centimeters. The default value is 100 centimeters. One DSM with the selected spacing is generated in addition
to a DSM generated using the resolution selected in the DSM and Orthomosaic tab. 

For more information about the file formats and the software with which these files can be opened: 202558499.

Note: It is possible to select more than one format to save the Grid DSM in more than one formats.

Note: The Grid DSM is restricted to 256 million points. If the chosen grid spacing or resolution generates more than 256 million points, then the grid
sampling or resolution distance is doubled until the number of generated points does not exceed 256 million.

 

Raster DTM 

 Allows to generate the raster DTM. For more information about the concept of DTM: 217263226.

Important: The option to generate the raster DTM is only available when the options Raster DSM and Merge Tiles for raster DSM are selected. For more
information about the options of the raster DSM: 202557769.

Merge Tiles (activated by default):  Generates a single DTM GeoTIFF file by merging the individual tiles. When this option is not selected, the merged DTM file is
not generated and the contour lines are not using the DTM.

 

Raster DTM Resolution

Allows to define the spatial resolution used to generate the DTM.

Automatic (default): By default, the resolution is set to 5 X GSD. One can also easily change the resolution to multiples of the GSD. 
Custom: Allows to select any value higher than 5 X GSD, for the resolution of the Raster DTM.

 

Contour Lines

Allows to generate contour lines using the Raster DSM or the Raster DTM. For more information about the concept of contour lines using the Raster
DSM: 202559879 and the raster DTM: 217262006.

Important: The contour lines are computed using the: 
the Raster DTM, if it is already generated. For more information about contour lines, using the DTM: 217262006.
the Raster DSM, if the raster DTM is not generated or if the DTM tiles are not merged. For more information about contour lines, using the
DSM: 202559879.

Important: The option to generate the contour lines is grayed out if the option to merge the tiles of Raster DSM is disabled. For more information about
the options of the Raster DSM: 202557769.

SHP: When this option is selected, the contour lines file is generated in .shp format. 
PDF: When this option is selected, the contour lines are saved in .pdf format. 
DXF: When this option is selected, the contour lines file is generated in .dxf format.
Contour Base [units]: It defines the relative altitude which is used as a contour line base. It can be in meters or in feet according to the coordinate system used.
Elevation Interval [units]: It defines the contour line elevation interval. It can be in meters or in feet according to the coordinate system used. It can be any positive
value. 

Warning: The Elevation Interval must be smaller than (Maximum - Minimum) altitude of the DSM/DTM.

Note: The smaller the Interval value, the larger the size of the contour lines file and the more processing time will be needed for its generation.

Note: The minimum altitude of the model, the Contour Base and the Elevation Interval define the elevation of the contour lines: The Contour Base
expected to be the altitude of the first contour line. If it is lower that the minimum altitude, then the elevation of the first contour line is expected to
be Contour Base+Elevation Interval. If this is still lower than the minimum altitude, then this check continues till the Contour Base+n* Elevation
Interval is equal or bigger than the minimum altitude of the model.

 

 

 

 

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558499
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https://support.pix4d.com/hc/en-us/articles/217262006
https://support.pix4d.com/hc/en-us/articles/217262006
https://support.pix4d.com/hc/en-us/articles/202559879


Example:  
For a project with minimum altitude 315 meters, Contour Base = 30 meters and Elevation Interval=1 means that the first contour line (the base) will
be at 315 meters (30+1*285).
For a project with minimum altitude 15 meters, Contour Base = 30 meters and Elevation Interval=1 means that the first contour line (the base) will
be at 30 meters (30+1*0).
For a project with minimum altitude 315 meters, Contour Base = 0 meters and Elevation Interval=10 means that the first contour line (the base) will
be at 320 meters (0+32*10).

Example: For a project with Minimum altitude 400 meters and Maximum altitude 650 meters and Contour Base = 0 meters, Elevation Interval = 50
meters means that that contour lines will be generated at 400, 450, 500, 550, 600, and 650 meters.

Resolution [units]: It defines the horizontal distance for which an altitude value is registered. The higher the Resolution value, the smoother the contour lines.

Example: If the Resolution is set to 100 cm, an altitude value will be registered every 100 cm horizontally.

Minimum Line Size [points]: It defines the minimum number of vertices that a contour line can have. Lines with less vertices will be deleted and less noise will be
produced.

Example: If the Minimum Line Size [points] is set to 20, all contour lines that have less than 20 vertices will be deleted.

Note: 
It is possible to select more than one format in order to save the contour lines in multiple formats.
If step 3. DSM, Orthomosaic and Index has already been processed and the DSM or DTM are generated, it is possible to generate the Contour
Lines without running step 3 again. For more information: 202558469.
For step by step instructions about how to generate contour lines: 202560639.
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Access: On the Menu bar, click Process > Processing Options..., the Processing Options pop-up appears. Click 3. DSM, Orthomosaic and Index.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

DSM and Orthomosaic Additional Outputs Index Calculator  

Allows the user to change the processing options and outputs related to the Index Calculator. These are processed during step 3. DSM, Orthomosaic and Index.

These settings come in 4 sections:

Radiometric Processing and Calibration: Allows the users to calibrate and correct the image reflectance, taking the illumination and sensor influence into
consideration. 
Resolution: Allows the user to set the resolution as well as the downsampling method (if needed).
Reflectance Map: Allows the user to decide if the Reflectance Map(s) will be generated while processing step 3. DSM, Orthomosaic and Index, and if the Tiles will
be merged.
Indices: Shows the list of indices either from the database or created by the user. Allows the user to select which indices are generated while processing
step 3. DSM, Orthomosaic and Index. For the selected indices, the Index Map is saved as a GeoTIFF, the Index Map Grid as a .shp file, the Classes as a .shp
file and the Classes with color representation as a .jpg file.
Export: Allows the user to select some desired outputs.

 

 



 

Radiometric Processing and Calibration

Allows the users to calibrate and correct the image reflectance, taking the illumination and sensor influence into consideration. It is possible to choose the type of
radiometric correction to be done:

No correction: no radiometric correction will be done
Camera only: corrections will be applied to the parameters that are written in the EXIF metadata and relate to the camera (vignetting, dark current, ISO,
etc...): 115001846106
Camera and Sun Irradiance: corrections will be applied to the camera parameters (same as using the option Camera only) as well as for the sun
irradiance information written in the XMP.Camera.Irradiance EXIF tag.
Camera, Sun Irradiance and Sun angle: corrections will be applied to the camera parameters and the sun irradiance information (same as using the
option Camera and Sun Irradiance) as well as to take into account the sun position. This option should only be chosen for flights that were done in clear sky
conditions. 

The camera used is displayed. Users can calibrate the sensor to perform an illumination adjustment in order to obtain more accurate reflectance values. If there
are more than one camera models in the project, all the cameras will be listed in the Radiometric Processing and Calibration section.

The Calibrate button allows to take into account the information from a picture with radiometric calibration target if such a target was used during the project.
After clicking Calibrate for a camera model, the Radiometric Calibration pop-up appears:

https://support.pix4d.com/hc/en-us/articles/115001846106


The Radiometric Calibration pop-up has the 2 sections:

Image: The image section allows the user to browse the image that will be used for the radiometric calibration.
Albedo: The Albedo section allows the user to set the albedo values for the calibration target. 

Image

In File Name, the Browse button, opens the Select a radiometric calibration image pop-up. This pop-up allows the user to select the image in which the
radiometric calibration target appears.

When an image is browsed, the user can draw a region on the image that will define the radiometric calibration. The Reset button, resets the area drawn by the
user. 



Albedo

In the Albedo section the detected bands of the camera model appear. This section allows the user to type the albedo values for the calibration target for the
bands of the camera model selected.

Important:  The albedo values can be between 0.0 and 1.0.

For more information about the radiometric calibration target: 206494883.

and the action buttons:

OK: Confirms the radiometric calibration.
Cancel: Does not save the radiometric calibration.
Help: Opens the Pix4Dmapper help.

Resolution

Allows the user to set the resolution for the reflectance map. If a resolution lower than 1 GSD is chosen, the downsampling method can be chosen among the
following options. Note that the window size will depend on the downsampling rate:

Gaussian Average: Apply a Gaussian filter to the image.
Fast Gaussian: This option performs the downsampling on the original images (hence does not produce a 1GSD reflectance map first), resulting in faster
processing time.
Average: The pixel takes the average value of the window around it.
Median: The pixel takes the median value of the window around it.

 

https://support.pix4d.com/hc/en-us/articles/206494883


75% Quantile: The pixel takes the value of the 75% quantile of the window around it. 
Minimum pixel: The pixel takes the minimal pixel value of the window around it. 
Maximum pixel: The pixel takes the maximal pixel value of the window around it. 

Reflectance Map

Allows users to generate and save the Reflectance Map in GeoTIFF format.

GeoTIFF: The Reflectance Map is generated and saved in GeoTIFF format during the step 3. DSM, Orthomosaic and Index. 
Merge Tiles: For most projects, the Reflectance Map is split into tiles where every tile is in GeoTIFF format. This option generates a single Reflectance Map file
by merging all the individual tiles. 

When this box is deselected, the merged Reflectance Map file is not generated, and users will only find smaller tiles in the result folder.

Indices

Allows the user to select which indices are generated while processing step 3. DSM, Orthomosaic and Index (If in the section Reflectance Map, Geotiff is
selected), and generates the Index Map Grid and the Classes for the selected indices. The resolution of the Index Map generated is the same as the Reflectance
Map.

Indices Box: All indices are displayed in the gray box with icons:
: The index exists in the Pix4Dmapper index database. For more information about the Pix4Dmapper Index Database List: 202558379.
: The index was created / edited by the user in another project (on the same computer) that was closed and saved. :202560489.
: The index was created / edited by the user in this project: 202560489.

 

Export

Allows the user to select some desired outputs:

Index Values as Point Shapefiles (.shp): This map is generated while generating the Index Map. The Index Map Grid is generated by placing a grid in the Index
Map. If a grid point lays on exactly 1 pixel, it takes the value of the pixel of the Index Map. If a point lays on several pixels, its value is interpolated with the values
of the neighboring cells of the Index Map.
Grid Size [unit/grid]: Defines the grid size. The default value is 200 cm/grid. 

Note: The maximum value that can be entered is 10000.

 

 

Index Values and Rates as Polygon Shapefiles (.shp): Allows the user to export the index values and rate regions as a .shp file. 
Grid Size [unit/grid]: Defines the grid size. The default value is 400 cm/grid.

Note: The maximal value that can be entered is 10000.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558379
https://support.pix4d.com/hc/en-us/articles/202560489
https://support.pix4d.com/hc/en-us/articles/202560489
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Access: On the Menu bar, click Process > Processing Options..., in the Processing Options pop-up click Resources and Notifications.

 

1. Initial Processing 2. Point Cloud and Mesh 3. DSM, Orthomosaic and Index Resources and Notifications

 

Resources  and Notifications   

Allows the user to select the usage of the hardware resources and to select a notification for when processing is done. This can be useful when running multiple
projects on the same computer or when the computer is needed for tasks other than processing:

This tab contains two sections: 

Maximum Resources Available for Processing: Allows to throttle the resources dedicated to the software
Notifications: Allows to trigger a notification when processing is completed.

Maximum Resources Available for Processing

RAM [GB]: By default all the available RAM memory is used. It is possible to reduce the amount of RAM assigned to the processing of the project by moving the
slider to a lower value.
CPU Threads:  By default all the CPU threads are used. It is possible to reduce the amount of CPU threads assigned to the processing of the project by moving
the slider to a lower value.
NVIDIA CUDA Capable Devices:
ONLY when using NVIDIA Graphic card(s) compatible with CUDA, it is possible to activate / deactivate the use of the Graphic card(s) by selecting/deselecting the
box.
When using Cuda processing, the processing speed is increased and the impact is more significant for large projects.
Under NVIDIA CUDA capable devices list, the list of GPUs appears . The cards that have at least 2 GB RAM are selected by default.

NVIDIA CUDA Capable Devices available. NVIDIA CUDA Capable Devices not available. 

 



Tip: When processing several projects of a given size at the same time, the first project starting step 2. Point Cloud and Mesh will use as much RAM as
possible. When another project starts processing step 2. Point Cloud and Mesh as well, less RAM will be available and processing might be slower.
Therefore, reducing the amount of RAM to be used so that the resources are shared between the projects running at the same time helps to reduce the
overall processing time.

For example on a 64GB RAM computer, when running 2 projects, set the amount of RAM to 32GB for each project.

Notifications

If the notification box is selected, an email notification will be sent to the email address used to log in Pix4Dmapper when processing is done.
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Access: On the Menu bar, click Process > Processing Options..., the pop-up Processing Options appears.

 

The section about templates allows to:

Load (select) a template.
Save a custom template.
Visualize the description of a template (Manage Templates).
Edit the name and description of a custom template (Manage Templates).
Delete a custom template (Manage Templates).
Import templates from the support site (Manage Templates).

It contains:

Current Options: Displays the selected processing options template.

Note: No Template: Refers to processing options templates (default or created by the user) that have been edited but are not saved.

Load Template: Allows to select a processing options template.

 

 



Note: The processing options templates are organized into three sections: Standard, Rapid and Advanced. A fourth section titled Personal appears
above the others when a new personal template has been created by the user.

Save Template: Displays two options:

Update "Template" with Current Options: Allows to overwrite the processing options template with the new selected options. Available when a Personal
template is selected and some options have been changed.
Create New Template with Current Options...: Allows to save the selected processing options as new Personal processing options template. Opens the Create
New Template pop-up which allows to enter a Name and a Description for the new template: 

                

 

Manage Templates...: The pop-up Templates Manager appears:

 



It contains two sections:

List of existing processing options templates.

Note: The processing options templates are organized into three sections: Standard, Rapid and Advanced. A fourth section
titled Personal appears above the others when a new personal template has been created by the user.

Description of the selected processing options template regarding the:
Image acquisition: Recommended image acquisition type for applying the template; the blue color refers to the acquisition plan and the yellow color refers to the
terrain or object type.
Outputs Quality/Reliability: The scale ranges from Low to High to differentiate the quality and reliability of the results between full and rapid/low resolution
processing ; high reliability indicates the higher resolution that can be achieved for the specific dataset with the specific processing options selected
in the template.

Note: For more information about the differences between the full and rapid/low resolution: 202558949.

Processing Speed: The scale ranges from Slow to Fast to differentiate the completion time between the full and rapid/low resolution processing.
Outputs Generated: List of images of the generated outputs.
Application Examples: List of common applications for which the template should be used.

 And the buttons:

New: Creates a new processing options template in the Personal section with the selected processing options.
Duplicate: Duplicates an existing processing options template with another name.
Remove: Deletes a processing options template.
Check box Import/Export: displays the buttons:

 

 

https://support.pix4d.com/hc/en-us/articles/202558949


Import...: Allows to import a template (.tmpl files created with Pix4Dmapper).
Export...: Allows to export a template as a .tmpl file.
Folder...: Opens the folder where the user processing options template are saved.

Note: More processing options templates (.tmpl) available here.

OK: Confirms the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help. 

Note: For more information about the Processing Options Templates, their outputs and their selected processing options: 205319155.
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Access: On the Menu bar, click View.

There are 2 items that can be selected / unselected:

Show View Toolbar: Show / hide the View toolbar. For more information: 202557839.
Show Sidebar: Show / hide the Sidebar. For more information: 202558389.

 

And 7 items that can be selected:

Home: Opens the Home View interface.
Map View: Opens the Map View, available when a project is created/opened.
rayCloud: Opens the rayCloud View, available when a project is created/opened.
Volumes: Opens the Volumes View, available when the point cloud and the DSM of a project are generated.
Mosaic Editor: Opens the Mosaic Editor View, available when the DSM and the Orthomosaic are generated.
Index Calculator: Opens the Index Calculator View, available when step 1. Initial Processing is completed.
Processing: Opens the Processing bar, available when a project is created/opened.
Log Output: Opens the Log Output bar, available when a project is created/opened.
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Access: On the Menu bar, click View > Home.

The Home View has 3 sections:

Projects
Help
Demo Project

 

Projects

Contains the items:

New Project...: Opens the wizard that guides the user to create a new project. For step by step instructions about how to create a new project:202557309.
Open Project...: Opens an existing project. Opens a pop-up to navigate and select a .p4d project file (Pix4Dmapper project file format).
Recent Projects: Displays a menu with the 4 last projects that have been opened. By clicking one of them, the project will open.
News: Displays news about Pix4D. 
Tips:Displays information about the use of Pix4Ddesktop. It opens the Knowledge Base articles containing a detailed description.

 

Help

Contains the items:

Getting Started: Opens the Support site, displaying the Getting Started index. This guide explains how to get started with Pix4Dmapper. It shows the needed
steps before using Pix4Ddesktop, how to obtain a good dataset, how to create a project and how to start processing.
Pix4Ddesktop Manual: Opens the Support site, displaying the Desktop Manual index.
Quick Links: Opens the Support site, displaying the Quick Links index.
Example Datasets: Opens the Support site, displaying the Example Datasets index.
Video Academy: Opens the Support site, displaying the Video Academy index.
Forum: Opens the Support site, displaying the Forum index page.
News: Displays news about Pix4D. 
Tips: Displays information about the use of Pix4Ddesktop. It opens the Knowledge Base articles containing a detailed description.

 

Demo Project

Contains the items:

Pix4Ddesktop Demo Project: Automatically loads a demo project, ready to be processed. Opens in a browser window the Getting Started index that explains how
to get started with Pix4Ddesktop.
News: Displays news about Pix4D.
Tips: Displays information about the use of Pix4Ddesktop. It opens the Knowledge Base articles containing a detailed description.
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Access: On the Menu bar, click View > Map View.

By selecting the Map View the following elements are displayed on the main window:

Menu bar entry: Displayed on the Menu bar.
Toolbar: The standard toolbar and some extra buttons related to the Map View.
2D View: Displayed in the main window. By default the Satellite view is displayed.
Status bar: Displayed at the bottom right of the Map View. Displays the coordinates when passing the mouse over the 2D View.

Important: The 2D Map displays the Earth if the images are not geotagged.

 

Menu bar entry

On the Menu bar, when clicking Map View, the following option is displayed:

Processing Area: Indicates the area of the project for which the different outputs will be generated.

Toolbar

The following toolbar buttons are displayed:

Standard toolbar buttons: For more information: 202557839.
Toolbar extra buttons:

Toolbar extra buttons

View
 Zoom In: Zooms in the selected view.

 Zoom Out: Zooms out the selected view.

Change Background Map: A drop-down list that changes the 2D View background displayed on the main window. It has the following options:

 

 



Satellite (default): Displays a satellite view of the project's location. If none of the images is geolocated and there are no GCPs in the project, the whole Earth is
displayed.
Maps: Displays a map view of the project's location. If none of the images is geolocated and there are no GCPs in the project, the whole Earth is displayed. The
background map is provided by Mapbox.

2D View 

Section which displays the location of the project on Earth and the project elements (images, GCPs, etc.). For more information: 202557979.

 

Status bar

The coordinates of the current mouse position on the 2D View are displayed at the bottom right of the Map View. Two types of coordinates are displayed:

Geographical WGS84 coordinates
Latitude and longitude coordinates are displayed.
Selected Coordinate System
The X and Y coordinates of the selected output coordinate system (202558239) are displayed .

Note: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, only the geographical WGS84 coordinates are
displayed.
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Access: On the Menu bar, click View > Map View and then, on the Menu bar, click Map View > Processing Area.

Note: Only one Processing Area can been used.

Warning:
It is recommended to include areas covered by images in the Processing Area, so as to exclude areas of low overlap that can affect the results.  
The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 1.
Initial Processing.
When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud and the Volumes View and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index. 
When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud and the Volumes View but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and
Index. 
When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.
When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected. 

Warning:  
In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the corresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters. 

The Processing Area indicates the area of the project for which the different steps of processing will be applied. The area can be defined in the Map View if the
project is georeferenced in a known coordinate system.

 

 

It contains 4 options:

Draw 
Import...
Edit...
Remove

 

For step by step instructions about how to select / draw the Processing Area: 202560179.

 

Draw

By clicking Draw, the information i0012 pop-up appears with instructions about how to draw the area:

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/203890769
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Left click starts drawing. 
Right click inserts the last vertex of the Processing Area and stops the drawing.
Esc button stops drawing and cancels the process.

  

Import...

By clicking Import..., the Select file pop-up appears which allows to load the area from a vector file (.shp or .kml):

Navigation window: Used to search for and select the vector file.
Open: Loads the file.
Cancel: Does not save the changes and closes the pop-up.

Note: The Vector file (.shp or .kml) has to be a polygon file (not lines) and can be given in any coordinate system from Pix4Dmapper's coordinate system
database.

 

Edit...

Available only if a Processing Area has already been drawn / imported. By clicking Edit..., the Edit Processing Area pop-up appears. It contains a table with the
following columns:

Vertex: Each vertex of the area drawn or imported.
Latitude: The latitude of each vertex.
Longitude: The longitude of each vertex.

 

 



 

To edit the area, by changing the Latitude and/or Longitude values, double-click on the corresponding cells in the table.

The Edit Processing Area pop-up also has 3 action buttons:

OK: Confirms the changes.
Cancel: Does not save the changes and closes the pop-up.
Help: Opens the Pix4Dmapper help.

 

Remove

Available only if a Processing Area has already been drawn / imported. By clicking Remove, the previously drawn or imported area is deleted.
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Access: On the Menu bar, click View > Map View. The 2D View is displayed on the Main window.

The 2D View has 2 components:

Background map
Displayed elements

 

Background map

On the top of the 2D View there is a drop-down list indicating the type of the background map that has been selected.

 

By default when a project is loaded, the Satellite type is selected. To navigate the map:

Zoom in: Move the mouse scroll wheel forwards.
Zoom out: Use the mouse scroll wheel backwards.
Pan: Left click and move the mouse.

Click on the background drop down list to select a different type of map. The following background maps are available:

Satellite: The background map displays a satellite map. The Satellite background is loaded only if there is Internet connection.
Maps: The background map displays the Mapbox map. The Maps background is loaded only if there is Internet connection.

  

Displayed elements

The elements that are displayed are the following:

Images
Flight plan
GCPs
Processing Area

 

202557629.html


 

Images
The images of the project that are geolocated with a known coordinate system are displayed as dots on the 2D View. The first image is displayed as a larger
dot. The color of the dot indicates the phase of the processing:

Red: When a project is loaded before processing has started.
Gridded red: For the images that are disabled (not taken into account for processing).
Dark green: For images that have been calibrated after step 1. Initial Processing.
Blue: During step 2. Point Cloud and Mesh for the loaded images.
Luminous green: After step 2. Point Cloud and Mesh.

When hovering over the image dots, the image name is displayed at the bottom part of the 2D View. When clicking on an image dot, a pop-up appears that
displays the corresponding image.

Important:  If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the images are not displayed on the 2D View.
The 2D View displays the whole Earth.

 

The Images layer has a sub-layer:

Flight plan: It displays the flight plan that was used to take the images as a green line starting from the larger dot (first image).  

 
GCPs

 



The GCPs of the project (if any), are displayed as a blue crosses on the map.

When hovering over the GCP cross, the GCP name is displayed at the bottom of the 2D View. When clicking on a GCP cross, the GCP/MTP Manager window
opens and the corresponding GCP is selected.

Important: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the GCPs are not displayed on the 2D View. The
2D View displays the whole Earth.

 

Processing Area

 



The Processing Area, if defined, is displayed on the 2D View as a polygon with a red border.

Important: If the project has no georeference or it is georeferenced in an arbitrary coordinate system, the Processing Area is not displayed on the 2D
View. The 2D View displays the whole Earth.
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Access: On the menu bar, click View > rayCloud.

The use of the rayCloud is optional and it can be used to:

Visualize the different elements of the reconstruction (Camera Positions, Reprojections (rays), GCPs, Manual / Automatic Tie Points, Processing Area, Clipping
Box, Densified Point Cloud, Point Cloud Classification, 3D Textured Mesh, Objects, Video Animation Trajectories) and their properties.
Visualize point clouds created in other projects or with other software.
Georeference a project using GCPs and /or scale and orientation constraints.
Create orthoplanes to obtain mosaics of any selected plane (for example, building facades).
Verify / improve the accuracy of the reconstruction.
Assign points of the point cloud to different classes.
Improve the visual aspect of the reconstruction.
Create objects, measure distances (polylines) and surfaces.
Create 3D fly-through animations (Video Animation Trajectories).
Export different elements (GCPs, Manual / Automatic Tie Points, Objects, Video Animation Trajectories).
Create point cloud files using points belonging to one or several groups.

When selecting the rayCloud the following elements are displayed on the Main window:

Menu bar entry: The standard menu bar items and an extra item.
Toolbar: The standard toolbar and some extra buttons specific to the rayCloud.
Left Sidebar: Displayed on the left of the 3D view. It consists of two sections: the Create section and the Layers section. The Create section allows the user to
create a Processing Area, Objects, Scale and Orientation Constraints and Orthoplanes. The Layers section displays the list of layers and sub layers (elements)
which are displayed on the 3D view. It allows to edit the display options of existing elements as well as to insert or import elements on the 3D view, and export
elements to file.
3D View: Displayed in the main view. Displays the different elements in 3D.
Right sidebar: Displayed on the right of the 3D view. Displays different information depending the selected element.
Status bar: Displayed on the bottom right of the rayCloud view. Displays the coordinates when passing the mouse over any element displayed in the 3D view.

 

More information in this Webinar: Using the rayCloud: 202561629.

 

Status bar

On the bottom right part of the 3D view, the following is displayed:

 

202557549.html
https://support.pix4d.com/hc/en-us/articles/202561629


Selected Coordinate System: Displays the selected coordinate system of the point.
Position: Displays the (X,Y,Z) coordinates in meters / feet of each point of the 3D view when passing the mouse over any element. When passing the mouse over
the displayed elements, the coordinates change.

Important: In the rayCloud, the coordinate system is the output coordinate system.
By default the output coordinate system is the same as the GCPs coordinate system, if GCPs are used, otherwise it is the same as the image
geolocation coordinate system. If the coordinates system is WGS84, the output is given in UTM. If less than 3 images are geolocated and less than 3
GCPs are defined, then the output coordinates system is set to "Arbitrary".
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Access: On the Menu bar, click View > rayCloud, and then click rayCloud.

The following options are displayed:

Viewpoint
Navigation Modes
Perspective/Orthographic
Change Background...
Display Sky
New Processing Area
New Scale Constraint
New Orientation Constraint
New Orthoplane
New Video Animation Trajectory...
New Polyline
New Surface

  

Viewpoint

Information: This option is also available in the Volumes view: On the Menu bar, click View > Volumes and then click Volumes.

Allows to select pre-defined viewpoints for the 3D View. These predefined viewpoints are accessible:

Using the Menu bar rayCloud > Viewpoint or the Menu bar Volumes > Viewpoint. 
Using the keyboard.

Using the Menu bar rayCloud > Viewpoint or the Menu bar Volumes > Viewpoint
View All: Moves the viewpoint in order to fit all the layers in the 3D View.
Focus on Selection: Moves the viewpoint in order to display in detail the selected element (point, camera).
Top: Moves the viewpoint in such a way that the layers are viewed from the top and fits all the layers in the 3D View.
Front: Moves the viewpoint in such a way that the layers are viewed from the front and fits all the layers in the 3D View.
Back: Moves the viewpoint in such a way that the layers are viewed from the back and fits all the layers in the 3D View.
Left: Moves the viewpoint in such a way that the view looks towards the left part of the layers and fits all the layers in the 3D View.
Right: Moves the viewpoint in such a way that the view looks towards the right of the layers and fits all the layers in the 3D View.
Home: Moves the viewpoint to the default viewpoint when opening the rayCloud and fits all the layers in the 3D View.
Using the keyboard
View All: Press "C"  to move the viewpoint in order to fit all the layers in the 3D View.
Focus on Selection: Press "F" to move the viewpoint in order to display in detail the selected element (point, camera)
Top: Press "7" to move the viewpoint in such a way that the layers are viewed from the top and fit in the 3D View.
Front: Press "1" to move the viewpoint in such a way that the layers are viewed from the front and fit in the 3D View.
Back: Press "Ctrl" + "1" to move the viewpoint in such a way that the layers are viewed from the back and fit in the 3D View.
Left: Press "3" to move the viewpoint in such a way that the layers are viewed from the left and fit in the 3D View.
Right: Press "Ctrl" + "3" to move the viewpoint in such a way that the layers are viewed from the right and fit in the 3D View.
Home: Press "0" to move the viewpoint to the default viewpoint when opening the rayCloud and fits all the layers in the 3D View.

View All Focus on Selection

 

 



Top Front

Back Left

Right Home

 

Navigation Modes



Information: This option is also available in the Volumes view: On the Menu bar, click View > Volumes and then click Volumes.

Allows the user to change the way to navigate in the 3D View, which defines how the 3D view reacts when using the mouse or keyboard:

Standard: Pix4D standard navigation mode.
Trackball: The camera movements are defined relatively to a ball placed at the center of the view.  Recommended to efficiently navigate around a single centered
object.
First Person: Allows the user to interact with the view by simulating piloting the camera rather than manipulating the model. Recommended for close inspection
and complex models requiring more degrees of freedom.

For more information and a full description of all the possible actions to navigate in the 3D View using the mouse or keyboard: 205360675.

Perspective/Orthographic

Information: This option is also available in the Volumes view: On the Menu bar, click View > Volumes and then click Volumes.

Defines the projection used to display the layers in the 3D View. By default, the perspective projection is used. It is possible to switch between perspective and
orthographic projection by clicking on the Perspective/Orthographic option of the rayCloud Menu bar or the Volumes Menu bar.

It is also possible to change the view type from perspective to orthographic using the keyboard by pressing "5".

Perspective projection: Parallel lines don't look parallel and further objects appear smaller. This is what human eyes see.
Orthographic projection: Parallel lines stay parallel. Therefore the size of objects does not depend on the distance. This view mode is recommended for technical
drawing.

Perspective projection vs Orthographic projection

For more information about Perspective/Orthographic projections: 

Wiki Orthographic projection
Wiki Perspective projection

 

Change Background...

Information: This option is also available in the Volumes view: On the Menu bar, click View > Volumes and then click Volumes.

Allows the user to change the color of the background in the 3D View.

The Select Color pop up appears:
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The Select Color pop-up has the following sections:

Basic colors: Selects a basic color.
Palette: Selects / modifies a color using the palette.
Color Properties Values: Modifies a color typing the color properties values (Hue, Sat, Val, Red, Green, Blue).
Display of the selected color.
Add to custom colors: Adds the selected color to custom colors, available for other projects.

And the action buttons:

OK: Confirms the changes.
Cancel: Does not save the changes.

 

Display Sky

Information: This option is also available in the Volumes view: On the Menu bar, click View > Volumes and then click Volumes.

Allows the user to display a realistic sky gradient in the horizon of the plane where the project is based.

Realistic Sky Disable Realistic Sky Enable

 

New Processing Area

A Processing Area is an area that restricts the model displayed and/or the outputs generated. Only one Processing Area can be drawn/imported in the project. If
a Processing Area already exists, the option New Processing Area is grayed out. 

For more information about the Processing Area: 202558439.

 



For step by step instructions on how to draw a Processing Area: 202560179.

Once a new Processing Area is created, the right sidebar displays the following information: 202558449.

 

 
Processing Area

 

New Scale Constraint

A Scale Constraint is a an line with known real Cartesian distance between 2 points, allowing to set up a local scale of the model.

It is a mathematical constraint over the geometry of the project.

It is used when:

No GCPs are not being used.
No good image geolocation is used for the images.

It is used to improve the relative accuracy by adding a local scale to the project, by defining the real distance between 2 known points.

Important: 
It is recommended to use the several Scale Constraint and distribute them along the project.
Once the Scale Constraints objects are added, it is needed to repotimize.

Warning: When creating Scale Constraints, if the project does not have image geolocation, it is suggested as well to create Orientation Constraints to
set up an local orientation for the model.

Example: In the real model, a Cartesian distance between point 1 and point 2 is known to be 5 meters, then, it is possible to create a scale constraint
(line) having as vertices the Points A and B and setting up the distance between the points to 5 meters.

For step by step instructions about how to draw a new Scale Constraint: 205360375.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.
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New Orientation Constraint

A Orientation Constraint is a line that represents a known axis, allowing to set up an local orientation of the model.

It is a mathematical constraint over the geometry of the project.

It is used when:

No GCPs are not being used.
No good image geolocation is used for the images.

It is used to avoid a rotated model or to force a certain orientation to the model, by defining one or more desired axes (X and /or Y and / or Z).

Important: 
In case of using several Orientation Constraint, if they represent a different axis (X, Y, Z), they must be placed with 90º between each other to avoid a
deformed model.
It is possible to create more than one Orientation Constraint for one axis (for example, X), then, the average value will be used.
Once the Orientation Constraints objects are added, it is needed to repotimize.

Warning: When creating Orientation Constraints, if the project does not have image geolocation, it is suggested as well to create Scale Constraints
to set up a local scale of the model.

Example: In the real model, the user knows that the desired orientation regarding the axis X, Y, and Z, then, it is possible to create 3 Orientation
constraint having 90º with each other and selecting which object represents which axis, defining a 3 dimensions coordinate system basis.

For step by step instructions on how to draw a new Scale Constraint: 205360385.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.

 

 

 

https://support.pix4d.com/hc/en-us/articles/205360385


 

New Orthoplane

An Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model without having any impact / modifications in the model.

It is created by defining orthoprojection areas that allows to set up:

Area of interest (surface and depth).
Location.
Orientation and direction of the projection.

Important: It is important to define properly the box (orthoprojection area):
Area of interest (surface and depth).
Location.
Orientation and direction of the projection.

Only the geometry inside the box (points of the densified point cloud) will be used to find the projection surface.

For step by step instructions about how to draw a new Scale Constraint: 204664359.

Once a new Scale Constraint is created, the right sidebar displays the following information: 202558219.

 

https://support.pix4d.com/hc/en-us/articles/204664359


 

New Video Animation Trajectory

An Animation trajectory is a 3D Fly-trough Animation created as a video.

For step by step instructions about how to create a 3D Fly-trough Animation: 202560299.

Once a new Animation Trajectory is created, the right sidebar displays the following information: 202558219.

 

https://support.pix4d.com/hc/en-us/articles/202560299


 

New Polyline

A Polyline Object is a continuous line composed of one or more sub-lines. It is created by specifying the vertices of each line. For more information about the
concept of Polylines: 202559829.

For step by step instructions about how to draw a new Polyline: 202560309.

Once a new Polyline is created, the right sidebar displays the following information: 202558219.

https://support.pix4d.com/hc/en-us/articles/202559829
https://support.pix4d.com/hc/en-us/articles/202560309


 

New Surface

A Surface is an object that can be used to define planar areas such as a road, the roof of a building, etc. It can also be used to correct the DSM and generate a
better orthomosaic on these surfaces.

For step by step instructions about how to draw a new Surface: 202560269.

Once a new Surface is created, the Sidebar displays following information: 202558219.

https://support.pix4d.com/hc/en-us/articles/202560269


 

Index > Interface > Menu View > rayCloud  Previous  |  Next  



Index > Interface > Menu View > rayCloud  Previous  |  Next  

 

Access: On the Menu bar, click View > rayCloud.

 

The following Toolbar buttons are displayed:

Standard Toolbar: For more information: 202557839.
Toolbar extra buttons.

 

Toolbar extra buttons

View

 Zoom In: Zooms in the selected view.

 Zoom Out: Zooms out the selected view.

 View All: Moves the viewpoint in order to fit all the layers in the 3D View.

 Focus on Selection: Moves the viewpoint in order to display in detail the selected element (point, camera).

 View from Top: Moves the viewpoint in such a way that the layers are viewed from the top and fits all the layers in the 3D View. 

Navigation

 Set standard camera

 Set trackball camera

 Set first person camera

 

https://support.pix4d.com/hc/en-us/articles/205360675
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Clipping

Note: For step by step instructions about how use the clipping box in the rayCloud: 204048035.

 Clip Point Cloud: Applies the Clipping Box in the 3D View and visualizes only the area contained in the Clipping Box.

 Edit Cliping Box: Visualizes the Clipping Box in the 3D View, visualize the Clipping Box properties in the right sidebar and allows the user to edit it in the 3D

View and/or the right sidebar.

Point Cloud Editing

Note: The points of the Point Cloud can be edited by assigning them into a different point group. For step by step instructions about how to
edit the point cloud points in the rayCloud: 202560499.

 Edit Densified Point Cloud: Enters/exits the Edit Point Cloud Densification mode, enabling/graying out the editing toolbar buttons below.

 Add Points to Selection: Allows the user to select the points to be edited.

 Remove Points from Selection: Allows the user to unselect the points to be edited.

 Select All: Allows the user to select all the visible points to be edited.

 Clear Selection: Allows the user to clear all the points selected to be edited.

 Invert Selection: Converts the selected points to be edited into unselected and vice versa.

 Allows the user to select the Point Group to which the selected points will be assigned. The options are: 

Unclassified: Selected by default. It contains points that do not belong to any other point group. By default, all the points are Unclassified.
Disabled: Points that will not be used for the step 3. DSM, Orthomosaic and Index. When processing step 3. DSM, Orthomosaic and Index, only the points
belonging to the point group Disabled will not be used.
Ground, Road Surface, High Vegetation, Building, Human Made Object: Predefined point groups that are created for the Point Cloud Classification. 
New Point Group: Option to create new Point Groups. By clicking New Point Group, a pop-up appears, type the New Point Group Name and click OK. The
created group is selected.

 Assigns the selected points to the selected Point Group.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The left sidebar is displayed on the left of the main window.

The left sidebar consists of the sections :

Create: This section allows the user to create a Processing Area, Orientation Constraints, Scale Constraints, Orthoplanes, Video Animations, Lines and
Surfaces. 
Layers: This section groups all the group of objects that can be displayed on the 3D View.

The left sidebar can be shown / hidden by dragging and dropping the left side border of the 3D View.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Create section in the left sidebar is displayed on the left of the main window.

  

The Create section consists of icons that allow the user to create a Processing Area, Scale Constraints, Orientation Constraints, Orthoplanes, Polylines and
Surfaces.

The Create section consists of the following icons:

  Create Processing Area: Allows the user to create a Processing Area. This icon is grayed our once a Processing Area is created. For step by step
instructions: 202560179.

 Create a New Scale Constraint:  Allows the user to create a new 3D Scale Constraint. For step by step instructions: 205360375.

 Create a New Orientation Constraint:  Allows the user to create a new 3D Orientation Constraint. For step by step instructions: 205360385.

 Create a New Orthoplane Constraint:  Allows the user to create a new 3D Orthoplane. For step by step instructions: 204664359.

 Create a New Video Animation Trajectory: Starts the New Video Animation Trajectory wizard. For step by step instructions: 202560299

 Create a New Polyline Object: Allows the user to create a new 3D Polyline. For step by step instructions: 202560309.

 Create a New Surface Object: Allows the user to create a new 3D planar Surface. For step by step instructions: 202560269.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

A layer is a group of objects that can be displayed on the 3D View. The Layers section of the left sidebar contains the following layers:

Cameras: Contains all the cameras of the project. One camera is associated to each image.
Rays: Allows to show / hide the rays between selected points in the model and the cameras where the point has been found. Contains the rays display
properties.
Tie Points: Contains the Manual Tie Points, GCPs, Check Points and Automatic Tie Points.
Processing Area: (available only if a Processing Area exists) Contains the Processing Area.
Point Clouds: Contains point clouds (Densified Point Cloud and loaded external point clouds).
Point Groups: Contains the different groups of points (each point of the densified point cloud is assigned to one group).
Triangle Meshes: Contains Triangle Meshes (generated in Pix4Dmapper or imported).
Objects: Contains any drawn object: Polylines, Surfaces, Video Animation Trajectories, Orthoplanes, Scale Constraints and Orientation Constraints.

Characteristics:

By clicking on the left arrow of a layer, the sub-layers and layer properties are shown or hidden.
By clicking on the a layer's check box, the corresponding layer is shown or hidden in the 3D View.
The different layer properties can be edited.
Some layers have a context menu that can be accessed by right clicking on the corresponding layer.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Cameras layer contains the following sub-layers:

Display Properties: Displays properties for all the cameras.
Calibrated Cameras: The cameras that have been used for the reconstruction of the model.
Uncalibrated Cameras: The cameras that have not been used for the reconstruction. These cameras are cameras for which the optimized position could not be
computed during initial processing and that have been discarded from the reconstruction.
Disabled Cameras: The cameras that have been disabled by the user. 

 

Display Properties

The Display Properties layer allows to edit the display properties for all the cameras. The following properties can be edited:

Computed position: View/hide the calibrated (optimized) camera position sphere (this property affects only the Calibrated cameras).
Radius: Increases/decreases the computed camera positions' sphere radius (this property affects only the Calibrated cameras).
Color: Selects the computed camera positions' sphere color, the color for the projection lines (between the computed position and the corners of the thumbnails)
and the  color for the thumbnails borders(this property affects only the Calibrated cameras).
Projection: View/hide projection lines between the computed camera positions and the thumbnails (this property affects only the Calibrated cameras).
Thumbnail: View/hide the thumbnails of the original images (this property affects only the Calibrated cameras).
Projection Distance: Increases/decreases the distance between the computed camera positions and the thumbnails (this property affects only the Calibrated
cameras).
Initial Position: View/hide the initial camera position sphere.
Radius: Increases/decreases the initial camera positions sphere radius.
Calibrated Color: Selects the initial camera positions' sphere color for the Calibrated Cameras (cameras used for the reconstruction).
Uncalibrated color: Selects the initial camera positions' sphere color for the Uncalibrated Cameras (cameras not used for the reconstruction).
Projection: View/hide projection lines between the computed camera positions and the hypothetical thumbnails (the thumbnail box appears but empty).
Projection Distance: Increases/decreases the distance between the computed camera positions and the hypothetical thumbnails.
Position Error: View/hide a line between initial and computed camera positions (this property affects only the Calibrated cameras).
Color: Color for the line between initial and computed camera positions (this property affects only the Calibrated cameras).

 

Calibrated Cameras

 



The Calibrated Cameras layer contains the list of Calibrated Cameras. 

On the left of each camera name, the  icon is displayed to indicate that the camera is calibrated.

Uncalibrated Cameras

The Uncalibrated Cameras layer contains a list of Uncalibrated Cameras. 

On the left of each camera name, the  icon is displayed to indicate that the camera is uncalibrated.

Disabled Images

The Disabled images layes contains a list of the images disabled by the user. 

On the left of each camera name, the  icon is displayed to indicate that the camera is disabled. 
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

Note: Even if the layer Rays is selected, if the layer Cameras is not selected, the rays will not be visible.

The Cameras layer contains the following sub-layer:

Display Properties: Displays properties for all the rays.

 

Display Properties

The following properties can be edited:

Computed Ray Color: Selects the ray color for the projection lines between the selected 3D point and the calibrated cameras where the 3D point was visible but
not marked, crossing the thumbnail in the 3D point where the point is found in the original image. 
Marked Ray Color: Selects the ray color for the projection lines between the selected 3D point and the calibrated cameras where the 3D point was marked,
crossing the thumbnail in the point where the 3D point is found in the original image. 
Uncalibrated Ray Color: Selects the ray color for the projection lines between the selected 3D point and the not calibrated cameras.
Show Non Marked Rays: View/hide the rays for calibrated cameras where the 3D point was visible but not marked.
Show Uncalibrated Rays: View/hide the rays for uncalibrated cameras.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

The Tie Points layer contains the following sub-layers:

GCPs/MTPs: All the Manual Tie Points, 2D GCPs, 3D GCPs, and Check Points of the project.
Automatic: The Automatic Tie Points computed during step 1. Initial Processing. Only Automatic Tie Points visible in at least 3 images are displayed.

 

GCPs/MTPs

The GCPs/MTPs layer has the following structure:

Display Properties: Displays properties of all Manual Tie Points and GCPs.
Computed Position: View/hide the points optimized position.
Minimum Pixel Size: Defines the size of the points' computed positions on the screen (not the real size of the points with respect to the model). This property
allows the points to be visible both when visualizing the model from very close and from very far. When the zoom level is above the given zoom level defined by the
Minimum size property, the points keep the same size on the screen independently from the zoom level. When zooming in closer to the model, below the zoom
level defined by the Minimum size property, the size of the points on the screen will increase each time the user zooms in so that the points remain visible even if
the view is close to the model.
Minimum Physical Size: Defines the minimum physical size of the points in the 3D View. This defines the zoom level below which the points need to be displayed
with their real size with respect to the model so that the points remain visible even when zooming in very close to the model.
Marked Color: Cross color of the points' computed positions for points marked on at least 2 images.
Non marked color: Cross color of the points' computed positions for points marked in less than 2 images.
Initial Position: View/hide the points' initial positions (this property affects only the GCPs and Check points).
Minimum Pixel Size: Defines the size of the points' initial positions on the screen (not the real size of the points with respect to the model). This property allows
the points to be visible both when visualizing the model from very close and from very far. When the zoom level is above the given zoom level defined by the
Minimum size property, the points keep the same size on the screen independently from the zoom level. When zooming in closer to the model, below the zoom
level defined by the Minimum size property, the size of the points on the screen will increase each time zooming in so that the closer to the model the view gets,
the points remain visible.
Minimum Physical Size: Defines the physical minimum size of the points on the 3D View. This defines the zoom level below which the points need to be
displayed with its real size with respect to the model so that the points remain visible even when zooming in very close to the model.
Color: Cross color of the points' initial positions for GCPs.
Checkpoint Color: Cross color of the points' initial positions for Check Points.
Position error: View/hide the line between the points' initial and computed positions (this property affects only the GCPs and Check points).
Color: Color for the line between the points' initial and computed positions (this property affects only the GCPs and Check points).

 



Show Error Ellipsoid: View/hide the ellipsoid formed by the theoretical error. For more information: 202559139.
Color: Color for the error ellipsoid.
Physical Size Scale: Defines the minimum physical size of the ellipsoid on the 3D View. This defines the zoom level below which the ellipsoid need to be
displayed with their real size with respect to the model so that the ellipsoid remain visible even when zooming in very close to the model.
List of Manual Tie Points, 2D GCPs, 3D GCPs and Check points: Each point has the following sub-element:
Display Properties: This layer allows the user to edit the display properties for the corresponding point. The properties that can be edited are the same than the
properties for all the points.

On the left of each point's name, an icon is displayed that indicates the type of the point. The type can be:

 Manual Tie Point
 2D GCP
 3D GCP
 Check Point

By right clicking the GCPs/MTPs layer, a context menu with the following action appears:

Export Points: Opens the Export pop-up, allowing the user to export Manual Tie Points and/or, export initial and/or computed GCPs position.

Note: If the model does not have GCPs or Manual Tie Points, the option Export Points will be grayed out.

The available formats are:
AutoCad DFX (*.dfx)
ESRI Shapefiles (*.shp)
Keyhole Markup Language (*.kml)
Microstation DGN (*.dgn)

On the top of the Export  pop-up there are 3 check-boxes that allow the user to select what kind of points to export:

Export Initial GCPs position: Exports the initial position of the GCPs.
Export Computed GCPs position: Exports the computed position of the GCPs.
Export Manual Tie Points: Export the Manual Tie Points.

By right clicking on a point layer, a context menu with the following actions appears:

Rename: Rename the point.
Remove: Removes the point.

 

Automatic

This layer displays the Automatic Tie Points that are computed during initial processing. Each Tie Point is visible in at least 3 images. The Automatic layer has
the following sub-element:

Display Properties: Displays properties of the Automatic Tie Points.
Point Size: Size for each point in the 3D View.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.
The Processing Area layer appears on the Layers section of the left sidebar once a Processing Area is drawn.

Warning:
It is recommended to include areas covered by images in the Processing Area, so as to exclude areas of low overlap that can affect the results.  
The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 1.
Initial Processing.
When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud and the Volumes View and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index. 
When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud and the Volumes View but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and
Index. 
When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.
When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected. 

Warning:  
In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the corresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters. 

Note: For step by step instructions about how to select a Processing Area: 202560179.

 

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/203890769
https://support.pix4d.com/hc/en-us/articles/202560179


By right clicking on the Processing Area layer a context menu with the following option appears:

Remove: Allows the user to remove the Processing Area. The Create Processing Area icon in the Create section of the left sidebar of the rayCloud can be used
again to create a new Processing Area. The Processing Area layer of the Layers section of the left sidebar of the rayCloud is removed. 

 

The Processing Area has the following sub-element:

Display Properties: Allows the user to edit the display properties for the Processing Area. The following properties can be edited:
Color: Color of the top, bottom, and side planes that define the area.
Vertex Color: Color of the spheres that represent the vertices of the middle plane of the area.
Vertex Radius: Radius of the spheres that represent the vertices of the middle plane of the area.
Line Color: Color of the lines between the vertices of the planes (bottom, middle, and top planes) of the area.
Line Width: Width of the lines between the vertices of the planes (bottom, middle, and top planes) of the area.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main
window. 

Note:  
This layer is also accessible from the Volumes view: On the Menu bar, click View > Volumes to open the Volumes. The Layers section is displayed on
the left of the main window. The Volumes view is available when the point cloud and the DSM are generated.
The Display Properties of the point clouds can be changed in the rayCloud and the Volumes. When they are changed in one view, they will be inherited
in the other view. 

Note: By default, the different point clouds are not loaded or displayed:
The name of a loaded point cloud is displayed in standard format, while the name of point clouds that are not loaded are displayed in italics.

By clicking on the point cloud's check box, the corresponding point cloud's visibility is toggled in the 3D View.
Once step 2 is completed, when reopening a project, or when a point cloud has been unloaded:
The point clouds are not loaded in the rayCloud. The next time that the point cloud's check box is selected, the Information i0014 pop-up message
appears: 

OK: Loads and displays the mentioned layer in the rayCloud.
Cancel: Closes the pop-up message and does not perform any action.

 

 

 



 

 

Densified Point Cloud

The Densified Point Cloud layer has a sub-layer that displays the name of the available point cloud(s). If the point cloud has been generated by splitting it into
multiple parts, each part is displayed as one layer. On the left of the point cloud name there is an icon indicating that the layer is a point cloud: . 

The loaded point cloud layer has the following sub-elements:

Display Properties: Allows to edit the display properties for the densified point cloud. The following property can be edited:
Point Size: Size of each point for the densified point cloud in the 3D View.
Show Class Color: Displays the point cloud classification results. Each point is drawn as a flat square, having a different color according to the predefined point
group it belongs. When the point cloud classification is not generated, white color is applied to all the points. White color is also applied to points that belong to a
user-defined group.
Shader: Defines the points shape and color in the 3D View. The different options are:
Screen Aligned Quads (default): Each point is drawn as a flat square where the point is located. It is the fastest to render but produces many artifacts when
changing the viewpoint. The color for each point comes from the reconstruction.
Spherical Points: Each point is drawn as a non-perspective corrected sphere, for example, an approximated ball. It reduces the artifacts when moving the view but
is not correct when the points are very close to the viewpoint. It gives the best compromise between rendering speed and image quality. The color for each point
comes from the reconstruction.
Spherical Points (HD): Each point is drawn as a perspective corrected sphere. This gives the highest image quality but it is very slow to render. The color for each
point comes from the reconstruction.
Screen aligned quads, Altitude (Red,Green,Blue): The same as Screen Aligned Quads but the color for each point is given by the altitude.
Spherical Points, Altitude (Red,Green,Blue): The same as Spherical Points but the color for each point is given by the altitude.
Spherical Points (HD), Altitude (Red,Green,Blue): The same as Spherical Points (HD) but the color for each point is given by the altitude.
Screen aligned quads, Thermal: Useful for thermal project. The same as Screen Aligned Quads but the color for each point is given by the value of the channel in
the Ironbow palette.
Spherical Points, Thermal: Useful for thermal project. The same as Spherical Points but the color for each point is given by the value of the channel in the Ironbow
palette.

By clicking on an specific densified point cloud's check box, the corresponding point cloud is shown or hidden in the 3D View.

By right clicking on an specific densified point cloud's name, a context menu with the following action appears:

Load Layer: Visible if the point cloud is not loaded, loads the point cloud in the rayCloud.
Unload Layer: Visible if the point cloud is loaded, unloads the point cloud from the rayCloud.

Tip: Loaded layers consume RAM and GPU memory. Unloading layers that are not needed increases the speed using the rayCloud.

 

 



Export Point Cloud: Allows to export a Densified Point Cloud of all the selected point groups, with the selected properties, in the selected formats and with the
desired path / file name.

Important: If a Processing Area exists, only points withing the processing area are exported.

Useful in cases where:
The point cloud has been modified using the rayCloud (deleted points, changed or created the Processing area).
The point groups generated during the point cloud classification need to be exported.
The intent is to export only one/some point groups.
Some point cloud format files were not generated (not selected in the processing options).
Change output options: Save/discard colors.

By clicking Export Point Cloud, the Export Point Cloud pop-up appears:

It contains 2 sections:
Exported Data: Allows the user to configure some parameters for the exporting and allows to select the Point Groups to export.
Save Colors: Selected by default, this saves the color values for each point of the Point Cloud. If not selected, the color will not be exported for the exported point
cloud.
Merge Tiles Into One File: Not selected by default. In case the point cloud output files were divided in parts, this forces to export all parts within the same file by
merging the parts.

Warning: When generating the point cloud, if it consists of many points, it is divided into parts.

When exporting a point cloud and selecting Merge Tiles Into One file, the software will export one tile for the entire point cloud.

Export Point Groups: Allows the user to select which point groups will be exported for the Densified Point Cloud. By default, all the point groups are selected.
Even when the point cloud classification has not been generated, the predefined point groups appear in the Export Groups section. By selecting the box next to
the point group name, the point group will be exported. 

Warning: The exported Densified Point Cloud will contain all the point groups selected. By default, all the point groups are selected.
The Disabled point group cannot be exported.

 
Format: Allows the user to select the different formats in which the point cloud is exported. It is possible to select:
LAS
LAZ
PLY
XYZ (it is possible to use as a delimiter: Space, Tab, Comma and Semicolon).

And:

 

 

 



File Name: Displays the path and name where the point cloud will be stored. By default, this is the project folder where the point cloud is stored after step 2. Point
Cloud and Mesh.
Browse...: Allows the user to select the path/name where the exported point cloud will be stored.

Warning: If the exported point cloud file is saved with the same name in the same folder where an existing file exists, it will replace the existing point
cloud.

OK: Saves the project and exports the selected formats with the selected parameters.
Cancel: Closes the pop-up message and does not perform any action. 

 

External Point Clouds

It is possible to visualize other point clouds by selecting the point cloud file and drag and dropping it into the Point Clouds layer. A new sub-layer is added to the
Point Clouds layer with the path to the loaded file as name. The loaded point cloud has the following sub-element:

Display Properties: Displays properties for the corresponding point cloud.
Point Size: Size of each point for the corresponding point cloud in the 3D View.
Shader: Defines the points shape and color in the 3D View. The different options are:
Screen Aligned Quads (default): Each point is drawn as a flat square where the point is located. It is the fastest to render but produces many artifacts when
changing the viewpoint. The color for each point comes from the reconstruction.
Spherical Points: Each point is drawn as a non-perspective corrected sphere, for example, an approximated ball. It reduces the artifacts when moving the view but
is not correct when the points are very close to the viewpoint. It gives the best compromise between rendering speed and image quality. The color for each point
comes from the reconstruction
Spherical Points (HD): Each point is drawn as a perspective corrected sphere. This gives the highest image quality but it is very slow to render. The color for each
point comes from the reconstruction.
Screen aligned quads, Altitude (Red,Green,Blue): The same as Screen Aligned Quads but the color for each point is given by the altitude.
Spherical Points, Altitude (Red,Green,Blue): The same as Spherical Points but the color for each point is given by the altitude.
Spherical Points (HD), Altitude (Red,Green,Blue): The same as Spherical Points (HD) but the color for each point is given by the altitude.

The following formats can be loaded:

.las

.laz

Loaded point clouds are displayed in the right position if it is a Pix4Dmapper file or an external file using the same coordinate system as the output coordinate
system selected in Pix4Dmapper.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

Note: This layer is also accessible from the Volumes view: On the Menu bar, click View > Volumes to open the Volumes. The Layers section is
displayed on the left of the main window. The Volumes view is available when the point cloud and the DSM are generated. 

The Point Groups layer contains the following sub-layers:

Unclassified: Selected by default. It contains points that do not belong to any other point group. By default, all the points are Unclassified.
Disabled: Points that will not be used for step 3. DSM, Orthomosaic and Index. When processing step 3. DSM, Orthomosaic and Index, only the points belonging
to the point group Disabled will not be used.
Ground, Road Surface, High Vegetation, Building, Human Made Object: Predefined point groups created for the Point Cloud Classification. When the point cloud
classification has not been generated the predefined point groups are empty.

By selecting/unselecting a specific Point Group checkbox, the corresponding Point Group is shown/hidden in the 3D View.

By right clicking a specific Point Group, a context menu with the following action appears:

Rename: Allows to change the Point Group name.
Remove: Deletes the selected Point Group.

For:

Unclassified: Rename and Remove are grayed out.
Disabled: Rename and Remove are grayed out.
Predefined Point Groups: Rename and Remove are grayed out. 
New Point Groups: Rename and Remove are available.

By right clicking on the Point Groups layer, a context menu with the following action appears:

New Point Group: Option to create New Point Group. By clicking New Point Group, a new point group named Group 1 will be created in the Point Groups sub-
layer. 
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

Note:  
This layer is also accessible from the Volumes view: On the Menu bar, click View > Volumes to open the Volumes. The Layers section is displayed on
the left of the main window. The Volumes view is available when the point cloud and the DSM are generated.
The Display Properties of the triangle meshes can be changed in the rayCloud and the Volumes. When they are changed in one view, they will be
inherited in the other view. 

The Triangle Meshes layer can display a 3D Textured Mesh. 

By default, the 3D Textured Mesh (if generated) is not loaded in the 3D view. 
By selecting/unselecting the Triangle Mesh checkbox, the corresponding triangle mesh is shown/hidden in the 3D view.

The Triangle Meshes layer can also display a 2.5D Triangle Mesh of any point cloud file that has been loaded by dragging and dropping it on the Triangle
Meshes layer. The following formats can be dragged and dropped:

.las 

.laz

It displays a 2.5D triangle mesh, in the right position if it is a Pix4Dmapper file or external file in the same coordinate system as the output coordinate system
selected in Pix4Dmapper.

Warning: DO NOT drag and drop a point cloud to generate the Triangle Mesh while a project is processing; processing may stop.

Once step 2. Point Cloud and Mesh is completed, when reopening a project, or when a triangle mesh has been uploaded, the Triangle Meshes are not loaded in
the 3D view. Next time that the triangle meshes checkbox is selected, the triangle mesh is loaded again.

The Triangle Meshes layer contains the following sub-layers:

Display Properties: Displays properties for all the triangle meshes.
List of triangle meshes: All the triangle meshes loaded in the project.

 

Display Properties

Displays properties for all the triangle meshes.

Allows to edit the display properties for all the triangle meshes. The following properties can be edited:

Color: The color of all the triangles of the triangle meshes. The color is only applied to the monochrome shader. The default color is gray.
Shader: Specifies the way each triangle of the mesh is colored. The color is related to the 3D position of each triangle. The mesh can be colored in different ways:
Textured: Selected by default for the 3D textured Mesh generated for the project. Not available for dragged and dropped triangle meshes. The triangles are colored
with the texture file generated when generating the 3D Textured Mesh. 
Monochrome: The triangles are colored with a color-to-black scale that depends on an angle measured with respect to a virtual sun positioned 45 degrees from
the north-east horizon. It uses the color selected above.
Color: The triangles are colored with an RGB scale. The color of a triangle depends on an angle measured with respect to 3 virtual suns that have Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the three virtual suns. This shader displays a slope map if the model is
viewed from above. It gives information about the orientation of each surface.
Altitude (Red, Green, Blue): The triangles are colored with an RGB scale. The color of a triangle depends on the altitude of the triangle.
Altitude (Topography): The triangles are colored with a default scale. The color of a triangle depends on the altitude of the triangle.
Thermal: Useful for thermal project. The triangles are colored according to the channel value in the Ironbow palette. 

 

List of  triangle meshes

By default, the 3D Textured Mesh (if generated) is not loaded in the 3D view. If it has been generated, by selecting/unselecting the triangle mesh's checkbox, the
corresponding triangle mesh is shown/hidden in the 3D view.

By right clicking on a specific triangle mesh's name, a context menu with the following action appears:

Load Layer: Visible if the triangle mesh is not loaded, load the triangle mesh in the 3D view.
Unload Layer: Visible if the triangle mesh is loaded, unload the triangle mesh from the 3D view.
Export Mesh...: Allows to export a triangle mesh from the 3D view with the selected properties, in the selected formats and in the desired file path/image name. 

By clicking Export Mesh..., the Export Mesh pop-up appears:

 

 

 



It contains 4 sections:

3D Textured Mesh: Exports the 3D textured mesh. 
3D Textured Mesh Settings: It contains 2 sections: 
Texture: Allows to rename the texture file. By default the texture file name is project_name_texture. 
Format: Allows to select the different formats in which the textured mesh is exported. It is possible to select:
PLY
FBX
DXF
DXF (polylines)
OBJ
Tiled Texture: It tiles the texture file of the obj file.
3D PDF: If this format is selected, it is possible to select the Logo that is embedded in the 3D PDF. The logo can be imported in .jpeg or .tiff format.
LOD Mesh (Beta): Allows to generate and export the mesh to multi-LOD (level of details) format. The LOD mesh is in Beta version.
LOD Mesh Settings: Allows to define the LOD mesh settings:
Number of Levels: Allows to define the number of different levels of details to be generated between 1 and 7. The higher the number of levels the more detailed the
representation and the longer the processing time.

Important: For large projects, it is possible that the LOD cannot be generated for a high number of levels as there is a maximum
number of 20000 triangles that can be generated for each level of details.

Texture Quality: Allows to define the resolution of the texture. It is possible to select:
Low - 512x512
Medium - 1024x1024
High - 4096x4096
Format: Allows to select the format in which the LOD mesh is exported. It is possible to select:
OSGB
SLPK

 



Warning: 
The two files cannot be be generated and exported at the same time. It is possible to export them separately.
The SLPK file is georeferenced only when the project is georeferenced. Only the georefernced SLPK files can be opened in ArcGIS
Online and ArcGIS Earth.

And:

Save As: Displays the path to the folder where the mesh is stored. By default, this is the project folder where the 3D Textured Mesh is stored after step 2. Point
Cloud and Mesh.
Browse...: Allows the user to select a different name for the mesh and a different path to be stored.

Warning: If the exported triangle mesh is saved with the same name in the same folder where a previously generated triangle mesh
already exists, the existing triangle mesh will be overwritten.

OK: Saves the project and exports the selected formats with the selected parameters.
Cancel: Closes the pop-up message and does not perform any action. 
Help: Opens the Pix4Dmapper help.

Each triangle mesh layer has the following sub-element:

Displays Properties: Displays properties for the corresponding triangle mesh and only applies to the corresponding triangle mesh. The same properties are
available for all triangle meshes.

On the left of the triangle mesh name, there is an icon indicating that the layer is a triangle mesh: .
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The Layers section in the left sidebar is displayed on the left of the main window.

 

The Objects layer contains the following sub-layers:

Polylines: Contains the list of polylines added to the project. A Polyline object is a continuous line composed of one or more sub-lines. It is created by specifying
the vertices of each line. For more information about the concept of polyline: 202559829.
Surfaces: Contains the list of surfaces added to the project. A Surface object can be used to define planar areas such as a road, the roof of a building, etc. It can
also be used to correct the DSM to generate a better orthomosaic on these surfaces and to correct the visual aspect of the 3D Textured Mesh removing noise or
filling areas. 
Animation Trajectories: Contains the list of Animation Trajectories added to the project. The animation Trajectories consist of waypoints that define the path for
an imaginary camera that records the scene.
Orthoplanes: Contains the list of Orthoplanes added to the project. The Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model
without having any impact / modifications in the model.
Scale Constraints: Contains the list of Scale Constraints added to the project. The Scale Constraint is a line with known real Cartesian distance between 2
points, allowing to set up a local scale of the model.
Orientation Constraints: Contains the list of Orientation Constraints added to the project. The Orientation Constraints is a line that represents a
known axis, allowing to set up an local orientation of the model.

 

Polylines

 

https://support.pix4d.com/hc/en-us/articles/202559829


Contains the list of polylines added to the project. A Polyline object is a continuous line composed of one or more sub-lines. It is created by specifying the
vertices of each line. For more information about the concept of Polyline: 202559829.

The Polylines layer has the following structure:

Display Properties: This layer allows the user to edit the display properties all the polylines.
Vertex Color: Color of the spheres that represent the vertices of the polylines.
Vertex Radius: Radius of the spheres that represent the vertices of the polylines.
Line Color: Color of the lines between the vertices of the polylines.
Line Width: Width of the lines defining the polylines.
List of Polylines: Each Polyline has the following sub-element:
Display Properties: This layer allows the user to edit the display properties of the line. The properties that can be edited are the same than the Display properties
of the Polylines listed above.

By right clicking on the Polylines sub-layer, a context menu with the following options appears:

New Polyline: Allows the user to draw a new polyline. For step by step instructions: 202560309.
Export All Polylines: Opens the Export pop-up that allows to export the corresponding components from the polyline into a file.

Important: A Polyline is composed of lines and vertices to which Manual Tie Points are associated. The lines and vertices of the Polylines are
exported.

The following file formats can be selected for export:
AutoCAD DFX (.dfx).
ESRI Shapefiles (.shp).
Keyhole Markup Language (.kml).
Microstation DGN (.dgn).

Important: The option Export All Polylines is enabled only if at least one Polyline has been drawn.

Surfaces

 

 

https://support.pix4d.com/hc/en-us/articles/202559829
https://support.pix4d.com/hc/en-us/articles/202560309


Contains the list of surfaces added to the project. A Surface object can be used to define planar areas such as a road, the roof of a building, etc.It can also be
used to correct the DSM to generate a better orthomosaic on these surfaces and to correct the visual aspect of the 3D Textured Mesh removing noise or filling
areas. 

The Surfaces layer has the following structure:

Display Properties: This layer allows the user to edit the display properties for all the surfaces.
Vertex Color: Color of the spheres that represent the vertices of the surfaces.
Vertex Radius: Radius of the spheres that represent the vertices of the surfaces.
Line Color: Color of the lines between the vertices of the surfaces.
Line Width: Width of the line defining the surface areas.
Base: View/hide the base of the surfaces.
Color: Color of the base of the surfaces.
Shader: Specifies the way each triangle of the base surfaces is colored. The color is related to the 3D position of each triangle. 2 ways of coloring the triangles
are available:
Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.
Color: The triangles are colored with a RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.
List of Surfaces: Each Surface has the following sub-element:
Display Properties: This layer allows the user to edit the display properties of a surface. The properties that can be edited are the same than the Display
Properties of the Surfaces listed above.

By right clicking on the Surfaces sub-layer, a context menu with the following options appears:

New Surface: Allows the user to draw a new surface. For step by step instructions: 202560269.
Export All Surfaces: Opens the Export pop-up that allows to export the corresponding components from the surface into a file.

Important: A Surface is composed of a surface mesh and vertices to which Manual Tie Points are associated. The vertices and the surface mesh of
the Surfaces are exported.

The following file formats can be selected for export:
AutoCad DFX (.dfx).
ESRI Shapefiles (.shp).
Keyhole Markup Language (.kml).
Microstation DGN (.dgn).

 

https://support.pix4d.com/hc/en-us/articles/202560269


Important: The options Export All Surfaces is enabled only if at least one Surface has been drawn.

   

List of objects

Each object layer has the following sub-element:

Display Properties: Displays properties of the corresponding objects. The properties that can be edited are not the same for all the objects.

Note: Changing the Display Properties of the selected object, affects only to the selected object.

On the left of the object name, there is an icon indicating the type of the object:

 Polyline

 Surface

By right clicking on a specific object's layer, a context menu with the following options appears:

Insert Vertices: (only available for Polylines) Insert vertices on the line between existing vertices of the object.
Rename: Rename the object.
Export: Opens the Export pop-up that allows the user to export the corresponding components from the selected object into a file.

Important: 
A Polyline is composed of lines and vertices to which Manual Tie Points are associated. The vertices and lines of the Polyline will be exported.
A Surface is composed of a surface mesh and vertices to which Manual Tie Points are associated. The vertices and the surface mesh of the Surface will
be exported.

The following file formats can be selected for export:
AutoCad DFX (.dfx).
ESRI Shapefiles (.shp).
Keyhole Markup Language (.kml).
Microstation DGN (.dgn).
Remove: Removes the selected object.

Important: The option Remove do not delete the Manual Tie Points generated when drawing the object (when drawing a Polyline or a Surface, the
vertices are associated to Manual Tie Points).

 

Animation Trajectories

 

 

 

 



Contains the list of Animation Trajectories added to the project. The Animation Trajectories consist of waypoints that define the path for an imaginary camera that
records the scene.

The Animation Trajectories layer has the following structure:

Display Properties: Displays properties of the corresponding objects. The properties that can be edited are:
Start Vertex Color: Color of the spheres that represent the first waypoints.
Vertex Color: Color of the spheres that represent the waypoints.
Vertex Radius: Radius of the spheres that represent the waypoints.
Line Color: Color of the lines between waypoints.
Line Width: Width of the line defining the path between waypoints.
List of Animation Trajectories: Each Animation Trajectory has the following sub-element:
Display Properties: This layer allows to edit the display properties of the Animation Trajectories. The properties that can be edited are the same than the Display
properties of the Animation Trajectories listed above.

By right clicking on the Animation Trajectories sub-layer, a context menu with the following options appears:

New Video Animation Trajectory: Allows to create a new Animation Trajectory. For step by step instructions: 202560299.
Import...: Opens the Import Video Animation Trajectory pop-up that allows to import Animation Trajectories created previously with Pix4Dmapper for the
same area of study or created manually. 

For step by step instructions about how to import an Animation Trajectory to the rayCloud: 202560569.

https://support.pix4d.com/hc/en-us/articles/202560299
https://support.pix4d.com/hc/en-us/articles/202560569


Contains the sections:

Navigation window: Used to search for and select the file to be imported.
File name: Displays the name of the selected file to be imported.
Files of type:  Displays the possible formats accepted for the input file: .csv and .txt are accepted.

And contains the action buttons:

Open: Imports the selected file.
Cancel: Does not import the animation and exits the pop-up.

Important: Manually created Animation Trajectories must have the same format and extension than files generated when exporting an Animation
Trajectory with Pix4D.

 

List of Animation Trajectories

On the left of the object name, there is an icon indicating the type of the object:

 Animation Trajectory

By right clicking a specific object's layer, a context menu with the following options appears:

Rename: Renames the object.
Remove: Removes the selected object.
Export...: Opens the Export Video Animation Trajectory pop-up that allows to export the selected Animation Trajectory.

For step by step instructions about how to export an Animation Trajectory with the rayCloud: 203123429.

Contains the action buttons:

Save: Confirms the path and name to export the animation and opens the Video Animation Trajectory File Parameters pop-up:

Contains the options:

 

https://support.pix4d.com/hc/en-us/articles/203123429


Separator Character: Character to be used as separator for the different information for each waypoint / interpolated Point: 
Time [s], Position X, Position Y, Position Z, Rotation X, Rotation Y, Rotation Z.

Note: The default value for separator ";" in Microsoft Excel is read as Tab and will place each separated text in one column.

Comment Character: Character to be used as first character for the comment lines which includes information about the video animation options:
Name, Time computation, Interpolation, Max speed, Duration, Number of points, Distance unit of measure, Angle unit of measure.
Write Interpolated Points [m]: By default it is not selected. Only the video animation options, the created waypoints and its coordinates are stored. Select Write
Interpolated Points [m] to store as well intermediate points between consecutive waypoints and select the Maximum distance between interpolated points. By
default, the value is 1, and it will create one intermediate point per meter.

OK: Exports the animation. 
Cancel: Does not export the animation and exits the pop-up.
Help: Opens the Pix4Dmapper help.

Important: It is possible to export Animation Trajectories as CSV files which can be opened with any text editor or spreadsheets editor.

 

Orthoplanes

Contains the list of orthoplanes added to the project. An Orthoplane is a tool to create one or several orthophotos of arbitrary areas of the model without having
any impact / modifications in the model.

The Orthoplanes layer has the following structure:

Display properties: This layer allows the user to edit the display properties for all the orthoplanes.
Color: Color of the top, bottom, and side planes that define the area.
X Handle Color: Color of the X location arrow and X dimension sphere.
Y Handle Color: Color of the Y location arrow and Y dimension sphere.
Z Handle Color: Color of the Z location arrow and Z dimension sphere.
Near Plane Edge Color: Color of the lines that define the surface that represents the origin of the projection.
Far Plane Edge Color: Color of the lines that define the surface that represents the limit of the projection.
List of Orthoplanes: Each object has the following sub-element:
Display Properties: This layer allows the user to edit the display properties for the orthoplane. The Display Properties that can be edited are the same as the
Display Properties of the Orthoplanes listed above.

 

 



By right clicking on the Orthoplanes sub-layer, a context menu with the following options appears:

New Orthoplane: Allows to create a new 3D Orthoplane. For step by step instructions: 204664359.

By right clicking on a specific object's layer, a context menu with the following options appears:

Rename: Renames the object.
Remove: Removes the selected object.

 

Scale Constraints

Contains the list of Scale Constraints added to the project. A Scale Constraints object is a line with known real Cartesian distance between 2 points, allowing to
set up a local scale for the model.

The Scale Constraints layer has the following structure:

Display Properties: This layer allows to edit the display properties for all the Scale Constraints.
Vertex Color: Color of the spheres that represent the vertices of the Scale Constraints.
Vertex Radius: Radius of the spheres that represent the vertices of the Scale Constraints.
Line Color: Color of the lines between the vertices of the Scale Constraints.
Line Width: Width of the line defining the distance between vertices of the Scale Constraints.
List of Scale Constraints: Each object has the following sub-element:
Display Properties: This layer allows the user to edit the Display Properties of the Scale Constraint. The properties that can be edited are the same as the
Display Properties for the Scale Constraint listed above.

By right clicking on the Scale Constraints sub-layer, a context menu with the following options appears:

New Scale Constraint: Allows the user to create a new Scale Constraint. For step by step instructions: 205360375.

By right clicking on a specific object's layer, a context menu with the following options appears:

Remove: Removes the selected object.

 

Orientation Constraints

https://support.pix4d.com/hc/en-us/articles/204664359
https://support.pix4d.com/hc/en-us/articles/205360375


Contains the list of Orientation Constraints added to the project. An Orientation Constraints object is a line that represents a known axis, allowing to set up an
local orientation for the model.

The Orientation Constraints layer has the following structure:

Display properties: This layer allows the user to edit the display properties for all the Scale Constraints.
Vertex Color: Color of the spheres that represent the vertices of the Orientation Constraints.
Vertex Radius: Radius of the spheres that represent the vertices of the Orientation Constraints.
Line Width: Width of the line defining the Orientation Constraints.
List of Orientation Constraints: Each object has the following sub-element:
Display Properties: This layer allows the user to edit the Display Properties of the Orientation Constraint. The Display Properties that can be edited are the
same as the Display Properties for the Orientation Constraints listed above.

By right clicking on the Orientation Constraints sub-layer, a context menu with the following options appears:

New Orientation Constraint: Allows the user to create a new 3D Orientation Constraint. For step by step instructions: 205360385.

By right clicking on a specific object's layer, a context menu with the following options appears:

Remove: Removes the selected object.

 

Index > Interface > Menu View > rayCloud > Left sidebar > Layers  Previous  |  Next  

 

https://support.pix4d.com/hc/en-us/articles/205360385


Index > Interface > Menu View > rayCloud Previous | Next

 

Access: On the Menu bar, click View > rayCloud to open the rayCloud. The 3D View is displayed in the center of the main window.

The 3D View displays the different objects defined in a project, such as the cameras, the GCPs, etc.The different layers that are displayed in the 3D View and
that are also visible in the Layers section of the left sidebar are:

Cameras: This layer groups all the cameras of the project (calibrated, uncalibrated and disabled). One camera is associated with each image of the project. It is
defined by its initial position (if known), the optimized position and orientation.
Rays: They are displayed when clicking on a 3D point on the 3D View if the Cameras and the Rays layers are shown. The 3D point is projected to all the
calibrated cameras in which the point is visible. The rays cut the thumbnails of the cameras at the location where the point is visible in the original images.
Tie Points: This layer groups all the Manual Tie Points, GPCs, Check Points, and Automatic Tie Points. The Automatic Tie Points are computed during initial
processing.
Processing Area: This layer displays the Processing Area defined in the Map View or the rayCloud.
Point Clouds: This layer groups all the point clouds. It contains the Densified Point Cloud and the drag-and-dropped external point clouds.
Point Groups: This layer groups all the point cloud classes. It contains the unclassified group but also all the predefined groups of the point cloud classification
and the user-defined groups.
Triangle Meshes: This layer groups the 3D Textured Mesh and triangle meshes generated by triangulating a point cloud that is loaded as a triangle mesh.
Objects: This layer groups all the objects defined by the user. These objects can be Polylines, Surfaces, Animation Trajectories, Orthoplanes, Scale Constraints
and Orientation Constraints.
Clipping Box: This tool allows to visualize only the points included in the Clipping Box. This tool is not visible in the Layers section of the left sidebar.

The layers can be shown/hidden using the Layers section of the left sidebar, which can also be used to change the display properties (color, size, etc.) of each
layer. For more information about the Layers section of the left sidebar: 202558029.

Important: It is possible to change the Points Density by Press "Alt" + "+" or "AltGr" + "- " in order to increase or decrease the density, "Alt" + "0" reset
the Points Density to default values.

Important: The navigation in the 3D View (how the 3D view reacts when using the mouse or keyboard) depends on the Navigation Mode selected. For
more information and full description of all the possible actions to navigate in the 3D View using the mouse or keyboard: 205360675.

Important: Several predefined viewpoints exist such as top view, front view, etc. These predefined viewpoints are accessible using the keyboard or
the Menu bar rayCloud > Viewpoint. For more information about the available viewpoints: 202558069.

 

Layers

Cameras
By default, the Camera layers are displayed on the 3D View as:
Blue sphere: Initial camera positions (GPS coordinates).
Green sphere: Optimized camera positions.
Red sphere: Initial camera positions (GPS coordinates) for Uncalibrated Cameras for which Pix4Dmapper could not find optimized positions and therefore were
not used for the reconstruction.
Pale Red sphere: Initial camera positions (GPS coordinates) for Uncalibrated Cameras that were disabled by the user and were not used for the reconstruction.
Green line: Distance between initial and optimized positions.
Green lines: Projection lines between the optimized camera positions and the original image thumbnails.
Green squares: Borders of the original image thumbnails.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/205360675


Cameras

Rays
By default, the rays can have the following colors:
Green rays: The rays that connect the selected 3D point and the calibrated cameras in which the 3D point was visible but not marked.
Orange rays: The rays that connect the selected 3D point and the calibrated cameras in which the 3D point was marked.
Red ray: The rays that connect the selected 3D point and the uncalibrated cameras.
Light Blue ray: The ray that connects the selected 3D point with the image that is currently selected in the Image View, and on which the point is visible but not
marked.
Light Purple ray: The ray that connects the selected 3D point with the image that is currently selected in the Image View, and on which the point has not been
marked.



Rays

Tie Points
By default, the Tie Points are displayed on the 3D View as:
Green cone: Optimized position of Manual Tie Points, GCPs, Check Points, and vertices of the Objects drawn in the 3D View that are marked in at least 2
images.
Orange cone: Vertices of the Objects drawn in the 3D View that are marked in less than 2 images.
Blue cone: Original position of GCPs and Check Points.
Colored point: Automatic tie point computed at step 1. Initial Processing colored using the original images.



Manual Tie Points



GCPs



Automatic Tie Points

Processing Area
By default, a Processing Area is displayed on the 3D View as:
Gray spheres: Vertices of the middle plane of the 3D Processing Area.
Gray lines: Lines between the vertices of the planes (bottom, middle, and top planes) of the 3D Processing Area.
Transparent gray planes: Top, bottom, and side planes that form the 3D Processing Area.
Transparent light gray planes: Top, bottom, and side planes that form the 3D Processing Area when hovering over the area in the 3D View.
White lines: Lines between the vertices of the planes (bottom, middle, and top planes) of the 3D Processing Area when selecting the area in the 3D View.



Processing Area

Point Clouds
By default, the Point Clouds are displayed on the 3D View using the 3D coordinates of their points as computed by Pix4Dmapper.

The coordinates of a given point are displayed on the bottom right part of the main window when the point is selected in the 3D View.



Densified Point Cloud

Point Groups
By default, the Point Groups are displayed on the 3D View using the 3D coordinates of the points of the selected point groups as computed by Pix4Dmapper or
defined by the user.



Point Groups: Disabled, Ground and High Vegetation

Triangle Meshes
By default, the 3D Textured Mesh is displayed using the Texture shader and other triangle meshes are displayed using the Monochrome shader with gray color.
For more information about the Display Options of the Triangle Meshes: 202558079.

Triangle Mesh

Objects



By default, the Objects are displayed on the 3D View as:
For Polylines, Surfaces and Video AnimationTrajectories:
Green sphere: Object vertices for Polylines and Surfaces. Waypoints for Animation Trajectories.
Green Arrow: Orientation of the camera in the waypoint (only for Animation Trajectories).
Blue sphere: First Waypoint in Animation Trajectories (only for Animation Trajectories).
Blue Arrow: Orientation of the camera in the first waypoint (only for Animation Trajectories).
Green surface: Base surface for Surfaces.
Green lines: Lines between vertices/waypoints from the same object. For Polylines, Surfaces and Animation Trajectories.
For Scale Constraints:
Light Blue double arrow: Scale Constraints.
For Orientation Constraints:
Dark Blue single arrow: Orientation Constraints.
For Orthoplanes:
Red sphere: Allows to increase the 3D orthoplane in the X dimension.
Blue sphere: Allows to increase the 3D orthoplane in the Y dimension.
Green sphere: Allows to increase the 3D orthoplane in the Z dimension.
Red cone: Allows to move the 3D orthoplane in the X dimension.
Blue cone: Allows to move the 3D orthoplane in the Y dimension.
Green cone: Allows to move the 3D orthoplane in the Z dimension.
Gray lines: Lines between the vertices of the planes of the 3D orthoplane.
Light gray lines: Defines the frontal surface of the 3D orthoplane (face that will be mapped).
Transparent light blue planes: Side planes that form the 3D orthoplane.

Polylines



Surfaces



Animation Trajectory



Orthoplanes



Scale Constraint



Orientation Constraint

Clipping Box
Pink spheres: Allows to increase the 3D area in the X dimension.
Light blue spheres: Allows to increase the 3D area in the Z dimension.
Light green spheres: Allows to increase the 3D area in the Y dimension.
Light purple sphere: Allows to rotate the 3D area.
Transparent light blue planes: Side planes that form the 3D area.



Index > Interface > Menu View > rayCloud Previous | Next
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
For information about the sidebar's display possibilities: 202558389.

The rayCloud right sidebar displays different information for the element that is currently selected in the 3D View. The elements that can be selected in the 3D
View are:

Clipping box
Cameras
GCPs and Manual Tie Points
Automatic Tie Points
Processing Area
Point Clouds
Objects: Polylines, Surfaces, Animation Trajectories, Orthoplanes, Scale Constraints and Orientation Constraints

 

Index > Interface > Menu View > rayCloud  Previous  |  Next  

 

https://support.pix4d.com/hc/en-us/articles/202558389
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. In the toolbar, click the button . The right sidebar is displayed on the right of

the main Window.
The Clipping Box is displayed in the 3D View and the Clipping Box Properties are displayed in the right sidebar.

Note: The Clipping Box only affects the display, not the results of any outputs of step 1. Initial Processing, step 2. Point Cloud and Mesh or step 3.
DSM, Orthomosaic and Index.

 

The following information is displayed:

Center X [m]: Relative X coordinate of the center of the Clipping Box.
Y [m]: Relative Y coordinate of the center of the Clipping Box.
Z [m]: Relative Z coordinate of the center of the Clipping Box.
Size X [m]: Size in meters of the X side of the Clipping Box.
Y [m]: Size in meters of the Y side of the Clipping Box.
Z [m]: Size in meters of the Z side of the Clipping Box.
Rotation Z [degree]: Represents the angle between:
The X axis of the model and the X axis of the Clipping Box.
The Y axis of the model and the Y axis of the Clipping Box.

 

 

 



Rotation 0º Rotation 45º

Below that information there are four buttons:

Expand: Creates a new Clipping Box which covers the full model.
Apply: Applies the changed in the values of the properties of the Clipping Box.
Cancel: Cancels the changes in the values of the properties of the Clipping Box.
Help: Opens the Pix4Dmapper help.

Note: On the toolbar,   applies the Clipping Box in the 3D View and visualizes only the area contained in the Clipping Box.

For step by step instructions about how to use the Clipping Box: 204048035.
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https://support.pix4d.com/hc/en-us/articles/204048035


Index > Interface > Menu View > rayCloud > Right sidebar  Previous  |  Next  

  

Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.

The camera information is displayed on the right sidebar when selecting in the 3D View:

The initial camera position (for calibrated and uncalibrated cameras for which the initial position is known).
The calibrated camera position (for calibrated images).
The camera associated image thumbnail (for calibrated images).
The camera information is also displayed when selecting a given camera in the Layers section of the left sidebar.

 The displayed camera information is different for:

Calibrated images
Uncalibrated images

Calibrated images

The following information is displayed in the Selection section:

Camera: Name of the image associated to the selected camera.
Camera Model: Camera model associated to the selected camera, including Image size in pixels (widthxheight) and band configuration.
Number of Marked MTPs and GCPs: Number of Manual Te Points / GCPs marked on the image.
Number of Automatic Tie Points: Total number of matched keypoints found on the image.
Computed Position [units]: X, Y, Z computed position of the camera.

 

Buttons:

Disable: Disables the image. In order to remove the camera from the reconstruction, the project needs to be reoptimized. This button is shown for enabled
cameras.
Enable: Enables the image. In order to include the camera in the reconstruction, the project needs to be reoptimized. This button is shown for disabled cameras.
Uncalibrate: This option should be chosen if the user is not confident about the calibration of the camera.
Help: Opens the Pix4Dmapper help. 
Apply: (available when the Image Annotation tool is used): Applies the image annotation. 

Image preview: Displays the image associated to the calibrated camera.

Orange cross: Represents the position of an automatic keypoint that has been matched with keypoints from other images.
Yellow cross: Represents a Manual Tie Point or a GCP marked on the image.
Right slider: Allows to select the minimum number of images with which a keypoint has been matched.

 Zoom in: Zoom in on the image. 

 



 Zoom out:  Zoom out of the image.

 Image Annotation:  Activates the Image Annotation mode.

 The Image Annotation tool includes the following: 

Mask: The pixels masked are not used for processing. Suitable for:
Removing an obstacle that appears in a few images, like a scaffold. For more information: 210748986.
Removing the background of the Orthoplane: For more information: 210226543.
(for Bebop projects) Removing the sky automatically. For more information: 205327965.
Carve: All the 3D points located on the rays connecting the camera center and the annotated pixels are not used for processing. Suitable for sky removal. For
more information: 212262883; 212262943.
Global Mask: The pixels annotated are propagated to all the images. All these pixels are not used for processing. Suitable for a consistent obstacle on all the
images, e.g. the foot of the drone. For more information: 210749586.

Tip: For the selected image:
In order to zoom in/out: Place the mouse over the location on which to zoom, and move the mouse scroll button forwards/backwards.
In order to pan: Place the mouse over the location on which to pan, and press the left mouse button while dragging the mouse.
By placing the mouse over an image and typing space, the image is displayed in full screen, where is possible to zoom, pan, click, etc.
When using the full screen mode, by typing:
Space: Minimizes the image and keeps the full screen zoom and panning level.
Esc: Minimizes the image and keeps the previous zoom and panning.

 

Images section

When double clicking on a cross in the Image preview (Automatic/Manual Tie Point or GCP), the Images section displays the images where the point can be
found (including the currently selected image). For more information: 202558459.

 

Uncalibrated images

When selecting an uncalibrated camera, it can be manually calibrated.

The following information is displayed in the Selection section:

 

https://support.pix4d.com/hc/en-us/articles/210748986
https://support.pix4d.com/hc/en-us/articles/210226543
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https://support.pix4d.com/hc/en-us/articles/202558459


Camera: Name of the image associated to the selected camera.
Camera Model: Camera model associated to the selected camera, including Image size in pixels (widthxheight) and band configuration.
Number of Marked MTPs and GCPs: Number of Manual Te Points / GCPs marked on the image.
Number of Automatic Tie Points (Inliers/Total): Inlier points and total number of matching keypoints found on the image.
Computed Position [units]: X, Y, Z position of the computed camera. Since there is no computed position, it appears as n/a.

 

Buttons:

Disable: Disables the image. In order to remove the camera from the reconstruction, the project needs to be reoptimized. This button is shown for enabled
cameras.
Calibrate: Allows to calibrate an uncalibrated camera. This button is enabled only if more than 20 Manual Tie Points and Automatic Tie Points are considered as
being inliers.
Close: Exits the manual calibration mode.
Help: Opens the Pix4Dmapper help. 
Apply: (available when the Image Annotation tool is used): Applies the image annotation.

Note: For step by step instructions about how to calibrate a camera: 202560189.

 

Image preview: Displays the image associated to the uncalibrated camera.

Red cross: Represents the position of an automatic keypoint that was not matched with keypoints of other images.
Orange crosses: Represents the position of an automatic keypoint which has a high probability of being accurately matched with keypoints of other images.
Yellow crosses: Represents a Manual Tie Point or a GCP marked on the image.
Right slider: Allows the user to select the minimum number of images with which a keypoint could be matched. 

 Zoom in: Zoom in on the image.

 Zoom out: Zoom out of the image.

 Image Annotation:  Activates the Image Annotation mode.

The Image Annotation tool includes the following: 

 

https://support.pix4d.com/hc/en-us/articles/202560189


Mask: The pixels masked are not used for processing. Suitable for:
Removing an obstacle that appears in a few images, like a scaffold. For more information: 210748986.
Removing the background of the Orthoplane: For more information: 210226543.
(for Bebop projects) Removing the sky automatically. For more information: 205327965.
Carve: All the 3D points located on the rays connecting the camera center and the annotated pixels are not used for processing. Suitable for sky removal. For
more information: 212262883; 212262943.
Global Mask: The pixels annotated are propagated to all the images. All these pixels are not used for processing. Suitable for a consistent obstacle on all the
images, e.g. the foot of the drone. For more information: 210749586.

Tip: For the selected image:
In order to zoom in/out: Place the mouse over the location on which to zoom, and move the mouse scroll button forwards/backwards.
In order to pan: Place the mouse over the location on which to pan, and press the left button while dragging the mouse.
By placing the mouse over an image and typing space, the image is displayed in full screen, where is possible to zoom, pan, click, etc.
When using the full screen mode, by typing:
Space: Minimizes the image and keeps the    full screen zoom and panning level.
Esc: Minimizes the image and keeps the previous zoom and panning.

 

Tie Points section: Displays in a table information about the Manual Tie Points and GCPs that are marked on the selected image. The table allows to edit the
information about the Tie Points by double clicking on the corresponding cell. For detailed information: 202557919.

Apply: When clicking on this button, the new marks or changes for the displayed Manual Tie Points and GCPs are added to the project.

 

Images section

When double clicking on a cross in the Image preview (Automatic / Manual Tie Point or GCP), the Images section displays the images where the point can be
found (including the currently selected image). For more information: 202558459.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The GCP or Manual Tie Point information is displayed when selecting a given 2D GCP, 3D GCP, Check point or Manual Tie Point in the 3D View or in
the Layers section of the left sidebar.

 

 The following information is displayed:

Label: The name of the point.
Type: The type of the point (3D GCP, 2D GCP, Check point, Manual Tie Point).
First Coordinate: 
Latitude [degree]: If the coordinate system of the GCPs is a geographic coordinate system.
X [m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.
X [feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.
Arbitrary X [m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.
Arbitrary X [feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.
Second Coordinate: 
Longitude [degree]: If the coordinate system of the GCPs is a geographic coordinate system.
Y [m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.
Y [feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.

 



Arbitrary Y [m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.
Arbitrary Y [feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.
Third coordinate:
Altitude [m]: If the coordinate system of the GCPs is a geographic coordinate system.
Z [m]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in meters.
Z [feet]: If the coordinate system of the GCPs is a projected coordinate system. The unit is given in feet.
Arbitrary Z [m]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in meters.
Arbitrary Z [feet]: If the coordinate system of the GCPs is defined by the user (local coordinate system). The unit is given in feet.
Horizontal Accuracy [units]: The horizontal accuracy defined for the 2D and 3D GCPs. For more information: 202557919.
Vertical Accuracy [units]: The vertical accuracy defined for the 3D GCPs. For more information: 202557919.
Marks in images: The number images on which the point is marked. 
Sο2 [pixel]: A posteriori variance component of all the marked points for a given 3D point. For more information: 202559199.
Theoretical Error S(X,Y,Z) [units]: Theoretical error estimation. For more information: 202559139.
Maximal Orthogonal Ray Distance D (x,y,z)[units]: Maximal distance from the estimated 3D point and all the rays used to compute that 3D point. The distance is
measured between the 3D point and the point defined by the line perpendicular to the ray passing through the 3D point. For more information: 202559179.
Error to GCP Initial Position [units]: Error in X, Y, Z between the original 3D position and the estimated 3D position. This information does not appear for Manual
Tie Points. 
Initial Position [units]: The initial X, Y, Z position of the 3D GCP, Manual Tie Point or Check point. The initial X, Y position of the 2D GCP.
Computed Position [units]: The computed X, Y, Z position of the 3D GCP, Manual Tie Point or Check point. The computed X, Y position of the 2D GCP.

Below the table there are four buttons:

Automatic Marking: Allows the user to automatically mark the 3D point in the images that have not been marked. This button is activated when the 3D point has
been marked in at least two images.
Apply: This button is active when the image marks have been modified, i.e. when a new image has been marked or when an existing mark has been updated or
removed. When clicking this button, the new marks are taken into account and the 3D position of the corresponding point is recomputed. This button is also
active when a change is done in the information regarding the point. 
Cancel: Does not save the changes made to the marks of the point in the images or the information of the point. 
Help: Opens the Pix4Dmapper help. 

The Images section: Displays the selected image and the other images where the point can be found. For more information: 202558459.

Important: The zoom level at which GCPs / Manual Tie Points are marked has an impact on the GCP / Manual Tie Point error obtained in the Quality
Report. Usually, the higher the zoom level, the more precisely the GCP / Manual Tie Point is marked. These GCPs / Manual Tie Points will have a
bigger impact on the reconstructed model than GCPs / Manual Tie Points marked on a lower zoom level; lower error values are also expected for these
GCPs / Manual Tie Points. For example, when GCPs / Manual Tie Points are marked without zooming into the images, the GCP / Manual Tie Point error
can be 10 times higher than when the GCPs / Manual Tie Points are marked by zooming into the images.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Automatic Tie Points information is displayed when an Automatic Tie Point is selected in the 3D View.

 

 The following information is displayed:

Automatic Tie Point name (Automatic Tie Point): A unique name that identifies the Automatic Tie Point: ATP [number], where number is unique.
Number of Images Marked On: Number of calibrated images on which the point has been automatically marked (identified as the same 2D keypoint).
Number of Images Visible In: Number of calibrated images on which the 3D automatic tie point has been reprojected (number of calibrated images where the
computed 3D point is visible).
Sο2[pixel]: A posteriori variance component of all the marked points for a given 3D point. For more information: 202559199.
Theoretical Error S(X,Y,Z)[units]: Theoretical error estimation. For more information: 202559139.
Maximal Orthogonal Ray Distance D(X,Y,Z)[units]: Maximal distance from the estimated 3D point and all the rays used to compute that 3D point. The distance is
measured between the 3D point and the point defined by the line perpendicular to the ray passing through the 3D point. For more information: 202559179.
Computed Position [units]: X, Y, Z position of the selected point.

Below this information there is one button:

Help: Opens the Pix4Dmapper help.

 

The Images section: Displays the images where the point is marked on and visible in. For more information: 202558459.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Processing Area information is displayed when the Processing Area is selected in the 3D View.

Warning:
It is recommended to include areas covered by images in the Processing Area, so as to exclude areas of low overlap that can affect the results.  
The Processing Area affects only the visualization of the Automatic Tie Points in the 3D View of the rayCloud. It does not affect the results of step 1.
Initial Processing.
When the Processing Area is defined before step 2. Point Cloud and Mesh is processed, it affects the Point Cloud visualized in the 3D View of the
rayCloud, the Volumes View and the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index. 
When the Processing Area is defined after step 2. Point Cloud and Mesh is completed, it only affects the Point Cloud visualized in the 3D View of the
rayCloud, the Volumes View but not the results saved on disk. This Processing Area will also affect the results of step 3. DSM, Orthomosaic and Index. 
When exporting the Point Cloud, it is possible to take into account the Processing Area, even if it is drawn after step 2 is processed. For more
information about how to export the Point Cloud: 203890769.
When the Processing Area is defined before step 3. DSM, Orthomosaic and Index is completed, only the results of step 3 will be affected. 

Warning:  
In order to take the Processing Area into account for the visualization of the Point Cloud and / or the generation of the outputs of step 2. Point Cloud and
Mesh, the corresponding filter should be selected in the Processing Options. For more information: 204644369.

The Processing Area will be taken into account for the results of step 3. DSM, Orthomosaic and Index even if the Processing Areas box is not selected
in the Point Cloud Filters. 

Note: For step by step instructions about how to select a Processing Area: 202560179.

 

The section Selection displays the following information:

Maximum Altitude [units]: Altitude of the top plane of the Processing Area.
Minimum Altitude [units]: Altitude of the bottom plane of the Processing Area.
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Important: Maximum Altitude should be higher than Minimum Altitude.

Note: The Maximum Altitude and Minimum Altitude can be edited by:
Selecting the text box and:
Clicking Page Up/Page Down keys: Increase/Decrease the value by 10 units.
Clicking Up Arrow/Down Arrow keys: Increase/Decrease the value by 1 unit.
Clicking Up Arrow/Down Arrow text box buttons: Increase/Decrease the value by 1 unit.
Typing a new number in the text box.

Below that information there are 2 buttons, grayed out by default, enabled once the values for Minimum or Maximum Altitude are modified.

Apply: Saves the new values for the Minimum/Maximum Altitude and applies the new filters.
Cancel: Does not save the new values for the Minimum/Maximum Altitude.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The Point Clouds information is displayed when a point of a point cloud is selected in the 3D View.

 

 The following information is displayed: 

Number of Images Visible In: Number of calibrated images on which the selected point has been reprojected (number of calibrated images where the computed
3D point is visible).
Computed Position [units]: X, Y, Z position of the selected point in the 3D View.

Below this information there is one button:

Help: Opens the Pix4Dmapper help.

 

The Images section: Displays the selected image and the other images where the point can be found. For more information: 202558459.
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Access: On the Menu bar, click View > rayCloud to open the rayCloud. The right sidebar is displayed on the right of the main window.
The object information is displayed when an object is selected in the 3D View, or when an object is selected in the Layers section of the left sidebar.

There are 7 type of objects:

Polylines
Surfaces
Animation Trajectories
Orthoplanes
Scale Constraints
Orientation Constraints

Note: A Manual Tie Point is associated to each vertex of the objects. The Sidebar allows the user to mark these Manual Tie Points on the images. Each
vertex that is marked in a least 2 images is taken into account in step 1. Initial Processing if it is started from scratch or if the reconstruction is re-
optimized.

Polylines

The following information is displayed:

Object name (object type): The name of the Polyline and its type (Polyline).
Number of Vertices: Number of vertices used to draw the Polyline.
Measurements
Terrain 3D length [units]: 3D length of the Polyline, taking into account the three coordinates of the vertices. For more information: 202559819.
Projected 2D length [units]: 2D length of the Polyline, taking into account the (X,Y) coordinates of the vertices. For more information: 202559839.

Note: When the polyline is created, next to the measurements, "error n/a " appears indicating that the measurement accuracy cannot be

calculated till all the vertices of the polyline are marked on at least 2 images. For step by step instructions: 202560609.

The buttons:

Copy to Clipboard: Copy the selected information to the clipboard that can be pasted into a text editor or spreadsheet by opening the destination file and pasting.
Apply: This button is active when the image marks for the Manual Tie Points associated to the Polyline vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. When clicking this button, the new marks are taken into account and the 3D position of the
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corresponding vertices is recomputed.
Cancel: This button is active when the image marks for the Manual Tie Points associated to the polyline vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. It cancels the modifications of the image marks.
Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Polyline: 202560309.

Surfaces

The following information is displayed:

Object name (object type): The name of the Surface and its type (Surface).
Number of Vertices: Number of vertices used to draw the object.
Measurements
Terrain 3D Length [units]: 3D length of the line that has been used to draw the Surface taking into account the three coordinates of the vertices. For more
information: 202559819.
Projected 2D Length [units]: 2D length of the line that has been used to draw the Surface taking into account the (X,Y) coordinates of the vertices. For more
information: 202559839.
Enclosed 3D Area [units2]: 3D area that is enclosed by this surface, taking into account the three coordinates of the vertices.
Projected 2D Area [units2]: 2D area that is enclosed by this surface, taking into account the (X,Y) coordinates of the vertices.

Note: When the surface is created, next to the measurements, "error n/a " appears indicating that the measurement accuracy cannot be

calculated till all the vertices of the surface are marked on at least 2 images. For step by step instructions: 202560609.
 

Used for DSM and triangle Mesh: When this box is selected, the surface is used to improve the DSM model and the 3D textured Mesh. For more
information: 211083803.

Automatic: Selected by default. It uses the normals of the points covered by the surface to estimate the normal of the plane. If the checkbox is not selected, the
sequence in which the surface vertices are drawn is used to define the normal of the plane. In this case, the surface should be drawn counterclockwise. 

And the buttons:

Copy to Clipboard: Copy the selected information to the clipboard that can be pasted into a text editor or spreadsheet by opening the destination file and pasting.
Apply: This button is active when the image marks for the Manual Tie Points associated to the surface vertices have been modified, i.e. when a new image has
been marked or when an existing mark has been updated or removed. When clicking on this button, the new marks are taken into account and the 3D position of
the corresponding vertices is recomputed.
Cancel: This button is active when the image marks for the Manual Tie Points associated to the surface vertices have been modified, i.e. when a new image has
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been marked or when an existing mark has been updated or removed. It cancels the modifications of the image marks.
Help: Opens the Pix4Dmapper help.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Surface: 202560269.

 

Animation Trajectories

Under Selection in the main frame the name of the Animation trajectory and 4 sections appear:

Waypoints
Video Animation Options
Playback Controls
Video Rendering

And the button:

Help: Opens the Pix4Dmapper help.

 

Waypoints

The following actions can be performed on the table:

Inserting Waypoints: Right click on any cell and click on one of the followings:
Insert Current Viewpoint as Waypoint Before Selection: Inserts the actual viewpoint in the 3D View as waypoint before the selected row (selected waypoint).
Insert Current Viewpoint as Waypoint After Selection: Inserts the actual viewpoint in the 3D View as waypoint after the selected row (selected waypoint).
Insert Displayed Computed Cameras Position as Waypoint Before Selection: Inserts ALL the cameras that are actually visible in the 3D View as waypoints before
the selected row (selected waypoint) by placing them (if more than one camera is inserted, the order is defined considering the exif information from the cameras).
Deleting Waypoints: Right click on any cell, and click on Remove Selected Waypoints.
Editing Values: Double click on the cell and edit the value. Timestamp cannot be edited manually, the values can be changed by changing the Duration,
 Maximum Speed or selecting/unselecting the Use Interpolation checkbox.

The table has as many rows as there are waypoints in the Animation Trajectory. Each row displays information for one waypoint.

Label: Name of the waypoint.

https://support.pix4d.com/hc/en-us/articles/202558459
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Timestamp [s]. Time at which the animation passes through the waypoint.
X coordinate [units]
Y coordinate [units]
Z coordinate [units]
Omega (Rotation in X Axis) [degrees]
Phi (Rotation in Y Axis) [degrees]
Kappa (Rotation in Z Axis) [degrees]

Video Animation Options

This section allows the user to change the time of the animation and use or not use interpolation between waypoints:

Duration [s]: Total length in seconds for the animation.
Maximum Speed [m/s]: Maximum speed of the movement of the fly-trough camera in meters/second. The speed is not constant since the software recognizes
changes in direction and orientation and reduces the speed in that sectors to allow smother camera movements.
Use Interpolation: Ensures a smooth transitions between waypoints.

Note: 
If the Use Interpolation  checkbox is NOT selected, the path between waypoints will be straight lines. 
If the Use Interpolation checkbox is selected, the path between waypoints will be curved lines. The angle of the curve is related to the angle
between consecutive lines.

This section contains 2 action buttons:

Apply: Saves the changes done in the sections Waypoints or Video Animation Options.
Cancel: Reverts the changes to restore the saved Animation Trajectory.

 

Playback Controls

This sections allows to display the animation in the 3D View.

 Play animation

 Stop animation

 

Video Rendering

This sections allows to create a video file and set up different video rendering properties:

File Name: Displays the path and the name where the video will be rendered and saved.
Format: Video file format. The available options are: MPEG4 and MPEG2.
Frame Rate: Frames per second to be stored in the video. The available options are:  24, 30 and 60 fps.
Resolution: Total width and height of the video in pixels. The available options are:  800x600, 1024x768, 1280x720 and 1920x1080.
Encoding Quality: Defines the pixel size within the video, the higher the encoding quality the higher definition
Show Visible Area: Displays / does not display in the 3D View a frame allowing to see which part of the 3D View fits in the scene to be recorded according to the
resolution. Elements outside the visible area do not appear in the recorded video
Pix4Dmapper Logo: When rendering and creating the video, it displays/ does not display the Pix4Dmapper logo in the bottom right of the video.

This section contains 4 action buttons:

Browse... : Opens the Save Video As window which allows to choose the video's folder.
Render: Converts the animation Trajectory into a video, saved in the selected path and using the video properties selected.
Cancel: Enabled while Rendering is in progress, allows to cancel the rendering of an Animation Trajectory into Video.
Help: Opens the Pix4Dmapper help.

For step by step instructions about how to create an Animation Trajectory: 202560299.

 

Orthoplanes

 

https://support.pix4d.com/hc/en-us/articles/202560299


Under Selection in the main frame appears 3 sections:

Object name (object type): The name of the Orthoplane and its type (Orthoplane).
Position X [units]: Position in X of the reference corner with respect to the origin of the output coordinate system.
Y [units]: Position in Y of the reference corner with respect to the origin of the output coordinate system.
Z [units]: Position in Z of the reference corner with respect to the origin of the output coordinate system.
Width [units]: Size in X of the orthoplane area in output coordinate system units.
Height [units]: Size in Y of the orthoplane area in output coordinate system units.
Clipping Distance [units]: Size in Z of the orthoplane area in output coordinate system units.
Orientation: Defines the rotation of the orthoplane area with respect to the axes of the coordinate system.
Yaw [degrees]: Rotation around the Y axis. 
Pitch [degrees]: Rotation around the X axis.
Roll [degrees]: Rotation around the Z axis.
Flip: Changes the orientation and direction of the projection.
Alignment tool (optional): Allows the user to align the orthoplane with a Surface Object.
Surface1: Allows the user to select the surface object to use for alignment.
Align: Aligns the Orthoplane to the selected surface by using the perpendicular vector to the surface as direction of the projection and using the base of the
surface as middle point of the Z of the Orthoplane.
Orthomosaic Generation Options: Options related to the output files.
Resolution [cm/pixel]: This value can be modified before generating the new Orthoplane mosaic and indicates the spatial resolution of the Orthomosaic.
Generate DSM: When the checkbox is selected, a DSM file is generated with the Orthoplane Mosaic. Processing options are optimized for facades (sharp
Surface Smoothing and Noise Filtering for the DSM filters, Raster DSM method set to Inverse Distance Weighting).
File Name: Path where the Orthoplane and optionally the DSM will be stored.
...: Selects the path where the Orthoplane and optionally the DSM will be stored.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object. It applies the changes.
Cancel: Cancels the changes in the properties since the last time that apply has been clicked.
Generate: Generates the Orthomosaic and optionally the DSM for the selected orthoplane in the selected path.
Help: Opens the Pix4Dmapper help.



The Instructions section displays instructions about how to draw a new Orthoplane.

For step by step instructions about how to draw a new Orthoplane: 204664359.

 

Scale Constraints

Contains 3 sections:

Selection
Instructions
Images

Under Selection in the main frame appears:

Object name (object type): The name of the Scale and its type (Scale Constraint).
GCP/MTP Labels: When creating a Scale Constraint, the vertices of the line representing the scale constraint are associated to Manual Tie Points. This label
displays the names of the Manual Tie Points associated to the object.
Computed Length [units]: Length measured in the 3D model. The  Computed Length Error is given by the difference between the Computed Length and the Initial
Length.
Initial Length [units]: Length measured in the field representing the real length of the scale constraint. The accuracy of the Initial Length is the accuracy of the
measurements in the field.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object or a new marking in the images. It applies the changes.
Cancel: Cancel the changes in the properties or in the marking since the last time that apply has been clicked.
Help: Opens the Pix4Dmapper help.

The Instructions section: Displays instructions about how to draw a new Scale Constraint.

The Images section: Displays the images in which the object is visible. For more information: 202558459.

For step by step instructions about how to draw a new Scale Constraint: 205360375.
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Orientation Constaints

Contains 3 sections:

Selection
Instructions
Images

Under Selection in the main frame appears:

Object name (object type): The name of the Orientation and its type (Orientation Constraint).
GCP/MTP Labels: When creating an Orientation Constraint, the vertices of the arrow representing the scale constraint are associated to Manual Tie Points. This
label displays the names of the Manual Tie Points associated to the object.
Computed Angular Error [degree]: Angular difference between the computed axis and the axis that was drawn.
Axis: Name of the axis that the Orientation Constraint represents.
Flip: Changes the direction of the Orientation by rotating it by 180°.
Angular Accuracy [degree]: Angular accuracy of the measurements in the field.

And the buttons:

Apply: Enabled when there has been any change in the properties of the object or a new marking in the images has been done. It applies the changes.
Cancel: Cancels the changes in the properties or in the marking since the last time that apply has been clicked.
Help: Opens the Pix4Dmapper help.

The Instructions section: Displays instructions to draw a new Orientation Constraint.

The Images section: Displays the images where the object can be found. For more information: 202558459.

For step by step instructions about how to draw a new Orientation Constraint: 205360385.

 

Index > Interface > Menu View > rayCloud > Right sidebar  Previous  |  Next  

https://support.pix4d.com/hc/en-us/articles/202558459
https://support.pix4d.com/hc/en-us/articles/205360385


Index > Interface > Menu View  Previous  |  Next  

 

Access: On the Menu bar, click View > Volumes.

 

The use of Volumes is optional and it can be used to:

Draw and visualize volumes.
Measure volumes.
Import and Export volumes.

When selecting the Volumes view the following elements are displayed on the main window:

Menu bar entry: The standard Menu bar items and an extra item.
Toolbar: The standard toolbar and some extra buttons specific to the rayCloud and the Volumes view.
3D View: Displayed in the main window. It is a simplified version of the rayCloud 3D View. Displays in 3D the different elements. 
Sidebar: Displayed on the left of the Volumes view.
Status bar: Displayed on the bottom right of the Volumes view. Displays the coordinates when passing the mouse over any element displayed in the 3D View.

 

 Status bar

On the bottom right part of the 3D View, the following is displayed:

Selected Coordinate System: Displays the selected coordinate system of the point.
Position: Displays the (X,Y, Z) coordinates in meters / feet of each point of the 3D View when passing the mouse over any element. When passing the mouse
over the displayed elements, the coordinates change.

 



Important: In the Volumes, the coordinate system is the output coordinate system.

By default the output coordinate system is the same as the GCPs coordinate system, if GCPs are used, otherwise it is the same as the image
geolocation coordinate system. If the coordinates system is WGS84, the output is given in UTM. If less than 3 images are geolocated and less than 3
GCPs are defined, then the output coordinates system is set to "Arbitrary".
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Access: On the Menu bar, click View > Volumes to open the Volumes view. The 3D View is displayed in the center of the main window.

The 3D Volumes view is a simplified version of the rayCloud view to facilitate the volume measurements. The different layers that are displayed in the 3D View
(also visible in the rayCloud) are:

Point Clouds: This layer contains the Densified Point Cloud generated during step 2. Point Cloud and Mesh and the drag-and-dropped external point clouds. It is
the background for drawing the volumes. 
Triangle Meshes: This layer groups the 3D Textured Mesh and triangle meshes generated by triangulating a point cloud that is loaded as a triangle mesh.
Volumes: This layer contains the volumes defined by the user. 
Clipping Box: This tool allows to visualize only the points included in the Clipping Box. This tool is not visible in the Layers section of the sidebar.

 

Important: It is possible to change the Points Density by Press "Alt" + "+" or "AltGr" + "- " in order to increase or decrease the density, "Alt" + "0" reset
the Points Density to default values.

Important: The navigation in the 3D Volumes View (how the 3D view reacts when using the mouse or keyboard) depends on the Navigation Mode
selected. For more information and full description of all the possible actions to navigate in the 3D View using the mouse or keyboard: 205360675.

Important: Several predefined viewpoints exist such as top view, front view, etc. These predefined viewpoints are accessible using the keyboard and are
using the Menu bar Volumes > Viewpoint. For more information about the available viewpoints: 202558069.  

Point Clouds

The Display Properties selected in the rayCloud are inherited to the Volumes. The Display Properties of the Point Cloud can be selected in the rayCloud or in the
Layers section of the sidebar of the Volumes view. For more information about the Display Properties: 202558049.

Triangle Meshes

The Triangle Meshes are not displayed by default. The Display Properties selected in the rayCloud are inherited to the Volumes. The Display Properties of the
Triangle Meshes can be selected in the rayCloud or in the Layers section of the sidebar of the Volumes view. For more information about the Display
Properties: 202558079.

Volumes

By default, the volumes defined in the Volumes view appear in the 3D View as:

Green sphere: Volume vertices.
Green surface: Base surface the volumes.
Green lines: Lines between vertices/waypoints of the same volume. 
Red Terrain: Triangles between the base surface and the terrain defined by the DSM.
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Access: On the Menu bar, click View > Volumes, and then click Volumes.

 

The following options are displayed:

Viewpoint
Navigation Modes
Perspective/Orthographic
Change Background...
Display Sky
New Volume

 

New Volume 

A Volume is an object that can be used for volume calculations. It is defined by a 3D Surface called base surface. The volume is computed between the base
surface and the terrain surface, defined by the DSM.

For step by step instructions about how to draw a new volume: 202560319.

Once a New Volume is created, the Sidebar displays the following information: 208652926.
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Access: On the Menu bar, click View > Volumes to open the Volumes view. The sidebar is displayed on the left of the main window. The Volumes view
is available when the point cloud and the DSM are generated.

The sidebar consists of the sections:

Objects: This section allows to draw, import and export volumes and obtain the measures of the drawn volumes. 
Layers: This section groups all the objects that can be displayed on the 3D View. 

The sidebar can be shown / hidden by dragging and dropping the left side border of the 3D View.
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Access: On the Menu bar, click View > Volumes to open the Volumes view. The sidebar is displayed on the left of the main window. The Volumes view
is available when the point cloud and the DSM are generated.

The Objects section consists of two parts:

The action buttons
The volume list

Action buttons 
There are 3 action buttons: 

 New volume: Allows the user to draw a new volume. For step by step instructions: 202560319.

 Import volume: Opens the Import Volume pop-up that allows to import volumes created previously with Pix4Dmapper or created manually for the same area

of study. For step by step instructions: 204836569.

Important: 
To import a volume created previously with Pix4Dmapper, it has to be a .shp file that contains surfaces (name_surfaces.shp) or vertices
(name_vertices.shp).
To import a volume created with an external software, it has to be a .shp file that contains a 3D polygon (surface) or 3D vertices.

 

 

https://support.pix4d.com/hc/en-us/articles/202560319
https://support.pix4d.com/hc/en-us/articles/204836569


It contains the sections:

Navigation window: Used to search and select the file to be imported.
File name: Displays the name of the selected file to be imported.
Files of type:  Displays the possible formats accepted for the input file: Shape files (.shp) are accepted.

And the action buttons:

Open: Imports the selected file.
Cancel: Does not import the Volume and exits the pop-up.

 

 Export volume: Allows the user to select and export the volumes the following buttons appear:

Select: Allows the user to select All or None of the volumes to be exported. The user can also select some of the Volumes to be exported by selecting the box
that appears next to the names of the volumes.

Important: At least one volume needs to be selected to be exported.

Cancel: Cancels the export of volumes.
Export: Opens the Export pop-up:

It contains the sections:
Navigation window: Used to search and select the directory in which the volume will be exported.
File name: Allows the user to select the name of the file to be exported.
Save as type:  Displays the possible formats accepted for the input file: 
AutoCad DFX (.dfx).
ESRI Shapefiles (.shp).
Keyhole Markup Language (.kml).
Microstation DGN (.dgn).

 

Volume list
It contains the list of volumes added to the project and the measures for each volume.

Important: The volume is computed between the volume's base and the surface defined by the DSM generated in step 3. DSM, Orthomosaic and Index.

The volume information is displayed by clicking the volume name in the Objects layer of the sidebar. 

Important: The volume information is displayed once the volume is computed. If the volume is not computed, the Compute button will appear. Clicking
the Compute button will compute the volume. 

The following information is displayed:

Volume name: The name of the volume.
Terrain 3D Area [units2]: Area that is defined by the DSM included in the volume's base.
Cut Volume [units3]: Volume that is above the volume base. The volume is measured between the volume's base and the surface defined by the DSM.
Fill Volume [units3]: Volume that is below the volume base. The volume is measured between the volume base and the surface defined by the DSM.
Total Volume [units3]: Total volume, Total Volume = Cut volume + Fill volume.

 

 

 



Tip: For more information on the error estimation (+/-) in volume calculation: 217114246.

 

When hovering over one volume, 2 action buttons appear: 

 View/Hide: Allows to view or hide the volume from the 3D view.

 Delete: Allows the user to delete the volume. 

When selecting a volume, 3 action buttons appear: 

 Compute: Computes the volume selected. Appears when the volume is not computed, when there is a change in the name or in the base surface of the

volume or the DSM.  
 Copy to Clipboard: Copies the measures of the selected volume to the clipboard that can be pasted into a text editor or spreadsheet by opening the

destination file and pasting.
 Settings: Allows the user to select the base surface settings and the display settings of the volumes. The Volume Settings pop-up appears. 

It consists of two tabs:

Base surface Settings: Allows to select the base plane for the volume calculation. There are six different options:  
Triangulated: Selected by default. Connects all the vertices and triangulates the volume above and below the base surface. Recommended option when the entire
boundary of the stockpile is visible and the surface is relatively flat.
Fit Plane: Fits a plane to the vertices, so that all vertices are at the minimum distance from the base surface. Recommended option when the entire boundary of
the stockpile is visible and the base surface is a hard surface, a slop or flat with the same altitude. 
Align with Average Altitude: The base surface is parallel to the XY plane with altitude at the average altitude of all vertices. 
Align with Lowest Point: The base surface is parallel to the XY plane with altitude at the lowest altitude of all vertices. Recommended option when part of he
boundary is not visible, for example the stockpile is partially surrounded by walls. 
Align with Highest Point: The base surface is parallel to the XY plane with altitude at the highest altitude of all vertices. Recommended option when the desired
computation is the fill volume of a bunker, a pool, a pond, etc. 
Custom Altitude [units]: The base surface is parallel to the XY plane with altitude at a custom altitude. Recommended option when the stockpile is surrounded by
walls and only part or even no boundary is visible, but the altitude of the flat base surface is known. 

Tip: For more information and specific cases about how to choose the base surface settings: 217114246.

Display: Allows to edit the display properties for one or all the volumes.
Vertex Color: Color of the spheres that represent the vertices of the bases of the volumes.
Vertex Radius: Radius of the spheres that represent the vertices of the bases of the volumes.
Line Color: Color of the lines between the vertices of the bases of the volumes.
Line Width: Width of the lines defining the bases of the volumes.
Base: View/hide the bases of the volumes.
Color: Color of the bases of the volumes.
Shader: Specifies the way each triangle of the bases of the volumes is colored. The color is related to the 3D position of each triangle. There are 2 ways of
coloring the triangles available:
Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.
Color: The triangles are colored with an RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.
Terrain: View/hide the triangles defining the terrain. These triangles are generated using the base of the volume and the DSM and below that surface.
Color: Color of the triangles defining the terrain. These triangles are generated using the base surface and the points above and below that surface (this property
only affects Volume objects).
Shader: Specifies the way each triangle defining the terrain is colored. The color is related to the 3D position of each triangle. 2 ways of coloring the triangles are
available:
Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.
Color: The triangles are colored with a RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202559219
https://support.pix4d.com/hc/en-us/articles/217114246
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Access: On the Menu bar, click View > Volumes to open the Volumes view. The Layers section is displayed on the left of the main window. The
Volumes view is available when the point cloud and the DSM are generated.

A layer is a group of objects that can be displayed on the 3D View. The Layers section of the left sidebar contains the following layers:

Objects: Contains all the volumes drawn in the Volumes view. 
Densified Point Cloud: Contains the densified point cloud generated during step 2. 
External Point Clouds: Contains the external point clouds loaded. 
Point Groups: Contains the different groups of points (each point of the densified point cloud is assigned to one group).
Triangle Meshes: Contains Triangle Meshes (generated in Pix4Dmapper or imported).
Processing Area: Contains the Processing Area.

 

Characteristics:

By clicking on the left arrow of a layer, the sub-layers and layer properties are shown or hidden.
By clicking on the a layer's check box, the corresponding layer is shown or hidden in the 3D View.
The different layer properties can be edited.
Some layers have a context menu that can be accessed by right clicking on the corresponding layer.

Objects

The Objects layer contains the Volumes sublayer, which contains the list of volumes added to the project. 

The volumes layer has the following structure:

Contains the list of volumes added to the project. It can be used for volume calculation. It is defined by a 3D surface called a base. The volume is computed
between the base and the terrain surface.

The Volumes layer has the following structure:

Display Properties: This layer allows the user to edit the display properties for all the volumes.
Vertex Color: Color of the spheres that represent the vertices of the bases of the volumes.
Vertex Radius: Radius of the spheres that represent the vertices of the bases of the volumes.
Line Color: Color of the lines between the vertices of the bases of the volumes.
Line Width: Width of the lines defining the bases of the volumes.
Base: View/hide the basex of the volumes.
Color: Color of the bases of the volumes.
Shader: Specifies the way each triangle of the bases of the volumes is colored. The color is related to the 3D position of each triangle. There are 2 ways of
coloring the triangles available:
Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.
Color: The triangles are colored with an RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.
Terrain: View/hide the triangles defining the terrain. These triangles are generated using the base of the volume and the points above and below that surface.
Color: Color of the triangles defining the terrain. These triangles are generated using the base surface and the points above and below that surface (this property
only affects Volume objects).
Shader: Specifies the way each triangle defining the terrain is colored. The color is related to the 3D position of each triangle. 2 ways of coloring the triangles are
available:
Monochrome: Selected by default. The triangles are colored with a color-to-black scale depending on the angle with respect to a virtual sun positioned in the
north-east at 45 degrees from the horizon. It uses the color selected above.
Color: The triangles are colored with a RGB scale. The color of a triangle depends on the angle with respect to 3 virtual suns with Red, Green, and
Blue illumination. The color of each triangle is the combination of the light received by the 3 virtual suns. This shader gives a slope map if the model is looked at
from top. It gives information about the orientation of each surface.
List of Volumes: Each object has the following sub-element:

 



Display Properties: This layer allows the user to edit the Display Properties of a Volume. The properties that can be edited are the same as the Display
Properties of the Volumes listed above.

By right clicking on the Volumes sub-layer, a context menu with the following options appears:

New Volume: Allows the user to draw a new volume. For step by step instructions: 202560319.
Import Volume: Opens the Import Volume pop-up that allows the user to import Volumes created previously with Pix4Dmapper for the same area of study or
created manually.

Important: 
To import a volume created previously with Pix4Dmapper, it has to be a .shp file that contains surfaces (name_surfaces.shp) or vertices
(name_vertices.shp).
To import a volume created with an external software, it has to be a .shp file that contains a 3D polygon (surface) or 3D vertices.

Contains the sections:

Navigation window: Used to search for and select the file to be imported.
File name: Displays the name of the selected file to be imported.
Files of type:  Displays the possible formats accepted for the input file: Shape files (.shp) are accepted.

And the action buttons:

Open: Imports the selected file.
Cancel: Does not import the Volume and exits the pop-up.
Help: Opens the Pix4Dmapper help.

Export All Volumes: Opens the Export pop-up that allows the user to export the corresponding components from the volume into a file.

Important: A Volume is composed of volume meshes, lines, and vertices to which Manual Tie Points are associated.

The following file formats can be selected for export:
AutoCad DFX (.dfx).
ESRI Shapefiles (.shp).
Keyhole Markup Language (.kml).
Microstation DGN (.dgn).

The type of components to export can be selected. The following components can be exported:

Export Vertices: Exports the vertices of the Volumes.
Export Surfaces: Exports the surface meshes of the Volumes.
Export Meshes: Exports the volume meshes of the Volumes.

Important: The options Export All Volumes is enabled only if at least one Volume has been drawn.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202560319
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Access: On the Menu bar, click View > Mosaic Editor (available only if step 3. DSM, Orthomosaic and Index has been completed).

 

 

Warning: 
The Mosaic Editor may be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improve its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten. The Grid DSM as well as the different orthomosaic formats (GeoTIFF, Google Maps Tiles, etc.) will be generated if
selected in the processing options.
For more information about the Mosaic Editor processes workflow: 204829349.

For step by step instructions about how to improve the visual aspect of the orthomosaic: 202559939 (for buildings), 202559959 (for bridges).

The use of the Mosaic Editor is optional and it can be used to:

Visualize the DSM (raster GeoTIFF Digital Surface Model).
Visualize the DTM (raster GeoTIFF Digital Terrain Model).
Visualize the Mosaic.
Improve the visual aspect of the orthomosaic.

When selecting the Mosaic Editor view the following elements are displayed on the Main window:

Menu Bar Entry: Extra entry displayed on the Menu bar.
Toolbar: The standard toolbar and some extra buttons specific to the Mosaic Editor.
Mosaic View: Displayed in the main window. By default the Orthomosaic is displayed. The Mosaic Editor can also be used to visualize the DSM (Elevation).
Sidebars: Displayed on the right of the Mosaic View. By default the Mosaic editing sidebar is displayed.
Status bar: Displayed on the bottom right of the Mosaic View. Display the coordinates when passing the mouse over the orthomosaic / DSM.

 

For step by step instructions related to the use of the Mosaic Editor: 202558709.

Video: Watch the instructional video related to the Mosaic Editor: here.

 

 

 

 

https://support.pix4d.com/hc/en-us/articles/202560079
https://support.pix4d.com/hc/en-us/articles/204829349
https://support.pix4d.com/hc/en-us/articles/202559939
https://support.pix4d.com/hc/en-us/articles/202559959
https://support.pix4d.com/hc/en-us/articles/202558709
https://www.youtube.com/watch?v=KUYSy1cIy7s


Figure 1. Mosaic Editor with DSM view



 

Figure 2. Mosaic Editor with DTM view

 



Figure 3. Mosaic Editor with Orthomosaic view

 

Menu bar entry

On the Menu bar, by clicking Mosaic Editor the following options are displayed:

 

View: Shows the view options of the Mosaic View.
Mosaic Editing: Opens the Mosaic Editing sidebar.
Visualization: Opens the Visualization sidebar.

 

Toolbar

The following Toolbar buttons are displayed:

Standard Toolbar: For more information: 202557839.
Toolbar extra buttons:
View

 Zoom In: Zooms in the selected view.



 Zoom Out: Zooms out the selected view.

 View All: Moves the viewpoint in order to fit the model in the Mosaic View.

Edit Mosaic

Element to be displayed in the Mosaic View, by default the Mosaic [group1] is displayed. If there are more than one groups of images, one Mosaic is generated
per group of images. It is possible to display the different generated mosaics as well as the DSM and the DTM.

 

Mosaic View

By default the Mosaic view is selected and the mosaic is displayed. If the DSM view is selected, the DSM is displayed. If the DTM view is selected, the DTM is
displayed.

When passing the mouse over the orthomosaic / DSM / DTM, the Mosaic Status bar displays the coordinates of the hovered point. 

The following mouse interactions are available:

Left click on the mosaic and move the mouse: Pan the mosaic.
Left click on a Region vertex while moving the mouse: Allows to move the vertex of the region.
Moving the mouse scroll forwards: Zoom in on the mosaic.
Moving the mouse scroll backwards: Zoom out of the mosaic.

 

Sidebars

There are two sidebars:

Mosaic editing sidebar : Allows the user to edit the mosaic.
Visualization sidebar: Allows the user to  visualize the mosaic or the DSM.

 

Status bar

On the bottom right part of the Mosaic View, the following is displayed:

Selected Coordinate System: Displays the selected coordinate system of the point.
Position: Displays the (X,Y) coordinates in meters / feet of each point of the orthomosaic / DSM / DTM. When passing the mouse over the orthomosaic / DSM /
DTM the coordinates change.

Important: The geographic (ellipsoid) projection coordinates are used in meters / feet, instead of geographic (ellipsoid) coordinates in degrees,
considering the output coordinate system selected.

By default the output coordinate system is the same as the one of the GCPs if GCPs are used. Otherwise it is the same as the one of the images. If the
coordinates system is WGS84, the output is given in UTM.

If less than 3 images are geolocated and less than 3 GCPs are defined, then the output coordinates system is "Arbitrary".

Note: The Status Bar displays the position for the whole area covered by the Orthomosaic / DSM / DTM and the area without data. When passing the
mouse over areas where there is no data, the no data altitude value -10000 is displayed.
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Access: On the Menu bar, click View > Mosaic Editor, in the Mosaic Editor, on the Menu bar click Mosaic Editor and select the menu
option View (available only if step 3. DSM, Orthomosaic and Index has been completed).

 

The View options affect the Mosaic View. The following options are available:

Show Mosaic [Group]
Show DSM
Show Region
Show Edited Mosaic
Show Processing Area
Show Mosaic Tiles

 

Show Mosaic [Group]

This option is selected by default.

It displays the mosaic generated using the images that belong to the corresponding group. The default group is group1. For more information about the image
groups: 202557949.

The mosaic can be edited by creating regions and by assigning another image to them or selecting another projection for each region. The edited mosaic will be
edited and visualized in real time. Once the editing has been completed, the mosaic needs to be exported in order to generate the new output files for the
mosaic. 

 

 

Show DSM

It displays the DSM using by default an RGB color map for the altitude values.

 



 

 

Show Region

This option is activated by default. It displays the drawn Regions.



 

Show Edited Mosaic 

This option is activated by default. It displays the edited mosaic. 

When it is not activated, the Mosaic View displays the content of the mosaic stored in file.

 

Where to activate/deactivate the Show Edited Mosaic  

 



Show Processing Area

This option is deactivated by default. It displays the Processing Area, which is the area for which the Orthomosaic is generated.

For more information about the Processing Area: 202558439.

 

 

 

Show Mosaic Tiles

This option is deactivated by default. It displays the GeoTIFF mosaic tiles that will be generated when exporting the mosaic. When the Processing Area  is
modified, the mosaic tiles are modified as well.
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Access: On the Menu bar, click View > Mosaic Editor, on the Menu bar click Mosaic Editor > Mosaic Editing (available only if step 3. DSM,
Orthomosaic and Index has been completed).

For information about the sidebar's display possibilities: 202558389.

 

The Mosaic Editing sidebar contains the following sections: 

Regions: Allows the user to select, draw or delete regions.
Images: Allows the user to select which projection and which image can be used for each region.
Export: Allows the user to:
Save locally the changes (saves changes in the Mosaic View in internal temporary files).
Reset the displayed mosaic.
Export an edited mosaic by exporting the internal temporary files.

 

Regions

Allows the user to select, draw or delete regions.

Contains the following buttons:

Region[number]: Available once one region has been drawn. Allows the user to select a region.
Draw: Allows the user to draw a region. For step by step instructions: 202560079.
Delete: Allows the user to delete the selected region.
Delete All: Allows the user to delete all the existing regions.

 

Images

This section:

Displays the different projections available for the selected region.

 

https://support.pix4d.com/hc/en-us/articles/202558389
https://support.pix4d.com/hc/en-us/articles/202560079


Note: The first projection that is displayed uses the most perpendicular image to selected region.

Displays the selected projection type and image for the selected region.
Allows the user to change the projection type and image to be used for the selected region.

It is possible to select:

Ortho Projection: displays a list of original images in ortho projection.
Planar Projection: displays a list of original images in a planar projection.

Note: 
Ortho Projection: The ortho projection preserves distances and can be used for mosaics dedicated to measurement applications.
Planar Projection: The planar projection does not preserve distances, but has fewer distortions than the ortho projection on sharp transitions such as
building edges. Therefore, it is not recommended to use planar images for mosaics dedicated to measurement applications. Its basic use is to improve
the visual aspect of the orthomosaic.

 

Export

Warning: 
The Mosaic Editor can be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improve its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten.
For more information about the Mosaic Editor processes workflow: 204829349.

Allows the user to:

Save locally the changes (saves changes in the Mosaic View in internal temporary files).
Reset the displayed mosaic.
Export an edited mosaic by exporting the internal temporary files saved.

Contains the following buttons:

Save: Saves the changes in the mosaic: Overwrites only the areas corresponding to the existing regions using the selected projections.

The saved Edited Mosaic will be loaded when opening the project again and when exporting it.

Reset: Resets the Edited Mosaic with the Generated Mosaic (which is stored in the results folder).

Note: When resetting all edits that have not been exported will get lost.

Export: The selected Edited Mosaic overwrites the Mosaic generated at step 3. DSM, Orthomosaic and Index.
Help: Opens Pix4Dmapper help.
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Access: On the Menu bar, click View > Mosaic Editor, on the Menu bar click Mosaic Editor > Mosaic Editing (available only if step 3. DSM,
Orthomosaic and Index has been completed).

For information about the sidebar's display possibilities: 202558389.

Important: This View is very useful for non standard original images (16 bits per band). It allows the user to specify which band is considered as red,
green and / or blue.

The Mosaic Editing sidebar contains the following sections: 

Band Information: Displays information for the different bands of the mosaic group / DSM / DTM.
Color Mapping: Allows the user to change the values to be considered for visualization for each pixel  and the visualization rules.
Apply: Allows the user to apply the changes. It considers the visualization parameters to be used in the Mosaic View.

 

Band Information

It displays information for the different bands of the mosaic group / DSM / DTM.

 

 

https://support.pix4d.com/hc/en-us/articles/202558389


The following information is displayed:

Name: Name of the band. 
Min: Minimum pixel value for all the pixels of the band.
Max: Maximum pixel value for all the pixels of the band.
Pixel: Data type, how many bytes are used to store the information of each band.

The band histogram section has one tab per band.

The histogram displays how many pixels in the model have a certain value for each band.

 

Color Mapping

Allows the user to change the values to be considered for visualization for each pixel  and the visualization rules.

It contains 2 sections:

RGBA

Selected by default for Mosaics.

It uses always 3 bands: The final color visualized will be the combination of the values for the 3 bands.

It is possible to select:

No color mapping: Selected by default. It takes the values from the original mosaic file.
Red band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the red band for the visualization.
Green band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the green band for the visualization.
Blue band: Grayed out unless No color mapping is not selected. It allows the user to select which band is considered as the blue band for the visualization.

 

Single Band

Selected by default for the DSM / DTM.

It is possible to use only one band. The final color visualized will consider only the values of one band.

Data band: Allows the user to select which band will be used for visualization.
Palette: Allows the user to select the palette of colors for the visualization of the values of the selected band. The different available options are:
Atlas: It uses the Atlas standard palette. Selected by default for DSM. It uses a palette using blue for low values, yellow for middle values and red for high values.



HSV: It uses the HSV standard palette.
RdYlGn: Low values are red, medium values are yellow and high values are green, used for agriculture.
Thermal: Low values are blue, high values are red. It is used for temperature measurements.
Spectral: It uses all the colors from the visual spectrum. It is used when many different values need to be distinguished.
Grays: It uses a gray scale.
Blues: It uses blue scale.
Red: It uses red scale.
Shading: Allows the user to disable / enable shading using illumination based on the values of each pixel on the model. For more information: How Hillshade
works. The different options available are:
Enabled: Selected by default, it uses shading.
Disabled: It does not use shading.
Ordering: Allows the user to invert the selected colors distribution. The different options available are:
Min to Max: Selected by default. It uses  the standard colors distribution for the selected palette.
Max to Min: It inverts the selected colors distribution for the selected palette.

 

Apply

Contains the following buttons:

Update: It applies the changes and considers the visualization parameters to be used in the Mosaic View.
Help: It opens Pix4Dmapper help.

Warning: 
The Mosaic Editor may be used to manually correct artifacts in the Orthomosaic resulting from Step 3. DSM, Orthomosaic and Index and in order to
improve its visual aspect.
The changes applied in the Mosaic Editor affect a local copy, not the mosaic resulting from Step 3. DSM, Orthomosaic and Index.
In order to obtain the edited mosaic, the mosaic needs to be exported: 202560079. The orthomosaic resulting from Step 3. DSM, Orthomosaic and
Index will then be overwritten. The Grid DSM as well as the different orthomosaic formats (GeoTIFF, Google Maps Tiles, etc.) will be generated if
selected in the processing options.
For more information about the Mosaic Editor processes workflow: 204829349.

 

Index > Interface > Menu View > Mosaic Editor  Previous  |  Next  

 

http://edndoc.esri.com/arcobjects/9.2/net/shared/geoprocessing/spatial_analyst_tools/how_hillshade_works.htm
https://support.pix4d.com/hc/en-us/articles/202560079
https://support.pix4d.com/hc/en-us/articles/204829349


Index > Interface > Menu View  Previous  |  Next  

 

Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed).

Note: 
A DSM is used to generate the Reflectance Maps.
One Reflectance Map is generated for each band of each group of images, but only one DSM is generated, regardless of the number of images' groups.
The Reflectance Maps contain the reflectance values of each pixel and are used to generate the Index Maps.
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.
If a Region is drawn, the Index Maps and Colored Index Maps will be generated only for this region.
Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.
If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.

Important: 
For more information about the files that are generated, under which action and where they are stored: 202558739.
All the outputs will be stored in: ...\project_name\4_index
For more information about the project folder structure: 202558649.

Warning: Once the Index Calculator has been used and results are generated, all the outputs from the Index Calculator will be DELETED if any of the
following steps / actions is started: step 1. Initial Processing, step 2. Point Cloud and Mesh, step 3. DSM, Orthomosaic and
Index, Reoptimize, Rematch and Optimize.

The existing results need to be backed up if they are to be kept.

The use of the Index Calculator is optional and allows to:

Generate an Index Map / Index Grid where the "color" of each pixel is computed using a formula that combines different bands of the Reflectance Map(s).
Visualize the Index Map as a Colored Index Map by applying a color mapping to it.
Export a georeferenced Colored Index Map.
Annotate the classes of the Index Map to generate an Application Map.
Export an Application Map as a shape file to be imported in tractor consoles.
Upload a Reflectance Map on MicaSense Atlas platform for processing, storage, management, presentation and analytics of multispectral data.

When selecting the Index Calculator view the following elements are displayed on the main window:

Menu bar entry: Extra entry displayed on the Menu bar.
Toolbar: The standard toolbar and some extra buttons related to the Index Calculator.
Index View: Displayed in the main window. When opening the Index Calculator for a project for the first time, it is blank. Once at least one Reflectance Map has
been generated, it displays by default the last index that was displayed before the project was closed.
Index Calculator sidebar: By default, it is displayed on the right of the Index View. Displays information about the Reflectance Map(s), the Index Map, and provides
tools to generate and edit the Index Maps.
Status bar: Displayed on the bottom right of the main window.  Displays the Index Value, the coordinate system and the coordinates when passing the mouse
over the Reflectance Map/ Index Map.

 

For step by step instructions about how to use the Index Calculator: 202558729.
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 Figure 1. Index Calculator

Menu bar entry

On the Menu bar, by clicking on Index Calculator the following option is displayed:

 

Show Color Scale: By default it is selected. View/hide the color scale graphic of the Index Map that is displayed on the top right of the Index View.
View All: Zoom in and out, so that the full Reflectance Map or Index Map is displayed in the Index View.

Note: For information about the files that are generated, following which action and where they are stored: 202558739.

 

Toolbar

The following Toolbar buttons are displayed:

Standard toolbar: For more information: 202557839.
Toolbar extra buttons:
View:

 Zoom In: Zooms in the selected view.

 

https://support.pix4d.com/hc/en-us/articles/202558739


 Zoom Out: Zooms out the selected view.

 View All: Zooms in and out, so that the full Reflectance Map or Index Map is displayed in the Index View.

Reflectance map:

 

By default the Reflectance Map of the first band is displayed. The drop-down list gives the option to hide the Reflectance Map and select the Reflectance Map of a
different band. 

Index Map:

Index Map display Index Map not display

By default, the Show Index Map box is selected. This option controls whether the generated Index Map will be displayed and overlaid on top of the reflectance
map. 



Regions:

Regions locked Regions unlocked

By default the Lock Regions box is selected. After the regions are drawn: 203937289, they will be displayed in the Index View. If the Lock Regions box is
selected, the region frame will be locked in position. Unselect the Lock Regions box to enable the editing of previously drawn regions by dragging the whole
region or a single vertex.
 

Index View

When opening the Index Calculator for a project for the first time, it is blank. Once at least one Reflectance Map has been generated, it displays by default the
last Reflectance Map / Index Map that was displayed before the project was closed.

Navigating on the Index View using the mouse:

Pan: Right/Left click and move the mouse (a hand icon appears representing the focus point for the movement).
Zoom in: Move the scroll wheel forward while positioning the mouse over the Index View.
Zoom out: Move the scroll wheel backwards while positioning the mouse over the Index View.

 

Index Calculator sidebar

The sidebar displays information about the Reflectance Map(s) and the Index Map and provides tools to generate and edit the Index Maps.

For details about the Index Calculator Sidebar: 202558249.

Status bar

On the bottom right part of the main window, if a Reflectance Map / Index Map is loaded in the Index View, the following information is displayed:

Index Value: Displays the pixel value of the Index under the current mouse location. When passing the mouse over the Index View, the value changes.
Output Coordinate System: Displays the selected output coordinate system.
Coordinates: Displays the (X,Y) coordinates in meters / feet of each point of the Reflectance Map / Index Map. When passing the mouse over the Reflectance
Map / Index Map the coordinates change.

Note: Coordinates of both the areas covered by the Reflectance Map / Index Map and of the areas not covered are displayed.

Index > Interface > Menu View  Previous  |  Next  
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

The Index Calculator Sidebar contains the following sections:

1. Reflectance Map: Used to:
Generate the Reflectance Map(s) used to generate the indices. One Reflectance Map is generated per group of images (RGB, NIR, etc...).
Displays information about the Reflectance Map(s).
2. Regions: Used to:
Define specific areas that the index calculation will be applied to. 
3. Index Map: Used to:
Generate, view, edit indices or select the index to be displayed in the Index View.
Displays information about the selected index.
4. Color Maps and Prescription: Used to:
Classify the Index Map, based on the indices values.
5. Export: Used to:
Export the index values and prescription rates as polygon shapefiles.
Export the selected Index Map using the selected classes for the color mapping.
Upload the Reflectance Map on MicaSense Atlas platform.

 

https://support.pix4d.com/hc/en-us/articles/202558389


Note: 
One Reflectance Map is generated for each band of each group of images.
The Reflectance Maps contain the reflectance values of each pixel and are used to generate the Index Maps.
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.
If a Region is drawn, the Index Maps and Colored Index Maps will only be generated for this region.
Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.
If a Colored Index Map already exists, creating a new Colored Index Map will overwrite the existing one.

Important: 
For information about the files that are generated, under which action and where they are stored: 202558739.
All the outputs will be stored in: ...\project_name\4_index
For more information about the project folder structure: 202558649.

 

Index > Interface > Menu View > Index Calculator  Previous  |  Next  
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Index > Interface > Menu View > Index Calculator > Sidebar  Previous  |  Next  

 

Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.
 

On the left part of section 1. Reflectance Map, there is an arrow that allows the user to show/hide the section by clicking on it:

 By default section 1. Reflectance Map is visible.
 Section 1. Reflectance Map is not visible.

And the buttons

Generate: Generates the Reflectance Map if not generated.

Note: The Reflectance Map is generated based on the selected Processing Options: 203891879. For more information about the generated files and
where they are stored: 202558739.

Help: Opens the Pix4Dmapper help.

The section 1. Reflectance Map also displays information for each band of the generated Reflectance Map(s) for each group of images. The following information
is displayed:

Band: Name of the band. If more than one group exists and the same band name exists in different groups, the bands are displayed as "Groupname_band."
Min: Minimum pixel value per band.
Avg: Average pixel value per band.
Max: Maximum pixel value per band.
Stdev: Standard deviation of pixel values per band.
Var: Variance of pixel values per band.

If the Reflectance Map(s) are not generated, it displays: "Reflectance Map not yet generated."

Reflectance Map not generated Reflectance Map generated 

Note: 
One Reflectance Map is generated for each band of each group of images.
The Reflectance Maps contain the reflectance values of each pixel and are used to generate the Index Maps.
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.

 

 

 

https://support.pix4d.com/hc/en-us/articles/202558389
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

On the left part of section 2. Regions, there is an arrow that allows the user to show/hide the section by clicking on it:

 By default section 2. Regions is expanded and visible.
 Section 2. Regions is collapsed and hidden.

 

The following information is displayed:

Selected region: Allows the user to select the region you want to edit.
Draw: Allows the user to draw the selected region in the Index View.
Clear: Allows the user to clear the drawn region in the Index View. Enabled if the selected region is drawn.
Formula Status icon: Next to the button Clear appears:

 The region exists and is valid.

 The region has not been drawn or the drawn area is incorrect (its edges intersect). 

Regions...: Opens the Region List pop-up, which allows the user to manage the regions:
Add a new region.
Delete an existing region.
Edit the name of a region.
Display some properties of the region.
Import / export the regions.
Help: Opens the Pix4Dmapper help. 

Regions...

 

https://support.pix4d.com/hc/en-us/articles/202558389


When the button Region... is clicked, the following pop-up appears:  

It contains the section Regions:

Regions table: Contains the columns:
Region: Name of the region, by double clicking on it, it is possible to edit the name.
Area [units]: Surface covered by the region.
%: Percentage of the total area occupied by the region.
Import...: Allows to import regions from a .shp files.
Export...: Allows to export the regions to a .shp file.
Add: Creates a new region.
Remove: Deletes the selected region.

And the buttons:  

OK: Confirms the changes.
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

On the left part of section 3. Index Map, there is an arrow that allows the user to show/hide the section by clicking on it:

 By default section 3. Index Map is visible. 
 Section 3. Index Map is not visible.

An Index Map is a single band image where each pixel value is computed using a mathematical formula combining the band information of the Reflectance Maps. 

 

https://support.pix4d.com/hc/en-us/articles/202558389


The following information is displayed:

Name: List of available indices. The icon shown before the index name is:
 The index exists in the Pix4Dmapper index database. 

For more information about the Pix4Dmapper index database list: 202558379.
 The index was created / edited by the user in this project.
 The index was created / edited by the user in another project (on the same computer) that was closed and saved. 

Formula: Displays the formula associated with the selected index. 
Formula Status icon: Next to the Formula there is an icon:

 The formula is valid.

 The formula is incomplete or contains undefined band names.

Index Status icon: If next to the Generate button there is
 The index has been generated.

Edit...: Grayed out when the selected index belongs to the Pix4Dmapper database. Enabled when the selected index was created by the user. Opens the Index
Maps window that allows the user to edit the formula that corresponds to the selected index. 
For detailed information: 202558279.
Indices...: Opens up the Index List window which displays the existing indices and allows the user to add, edit, or remove indices. For detailed
information: 202558299.
Generate: Generates a single band GeoTiff image. Each pixel's value is computed by applying the formula to the corresponding pixel of the Reflectance Map(s). It
is grayed out if the user-defined index formula is not valid.
Help: Opens the Pix4Dmapper help.

Important: For more information about the generated files and where they are stored: 202558739.

The section 3. Index Map also displays information about the generated index band. The following information is displayed:

Band: The Index Map has only one band to be displayed (band1).
Min: Minimum pixel value.
Avg: Average pixel value.
Max: Maximum pixel value.
Stdev: Standard deviation of pixel values.
Var: Variance of pixel values.

If the selected index has not been generated, it displays: "Selected idex map not yet generated."

 

Index Map not generated  Index Map generated

Note: 
The Index Maps are calculated using some specific band(s) from one or more groups of images. Therefore, information from one or more Reflectance
Maps may be used.
If a Region/Regions drawn, the Index Maps and Colored Index Maps will be generated only for this region/regions.
Colored Index Maps are generated by applying the defined coloring rules to the Index Maps. They are raster files with RGB values.
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. In section 3. Index Map, click Edit to edit the selected index (available for user defined indices).

The Index Map pop-up is used to easily edit the formula associated to the user defined index. The name of the index that is edited is displayed in the window title.

It contains 3 sections:

Reflectance Map Band Selection
Operations
Formula

And 3 action buttons:

OK: Confirms the changes. 
Cancel: Does not save the changes.
Help: Opens the Pix4Dmapper help.

 

Reflectance Map Band Selection

Displays information for each band of each group of images of the generated Reflectance Map(s).The following information is displayed:

Band: Name of the band . If more than one group exists and the same band name exists in different groups, the bands are displayed as "Groupname_band."
nm: Wavelength of the band in nano-meters.
Min: Minimum pixel value per band.
Avg: Average pixel value per band.
Max: Maximum pixel value per band.
Stdev: Standard deviation of pixel values per band.
Var: Variance of pixel values per band.

By clicking a band button, the band name will be automatically inserted in the Formula text box at the current cursor position.

 

Operations

Buttons that allow the user to automatically  insert mathematical operations in the formula text box at the current cursor position.

The available operations are:

 



Symbol + - * / ^ ( )
Action addition subtraction multiplication division exponentiation open parenthesis close parenthesis

Symbol sqrt log sin cos tan asin acos atan
Action square root natural logarithm sine cosine tangent arcsine arcosine arctangent

 

Formula

 Text box to edit/write the formula associated to the index.

 Under the text box a message appears indicating the formula validation status:

Valid formula.
Undefined "band_name" band.
Incomplete formula.
Syntax error.

Important: The formulas' expression is case sensitive: it distinguishes between upper and lower case.
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. On section 3. Index Map, click Indices...

The section Indices contains the Index table:

Status: The first column displays a green check  if the index has been generated and is empty if the index has not been generated. 

Name: Displays:
An icon that shows if:

 The index exists in the Pix4Dmapper index database. 
For more information about the Pix4Dmapper index database list: 202558379.

 The index was created / edited by the user in this project.
 The index was created / edited by the user in another project (on the same computer) that was closed and saved. 

 

https://support.pix4d.com/hc/en-us/articles/202558379


The index name. 
Formula: Displays:
An icon that shows:

 If the formula is valid.

 If the formula is incomplete or contains undefined band names.

The formula. 

And the buttons:

Edit: Enabled for user defined indices. Opens the Index Map pop-up allowing the user to edit the currently selected index formula.
Duplicate: Duplicates the selected index with the name: selectedIndex_copy. The duplicated index will be user defined even if it is duplicating an index from the
Pix4Dmapper index database.
Add: Creates a new user defined index. Opens the Index Map pop-up to enter the new formula. By default, it adds it with the name: unnamed. If the name already
exists, it will be created with the name: unnamed2.
Remove: Enabled for user defined indices. Deletes the selected index.

Important: User defined indices created for a project will be available for other projects on the same computer. 

Available actions on the table:

Select an Index: By clicking on a cell, the row will be selected and depending on the type of index (from the Pix4Dmapper database or user defined) some
buttons will be available or grayed out (see above for more information).
Edit Index name: Available only for user defined indices. Double click on a user defined index name and edit it.
Edit Formula: Available only for user defined indices. Double click on a user defined formula expression and edit it.

Important: The formulas expression is case sensitive: it distinguishes between upper and lower case.

The Index List pop-up has as well the following action buttons:

OK: Closes the Index List pop-up and the marked index is selected in the Name of the 3. Index Map section of the Index Calculator Sidebar. 
Cancel: Closes the Index List pop-up without selecting an index.
Help: Opens the Pix4Dmapper Help.
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

On the left part of section 4. Color Maps and Prescription, there is an arrow that allows the user to show/hide the section by clicking on it:

 By default section 4. Color Maps and Prescription is expanded and visible.
 Section 4. Color Maps and Prescription is collapsed and hidden.

The following information is displayed:

Number of Classes: Number of classes to classify the model. The default value is 5, the minimum value 2 and the maximum value 32.
Method of classification: It is possible to classify the area (classify the pixels in intervals based on their index value and represent each interval using one class
and therefore one color) considering:
Equal Spacing: Selected by default, all classes have the same range.
Equal Area: All classes represents the same area in the model.
Jenks: Uses the Jenks natural breaks optimization method. For more information: Wikipedia.

Equal Spacing Equal Area Jenks

Use Min/Max:
Enter the minimum and maximum index values to ignore the values outside this range. 
Clamped: Displays the pixels that have an index value outside the selected range (Min/Max) with the color of the minimum or maximum selected index values. It
is selected by default. If not selected, the pixels that have an index value outside the selected range (Min/Max), will be displayed with transparency.

 

https://support.pix4d.com/hc/en-us/articles/202558389
https://en.wikipedia.org/wiki/Jenks_natural_breaks_optimization


Classes description: It displays the properties of the classes.
Color: Color used in the Index View to represent the class.
Min / Max: Index value range used for each class.
Area [units]:Surface covered by the class.
Area [%]: Percentage of the total area occupied by the region.
Colors Distribution: Contains the palettes that can be used for coloring the classes.
RdYlGn: Low values are red, medium values are yellow and high values are green, used for agriculture.
Thermal: Low values are blue, high values are red, used for temperature measurements.
Spectral: Uses all the colors of the visual spectrum, used when it is needed to distinguish many different values.
Grays: Uses a gray scale.
Blues: Uses a blue scale.
Reds: Uses a red scale.
Invert: Unselected by default, it allows to invert the selected colors' distribution.
Prescription...: It displays some classes' parameters and allows to set the application rate and add comments:
Color: Color used in the Index View to represent the class.
Area [units]: Surface covered by the class.
Area [%]: Percentage of the total area occupied by the region.
Rate: It allows to enter the application rate for each class. This rate value should be filled after the on-site scouting is done. The rate units depend on the tractor
software. For chemicals and fertilizer, it could be kg/hectare, grams/hectare, liter/hectare etc. For seeds, it could be seed/hectares.
Quantity: Area[units] x Rate.
Comment: It allows to add comments for each class. These descriptions could be notes from the on-site scouting.

 

Help: Opens the Pix4Dmapper help.
Index > Interface > Menu View > Index Calculator > Sidebar  Previous  |  Next  
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Access: On the Menu bar, click View > Index Calculator (available once step 1. Initial Processing has been completed). The Index Calculator sidebar is
displayed on the right of the main window. For information about the sidebar's display possibilities: 202558389.

On the left part of section 5. Export, there is an arrow that allows the user to show/hide the section by clicking on it:

 By default the 5. Export is expanded and visible.
 Section 5. Export is collapsed and hidden.

The following information is displayed:

Index Values and Rates as Polygon Shapefiles (.shp) with Grid Size [unit/grid]
Exports the classes as a .shp file (polygon and grid) based on the selected Processing Options: 203891879. One shapefile will be exported for each Region. This
file can be imported directly into the tractor's displays for field (fertilizer) application.

Colored Index Map GeoTIFF (.tif) and GeoJPG (.jpg)
Exports a Colored Index Map that is generated by applying the defined coloring rules to the Index Map. It is a raster file with RGB values. A single Colored Index
Map will be exported for all the regions in 3 formats: .jpg, .tiff and .kml.

 

https://support.pix4d.com/hc/en-us/articles/202558389


 Upload Reflectance Map to MicaSense Atlas
Uploads the necessary reflectance maps for further processing on the MicaSense Atlas platform.

Note: MicaSense Uploader needs to be installed on the computer in order to upload to MicaSense Atlas.

Index > Interface > Menu View > Index Calculator > Sidebar  Previous  |  Next  

 

 



Index > Interface > Menu View  Previous  |  Next  

 

Access: On the Menu bar, click View > Processing (enabled once a project has been loaded or created). The Processing bar is displayed at the bottom
of the main window. For information about the displayed bars: 202558389.

The Processing bar allows to process a project.

It contains 1 section:

Processing

It also contains 2 Progress bars:

Current
Total

and the buttons:

Output Status...: Opens the Output Status pop-up.
Start: Starts the processing of the selected processing steps.
Cancel: Cancels processing.
Help: Opens the Pix4Dmapper help.

 

Processing

The Processing section contains 3 subsections:

1. Initial Processing: Automatically extracts keypoints from the images to compute the internal and external camera parameters using the software's advanced
Automatic Aerial Triangulation (AAT) and Bundle Block Adjustment (BBA). A sparse 3D point cloud is computed and a low resolution DSM and Orthomosaic are
generated and displayed in the Quality Report. For more information about the files generated during the Initial Processing: 202558519.

Warning: When reprocessing this step, the existing outputs of step 1 are deleted and overwritten and outputs of steps 2 and 3 (if previously
completed) are deleted.

2. Point Cloud and Mesh: Generates a dense 3D point cloud and a 3D textured mesh. For more information about the files generated during the Point Cloud and
Mesh: 202558549.

Warning: When reprocessing this step, the existing outputs of step 2 are deleted and overwritten and outputs of step 3 (if previously completed) are
deleted.

3. DSM, Orthomosaic and Index: Generates the DSM, orthomosaic, reflectance map and index map. For more information about the files generated during the
DSM, Orthomosaic and Index: 202558559.

Warning: When reprocessing this step, the existing outputs of this step are deleted and overwritten.
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Current

It displays the processing status of each substep as a percentage.

Note: When the project is processing, information about the substep that is currently running is displayed in the Current bar.

Total

It displays the processing status of all steps of processing that have been selected as the number of completed substeps.

Note: When the project is processing, the processing steps (1, 2, 3) that have been selected are displayed in the Total bar.
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Access: On the Menu bar, click View > Log Output. The Log Output bar is displayed at the bottom of the main window. For information about the
displayed bars: 202558389.

The Log Output bar displays useful information about the processing of the project. It describes the steps and substeps of processing, the actions taken, the
warnings and the errors during the processing.     

Important: 
Pix4Dmapper exports the log file (project_name.log). It is stored at the output folder project_name. 
The log file displayed at the Log Output bar is cleared each time that Pix4Dmapper closes. The next time that the software will be opened, the log file will
start registering the different actions from scratch. 

It consists of the following:

Levels drop-down list: Allows to define the level of details of the log displayed on the main window.
Options drop-down list: Allows to set the displaying options for the log on the main window. 
Search Engine: Allows to search for specific text / numbers in the log displayed on the main window. 
Clear Log: Clears (deletes) the log displayed on the main window.
Main window: Displays the log. 
Help: It opens Pix4Dmapper Help.

 

Levels

There are the following levels of details:

[Info]: Displays general information that is printed in the log file. The text is displayed in black.

Example: It displays the used version of Pix4Dmapper: [Info]: Version = <2.2.15>.

[Warning]: Displays the processing warning messages that are printed in the log file. The text is displayed in yellow.

Example: [Warning]: Some geotags were invalid and therefore removed.

[Error]: Displays the processing error messages that are printed in the log file. The text is displayed in red.

Example: [Error]: Failed to open file <file_directory>!.

[Processing]: Displays the processing steps and substeps that are printed in the log file and their status. The text is displayed in green.

Example: [Processing]: Substep Camera calibration started.

[UI]: Displays the actions that the user does in the User Interface. The text is displayed in blue.

Example: It displays [UI]: Open Results Folder clicked, when the user clicks the button Open Results Folder...

 

Options

There are the following options:
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Full Headers: It displays the full headers (Date, Time, % RAM, % CPU).
Wrap Lines: It wraps the lines when the main window is too small.

 

Search Engine

It allows to search for specific keywords, characters of numbers. The results of the searching are displayed in the main window.

 

Clear Log

It clears (deletes) the log that is displayed in the main window.

Important: 
The log file stored at the output folder project_name will not be deleted.
The Clear Log action can not be retrieved. Once the log is deleted from the main window, there is no way to bring it back.

 

Main window

It displays the log. The displayed information depends on the selected Levels and Options. If a keyword, character or number is used in the Searching Engine, the
displayed log shows only the strings that contain these elements.
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Access: On the Menu bar, click Help.

The Help menu has 6 items that can be selected:

Help Contents: Opens Pix4Dmapper help for the current View.
Online Support: Opens the Online support site in a browser.
Community: Opens the Support site, displaying the Community index page.
Personal Support: Opens the Online form to submit a request to the Support Team in a browser.
Settings...: Opens the Settings window that gives the user access to the proxy and camera database settings.
About...: Provides information about the version, License, Terms of service, Privacy policy and third party licenses.

 

Help Contents

The Pix4Ddesktop help provides full and detailed information about the current View (Welcome, Map View, rayCloud, Volumes, Mosaic Editor, Index Calculator).

Online Support

Opens a browser pointing to the Support website, which contains numerous articles with step by step instructions, answers to frequently asked questions as well
as news, updates, tutorials, use cases, etc.

Community

The Community contains the following topics:

User Space: Place to share news or discuss the profession. 
Image Acquisition: Pix4Dcapture, flight plans, indoor mapping, drones, cameras, GPS,...
Processing: Desktop and Cloud: processing, troubleshooting, outputs, accuracy, computer hardware.
Hall of Fame: Place to share 3D Models, Orthomosaics, fly-through videos of projects.
Important Communication: Updates about software releases, Support material (articles, videos), workshops,...

Personal Support

Contact the dedicated support team for personal support.

 

https://support.pix4d.com/hc/en-us/community/topics
https://support.pix4d.com/hc/en-us/articles/200288349
https://support.pix4d.com/hc/en-us/articles/200278215
https://support.pix4d.com/hc/en-us/articles/200266979
https://support.pix4d.com/hc/en-us/articles/115000026483
https://support.pix4d.com/hc/en-us/articles/115000025126


 

Settings...

Opens the Settings pop-up that gives the user access to the proxy and camera database settings and the language selection. 

It has 4 Tabs:

Proxy
Camera Database 
Language
Help Improving the Software

And 3 action buttons:

OK: Confirm the changes.
Cancel: Exit without saving.
Help: Open the Pix4Dmapper help.

Proxy



This tab allows the user to configure the Internet connection.

The first drop down list allows the user to select how to connect to the proxy:

No Proxy (default): If no proxy server is used.
Use Systems Settings: Uses the system-wide settings.
Socks5
Http

The following fields are displayed:

Host: Proxy host name.
Port: Proxy port number.
Username: Proxy user name.
Password: Proxy password.

In order to enter the proxy settings: 202560089.

Camera Database
This tab allows the user to clear the user camera model database or to import/export it from/to a file. It also displays the built-in database that is used.

The camera database tab has 2 sections:

User database: This section has the following action buttons:
Clear: Clears the user camera model database (cameras added or modified by the user).
Import...: Loads a camera database file *.xml with cameras added or modified by the user.
Export...: Exports cameras added or modified by the user to a camera database file *.xml.
Built-in database: Displays the date and the version of the last built-in camera database update.

Language

https://support.pix4d.com/hc/en-us/articles/202560089


This tab allows the user to set up the language.

The following languages are available:
English - U.S. English (default)
German (Germany) - Deutsch (Deutschland)
Spanish (Spain) - español de España (España)
French (France) - français (France)
Italian (Italy) - Italiano (Italia)
Chinese (China) - 中文 (中囯)
Chinese (Taiwan) - 中文 (台灣)
Japanese (Japan) - 日本語 (日本)
Russian (Russia) - русский (Россия)

Help Improving the Software

 

About...

It provides information about the version, license type, license key, license account, Terms of Use, Privacy Policy and third party licenses.

License Type.
License Key.
License Account: Pix4D user account to which the license is bound.

https://pix4d.com/eula/
http://pix4d.com/privacy/
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Note: The Pix4D Desktop license is a floating license which allows the user to log out one device and log in another. It is not needed to uninstall Pix4D
Desktop to move the license.

Each Pix4D Desktop license can be activated on different number of devices:

 

Version

 

Pix4Dmapper Pix4Dag Pix4Dmodel Pix4Dbim Pix4Denterprise Pix4D

Discovery
Number of
devices

Two

A desktop for full
processing.

A laptop for rapid check
in the field.

One

 

 

One

 

 

Two

A desktop for full
processing.

A laptop for rapid check
in the field.

Custom

More information here.

Unlimited

 

For more information about how to download and install Pix4D Desktop: 202557299. 
For step by step instructions about how to Log out Pix4D Desktop: 208469726.
For step by step instructions about how to Log in Pix4D Desktop: 207948656.
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http://pix4d.com/product/enterprise-solutions/
https://support.pix4d.com/hc/en-us/articles/208469726
https://support.pix4d.com/hc/en-us/articles/207948656
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The following shortcuts are available:

General shortcuts
Basic GCP/MTP Editor shortcuts
Log output shortcuts
rayCloud shortcuts
Layers Sidebar
3D View
Right Sidebar
Volumes shortcuts
Mosaic Editor shortcuts
View
Right Sidebar
Index Calculator

General shortcuts

Category Action Shortcut Note
Pix4Dmapper Help Open the Pix4Dmapper help F1  
    
Project    New project Ctrl + N  

Open project Ctrl + 0  
Save project Ctrl + S Does not save the changes done in the Mosaic Editor
Save project as Ctrl + Shift + S  
Exit Ctrl + Q  

 

Basic GCP/Manual Tie Point Editor shortcuts

Category Action Shortcut Note
Preview Remove marked GCP in currently displayed image Del The mouse needs to hover over the image

Zoom out of the image as long as the key is pressed Shift The mouse needs to hover over the image
Zoom in the image as long as the key is pressed Alt The mouse needs to hover over the image

  

Log output shortcuts

Category Action Shortcut Note
View Open find bar Ctrl + F  

Close find bar Esc  

 

rayCloud shortcuts

Category Action ShortcutNote
Layers Sidebar
Tie Points >
GCPs/MTPs

Rename point F2 A point needs to be selected
Remove point Del A point needs to be selected

    
Processing Area Remove area Del An area needs to be selected
    
Objects Rename object F2 An object needs to be selected

Remove object Del An object needs to be selected
3D View
Viewpoints       View All C  

Focus on Selection F  
Top 7  
Front 1  
Back Ctrl + 1  
Left 3  
Right Ctrl + 3  
Home 0  

    
Navigation Modes Standard Ctrl + Y  

Trackball Ctrl + T  
First Person Ctrl + H  

    
Navigation Modes >
Standard           

Zoom in +  



Zoom in faster Ctrl +
"+"

 

Zoom out -  
Zoom out faster Ctrl + "-"  
Move forward parallel to the
ground plane

Arrow Up 

Move forward parallel to the
ground plane faster

Ctrl +
Arrow Up

 

Move backward parallel to
the ground plane

Arrow
Down

 

Move backward parallel to
the ground plane faster

Ctrl +
Arrow
Down

 

Move up Page Up  
Move up faster Ctrl +

Page Up
 

Move down Page
Down

 

Move down faster Ctrl +
Page
Down

 

Rotate view down 8  
Rotate view down faster Ctrl + 8  
Rotate view up 2  
Rotate view up faster Ctrl + 2  
Rotate view left 4  
Rotate view left faster Ctrl + 4  
Rotate view right 6  
Rotate view right faster Ctrl + 6  

 
Navigation Modes >
Trackball

Zoom in +  
Zoom in faster Ctrl +

"+"
 

Zoom out -  
Zoom out faster Ctrl + "-"  

 
Navigation Modes > First
Person

Move forward W
Arrow Up

 

Move backward S
Arrow
Down

 

Move left A
Arrow
Left

 

Move right D
Arrow
Right

 

Move up Page Up  
Move down Page

Down
 

Look up I  
Look down K  
Look left J  
Look right L  

    
Perspective/OrthographicSwitch between perspective

and orthographic projection
5  

 
Point cloud density Increase point density Alt + "+" Decreases the number of points visible (improves performance on slow computers)

Decrease point density Alt + "-" Increases the number of points visible (requires better computers)
 
Edit Densified Point
Cloud

Delete points Del Must be in Edit mode and points must be selected
Select all Ctrl + A Must be in Edit mode
Clear selection Ctrl + C Must be in Edit mode
Invert selection Ctrl + I Must be in Edit mode

Right Sidebar
Images section Focus on selection P The mouse needs to hover over the image or the image needs to be selected

Pop up and maximize
thumbnail

Space Maximizes the image under the mouse cursor. Pressing Space again docks the image again
keeping the new point of view. Pressing Escape docks the image and keep previous point of view.

 

Volumes shortcuts 

The shortcuts of the Processing Area and the Objects layers of the Layers section of the sidebar and the shortcuts of the 3D View are the same as in the
rayCloud: 202558059.



Mosaic Editor shortcuts

Insert Cell  Insert a new cell after having added the last vertex.InsThe insert Cell mode needs to be activated and the vertices need to be created / marked

CategoryAction ShortcutNote
View
View    Show

Mosaic
Ctrl + 1 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of

mosaics - 1. For example, if two mosaics are generated, the shortcut to display the second mosaic is Ctrl + 2
Show DSM Ctrl + 2 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of

mosaics - 1. For example, if two mosaics are generated, the shortcut to display the DSM is Ctrl + 3
Show
Region

Ctrl + 3 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
mosaics - 1. For example, if two mosaics are generated, the shortcut to display the regions is Ctrl + 4

Show Edited
Mosaic

Ctrl + 4 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
mosaics - 1. For example, if two mosaics are generated, the shortcut to display the edited mosaic is Ctrl + 5

Show
Mosaic Area

Ctrl + 5 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
mosaics - 1. For example, if two mosaics are generated, the shortcut to display the mosaic area is Ctrl + 6

Show
Mosaic Tiles

Ctrl + 6 If several mosaics are generated because of multiple image labels, the shortcut number is incremented by the number of
mosaics - 1. For example, if two mosaics are generated, the shortcut to display the mosaic tiles is Ctrl + 7

Right Sidebar
Right
Sidebar

Mosaic
Editing

1  

Visualization2  
Draw region F2 Start drawing a region. Like clicking on the Draw button
Finish
drawing
region

Right
Click

End drawing a region and insert it in the list

Cancel
region
drawing

Esc  

Index Calculator

Category Action Shortcut Note
View View the whole map C  

Delete the selected region or region vertex Del The region/region vertex must be selected and the option Lock Regions must be deselected
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